Cherokee SRT8 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
So today I was driving around as usual and shut my car off and went into a store. When I got back I opened my car sat down and closed the door. The seat then moved about 4 or 5 times half an inch in each direction I said to myself what the hell is this thing doing. I started her up and the airbag light went on started beeping, it said "service back up sensors", the sunroof wouldn't work and the scariest thing was when my RPM sensor was bouncing all over the place but he engine was not increasing RPM's!!!! What the heck is going on help!!!!!
 

·
Registered
Joined
·
635 Posts
Sounds like a charging issue i.e. the battery or battery and alternator. These things tend to FREAK OUT and do pretty bizarre things when the battery goes bad and isn't providing the correct voltage. Just my opinion...gotta start diagnostics somewhere!
 

·
Premium Member
Joined
·
16,354 Posts
Sounds like a charging issue i.e. the battery or battery and alternator. These things tend to FREAK OUT and do pretty bizarre things when the battery goes bad and isn't providing the correct voltage. Just my opinion...gotta start diagnostics somewhere!
Yeah, when the battery goes in these things, it messes with everything. Just knew someone with this issue, his lights were going wicked and dash lights flashing.
 

·
Registered
Joined
·
8,340 Posts
Yeah, definitely sounds like something is up with the battery.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #5
That actually sounds like it could be the problem because after a night of being off, when I go to start the truck it delays a few seconds before the engine fires up...I thought maybe it could be something else but since the whole computer system keeps bugging out the battery sounds like the culprit.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #6
Went to get the battery checked out today. The guy said the battery was fine and the alternator was running smoothly so i don't know what the heck is going on with this thing.
 

·
Registered
Joined
·
630 Posts
this only happened to me once, some how i thought my lights were on auto but they werent, bright summer couldnt tell...so the whole time they were on. Battery wanted to quit i guess...everything was going crazy...couldnt use auto start or sunroof...said my doors were open, and yea the airbag thing was beeping. quick jump let the alt charge it back up and it was fine ever since.
 
1 - 7 of 7 Posts
Top