Cherokee SRT8 Forum banner
1 - 20 of 26 Posts

·
Registered
Joined
·
445 Posts
Discussion Starter · #1 ·
I installed the 6k type 2 switchbacks today with 6 ohm 50 w resistors...the turn signal (amber) works fine and blinks perfect..the problem is with the parking lights..they don't come on at all..fo the running lights have anything to do with resistor type? I thought they only control the blinker
 

·
Registered
Joined
·
665 Posts
Did you change the marker light bulb? That help mine work
 

·
Registered
Joined
·
445 Posts
Discussion Starter · #3 ·
Its the white parking lights that don't come on...now I can run my fogs /headlights without parking lights on..it actually looks kinda nice but would like to figure this out. Any help is appreciated
 

·
Registered
Joined
·
665 Posts
Its the white parking lights that don't come on...now I can run my fogs /headlights without parking lights on..it actually looks kinda nice but would like to figure this out. Any help is appreciated
I understand that . For some reason if you left the stock bulbs in the sidemarkers they put out the wrong voltage and makes things work funny . Try changing them to a led bulb
 
  • Like
Reactions: dsalogia

·
Premium Member
Joined
·
7,299 Posts
Yes, if the resistor is incorrect it will effect the running light operation as well. I would try a 3 ohm resistor.

All the jeeps I have worked on have either 3ohm or 1.5ohm resistors with the switchbacks.

As mentioned, sometimes you also need a LED in the side marker (behind the amber)......but it isn't always necessary.
 

·
Registered
Joined
·
445 Posts
Discussion Starter · #6 ·
Ok.I love this forum bc of the quick answers..u guys are great. Would u try 3ohm resistors first or led side markers?
 

·
Premium Member
Joined
·
7,299 Posts
With them not turning on, I would personally try the 3ohm first.

The side marker LED has fixed when mine would first flicker amber then go to white when I turned mine on. But, other jeeps work fine with a halogen in the side marker.

Kind of hit or miss as to what works on certain jeeps.
 

·
Registered
Joined
·
665 Posts
I have 3ohm and Led's in the corners never tried it before with the stock corner just put them in after reading all the post .
 

·
Registered
Joined
·
445 Posts
Discussion Starter · #9 ·
With them not turning on, I would personally try the 3ohm first.

The side marker LED has fixed when mine would first flicker amber then go to white when I turned mine on. But, other jeeps work fine with a halogen in the side marker.

Kind of hit or miss as to what works on certain jeeps.
My white don't come on at all so I will try the 3 ohm first
 

·
Premium Member
Joined
·
16,346 Posts
That's weird that this thread was brought up. Just last night, I was following my girlfriend and she said when my blinker was on, it turner go white to amber like it usually did, just amber. Seeing this thread, I went outside to check for myself...

Both up front will only turn amber. All these lighting issues I am having lately is giving me a big headache....
 

·
Registered
Joined
·
445 Posts
Discussion Starter · #11 ·
UPDATE: vled customer service email states I need 2 3ohm resistors per side..one for the turn and one for parking light making it 1.5 ohm? This sounds dumb..is this correct..I need to buy 2 pairs of 3 ohm?
 

·
Premium Member
Joined
·
7,299 Posts
Some need 1.5ohm. Some need 3ohm. Of course, on the ones that 3ohm worked, I didn't try a 1.5ohm to see if that also worked.

I have only ever hooked them to the turn signal wire, never to the parking light circuit.


But yes, you can wire two of the 3 ohms to give you 1.5ohms of resistance. I just use 1.5ohm resistors though.
 

·
Registered
Joined
·
665 Posts
UPDATE: vled customer service email states I need 2 3ohm resistors per side..one for the turn and one for parking light making it 1.5 ohm? This sounds dumb..is this correct..I need to buy 2 pairs of 3 ohm?
I think it's cause they don't sell or list 1.5 ohm ones only 3&6 . they sold me 3ohm's
 

·
Registered
Joined
·
445 Posts
Discussion Starter · #14 ·
After I install the 3 ohm, if it doesn't work I'm leaving the 6 ohm in and won't have a prkin light..I like the look anyway
 

·
Premium Member
Joined
·
1,043 Posts
After I install the 3 ohm, if it doesn't work I'm leaving the 6 ohm in and won't have a prkin light..I like the look anyway
Here is a link to a general diagram that I have posted on my website for the switchback installation. My SRT8 required the two 3 ohm resistors wired in parallel to achieve 1.5 ohms. At that point, the white running lamp illuminated as designed and switched to amber when the turn signal was activated. Hope this helps :D

 

·
Registered
Joined
·
665 Posts
OK I just did my friends 07 the wire is the green one and I only used a 3 ohm without changing the side marker and it work like it should . Double up the 6 ohm's you have and see if that works .
 

·
Registered
Joined
·
665 Posts
After I install the 3 ohm, if it doesn't work I'm leaving the 6 ohm in and won't have a prkin light..I like the look anyway
Any update ??
 
1 - 20 of 26 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top