Cherokee SRT8 Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
My truck should be featured in the newest installment of The Exorcist!! About once a week the airbag warning light goes on and turns on and off periodically while the truck is on but that isn't it. The seat starts moving by itself, sunroof won't work, RPM needle starts bouncing all over, check engine light comes on, headlights flicker, "service park assist" comes on, YOU NAME IT! The truck drives fine but when this occurs it makes me nervous to say the least. Took it to my mechanic he thinks its one of the vehicle's BUS's thats screwed up or a relay. Took it to Jeep and they have had my truck for two days and STILL can't figure out what is wrong with it!! Any thoughts?
 

· Premium Member
Joined
·
17,169 Posts
You ever remove your rear seat? There's a "brain box" under there that control a bunch of crap. Did the dealer get any U codes? They're connection codes for the different "brain boxes" in the vehicle. My guess is there's a loose connection or a chaffed wire somewhere. Good luck homey.
 

· "guy with the crazy Jeep"
Joined
·
4,868 Posts
You ever remove your rear seat? There's a "brain box" under there that control a bunch of crap. Did the dealer get any U codes? They're connection codes for the different "brain boxes" in the vehicle. My guess is there's a loose connection or a chaffed wire somewhere. Good luck homey.
That's where the FDCM sits.

For the people that take their seats out at the track it is very easy to hit this modual. I think Keoni (AKA Stud Muffin) had a issue with this too.

I think Stage 6 needs to fab up some sort of aluminum skid plate that protects this modual. Seriously!! :thinkerg:
 

· Registered
Joined
·
45 Posts
Discussion Starter · #5 ·
You ever remove your rear seat? There's a "brain box" under there that control a bunch of crap. Did the dealer get any U codes? They're connection codes for the different "brain boxes" in the vehicle. My guess is there's a loose connection or a chaffed wire somewhere. Good luck homey.
I replaced the battery about a month ago but the problems still persisted. BUT the person who owned the truck before me did have a monster sound system put in the car. When I bought it the speakers were removed but all the custom wiring was still there so maybe he did remove the rear seats for the installation. I'll definitely let Jeep know about that
 

· Registered
Joined
·
45 Posts
Discussion Starter · #6 ·
Got it back from Jeep today, they didn't find what was wrong BUT they did find a faulty sensor for the check engine light. Hopefully this was the problem if not... i'll just keep doing this:huh::huh:
 

· Premium Member
Joined
·
1,071 Posts
With a vehicle of that age, I would start by taking all the bolted ground leads loose and clean everything well and reconnect.
 
1 - 8 of 8 Posts
Top