Cherokee SRT8 Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
340 Posts
Discussion Starter · #1 ·
Here is what's happening to me. When the engine is on, not moving, I am getting a grinding/ticking noise on and off every few seconds. Sounds like either the transfer case motor or starter are engaging every few seconds. When I shift to drive, seems like my transfer case is binding at low speeds. When I try to turn and very low speeds, get a loud grinding noise. Seems to lurch forward. There is def hesitation at all speeds

I did put on new snow tires a few months ago. Running the Blizzak DM-V1 P275-45-20 on all fours. Could this be it? I doubt it since it's making noise when the Jeep is sitting

Anyone think my transfer case has gone bad? Ideas on things i can try. How do I disconnect the transfer case motor?

Not sure what to do at this point. Dont really feel like getting raped by the dealer
 

·
Premium Whore (Lifetime)
Joined
·
3,065 Posts
Here is what's happening to me. When the engine is on, not moving, I am getting a grinding/ticking noise on and off every few seconds. Sounds like either the transfer case motor or starter are engaging every few seconds. When I shift to drive, seems like my transfer case is binding at low speeds. When I try to turn and very low speeds, get a loud grinding noise. Seems to lurch forward. There is def hesitation at all speeds

I did put on new snow tires a few months ago. Running the Blizzak DM-V1 P275-45-20 on all fours. Could this be it? I doubt it since it's making noise when the Jeep is sitting

Anyone think my transfer case has gone bad? Ideas on things i can try. How do I disconnect the transfer case motor?

Not sure what to do at this point. Dont really feel like getting raped by the dealer

If its grinding when you are not moving, that rules out the transfer case for that peticular problem. The transfer case doesn't turn when the truck is parked idling. Could be the flex plate, or something in the driveline before the output shaft in the transmission.

The binding while turning and driving sounds like a transfer case problem. Have you tried changing the transfer case fluid?
 

·
Registered
Joined
·
340 Posts
Discussion Starter · #3 ·
It's hard to describe the noise when sitting still. It's not so much of a grinding noise. My wife compares it to an old telephone ringning. Haha. Could it be the starter is stuck and keeps engaging?

I have not changed the fluid yet. Ordered it a few days ago and waiting for it to arrive.
 

·
Registered
Joined
·
802 Posts
Whereabouts is the noise coming from? Right underneath you? Engine bay? Towards the rear? Left side? Right side?

What are your mods out of curiosity?

My rear hatch glass used to shake/vibrate every once in a while, especially once I started messing with the exhaust. Sounded crazy; metal-on-glass kind of jingle sound. Replaced the weather stripping, fixed. It's sweet when some crazy sound is a simple and cheap fix!

Get the T-Case fluid changed and drive it around for a day or two. You take off the motor by unscrewing the four screws that are laid out in an X pattern. I'd throw it in Dyno Mode via Predator/Trinity/inTune if you plan on driving it like that for any period of time.
 

·
Registered
Joined
·
340 Posts
Discussion Starter · #5 · (Edited)
Whereabouts is the noise coming from? Right underneath you? Engine bay? Towards the rear? Left side? Right side?

What are your mods out of curiosity?

My rear hatch glass used to shake/vibrate every once in a while, especially once I started messing with the exhaust. Sounded crazy; metal-on-glass kind of jingle sound. Replaced the weather stripping, fixed. It's sweet when some crazy sound is a simple and cheap fix!

Get the T-Case fluid changed and drive it around for a day or two. You take off the motor by unscrewing the four screws that are laid out in an X pattern. I'd throw it in Dyno Mode via Predator/Trinity/inTune if you plan on driving it like that for any period of time.

The noise is coming from directly underneath the front seats. I know for sure it isn't a rattle of any kind. It's def binding at low speeds. When i turn at low speeds (10 & under), it binds and lurches forward a bit.

I went back to stock rims with the toyo 275/315 setup. Problem actually has seemed to have gotten worse.\

Dont really have much for mods right now.....basically a catch can and CAI.

Transfer case fluid was changed about 30k miles ago. Still waiting on the new fluid to arrive.
 

·
Registered
Joined
·
5 Posts
transfer case

I'm having same issue noise, is there for a few seconds goes away and then back.
my cluster showed a warning sign saying "check 4x4 system" or something close to that.
brought it to my mechanic and scanned it and said "clutch slipping and 4x4 overuse"
Can it be the transfer case actuator is the problem here when put on the lift the actuator was piping hot?
Transmission fluid was changed 2 weeks ago.

I've read a few with the same problem where any resolved?
I think the Guru's can help Frankofiore and me here.

Thanks
 

·
Registered
Joined
·
340 Posts
Discussion Starter · #7 ·
I'm having same issue noise, is there for a few seconds goes away and then back.
my cluster showed a warning sign saying "check 4x4 system" or something close to that.
brought it to my mechanic and scanned it and said "clutch slipping and 4x4 overuse"
Can it be the transfer case actuator is the problem here when put on the lift the actuator was piping hot?
Transmission fluid was changed 2 weeks ago.

I've read a few with the same problem where any resolved?
I think the Guru's can help Frankofiore and me here.

Thanks
No dash lights have come on for me yet. Seems like we either need our Transfer Case replaced or rebuilt.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top