Cherokee SRT8 Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter · #1 · (Edited)
First would like to say I am really happy and enjoying this awesome car. I am able to accept she is not perfect, but still feel I am having to many little issues. I was not able to deal with the local stealerships (wanted over list price) so the car was purchased and delivered unseen from a dealer 200 miles away.

Having so much noise and clunks when the car changes into gears. It is real evident at low speed coming out of park or reverse but seems to be all the time. I also am getting a whining/whistling noise on deceleration and the highway. Guess it is a bad rear end.

Something is up with the alignment. I seem to be always correcting the steering wheel because the car is going off track. I have had very aggressive suspension setups in my past cars but never encountered tracking like this.

Noise and vibration from steering wheel but feel that it is probably a result of the Scorpions. Not impressed at all with this tire.

Front and rear doors are off alignment. The front doors seam is about an 1/8 further out then the back door. Also the chrome piece does not match up at all, looks like they put it on backwards.

Chrome piece on the trunk deck is loose and moves around.

I have black and seems like not all parts on the car are exactly same color. My body shop noticed it and you can tell different parts were painted at different times. Possibly a good buffing can fix that but we will see.

Had a green fluid splattered all over the engine bay. Don't know if it had to do with prep, or there lack of. At first thought it was something leaking but never came back after I cleaned it.

I know some may be nitpicking, but I think things should be a little better with a 60 grand vehicle. I like to modify my cars so a little worried about compromising my warranty if going to be plagued with problems. Also worried some of these imperfections may come back to haunt me if and when I sell the car.
 

·
Registered
Joined
·
405 Posts
i've also noticed the clunking when changing gears. curious what it is. very noticeable when changing from rev to drive. but also noticed it if i downshift while out driving.
 

·
Premium Member
Joined
·
1,062 Posts
What green fluid would there be in the vehicle?

Thankfully we have had none of those issues with our 2010. Just the quirky remote lock/unlock issue from time to time.
 

·
Registered
Joined
·
300 Posts
I had this issue with the gears in the past and it reared it ugly face the other day and slammed hard on an up shift at low rpm when I goosed it. I had trans case fluid or some kind of "case" fluid changed a while back and that seemed to help a little. Obviously not a permanent fix however. Mine is also an '06 tho.

I'm going to guess, and maybe put your mind at ease, and say the green stuff was a mixture of prep substances used when your vehicle was repainted.
 

·
Premium Member
Joined
·
714 Posts
I posted an earlier comment, but just saw the WK2 thread. Was this a demo model? How many miles were on the odometer when you got it?
 

·
Speed Junkie
Joined
·
483 Posts
Could the noise your hearing on decel possibly be the Eco mode? It whines. Why would you take delivery or proceed with sale with the "alignment" problems? Did you test drive? Or look at it any?

I have no issues with mine.
 

·
Speed Junkie
Joined
·
483 Posts
man a lot of problems with theses wk2's not a good sign. hopefully its just the first year bugs
For the most part there are no problems only a few with a small number of units completely normal with any brand.
 

·
Registered
Joined
·
69 Posts
Discussion Starter · #9 ·
No it was not a demo unit but had mileage on it because it was dealer traded and driven 200 miles to be delivered to me. Unfortunately it was impossible for me to go and pick it up so the salesman drove it down. I took a chance and bought this particular one sight unseen, so yes took delivery without driving and seeing this one. I just figured it was new so I should be ok.

I don't think it is eco mode, but I guess never thought to associate the two. Thanks and will look into that. I just hear the farting noise it makes in eco mode and that throws me off.

I will be making a trip to the dealer sometime this week and hopefully get it resolved.
 

·
Premium Member
Joined
·
714 Posts
No it was not a demo unit but had mileage on it because it was dealer traded and driven 200 miles to be delivered to me. Unfortunately it was impossible for me to go and pick it up so the salesman drove it down. I took a chance and bought this particular one sight unseen, so yes took delivery without driving and seeing this one. I just figured it was new so I should be ok.

I don't think it is eco mode, but I guess never thought to associate the two. Thanks and will look into that. I just hear the farting noise it makes in eco mode and that throws me off.

I will be making a trip to the dealer sometime this week and hopefully get it resolved.
Yeah, buying new you would expect it to have no issues, even if it was sight unseen. Good luck at the dealer and I hope everything works out. Wes
 

·
Registered
Joined
·
425 Posts
No it was not a demo unit but had mileage on it because it was dealer traded and driven 200 miles to be delivered to me. Unfortunately it was impossible for me to go and pick it up so the salesman drove it down. I took a chance and bought this particular one sight unseen, so yes took delivery without driving and seeing this one. I just figured it was new so I should be ok.

I don't think it is eco mode, but I guess never thought to associate the two. Thanks and will look into that. I just hear the farting noise it makes in eco mode and that throws me off.

I will be making a trip to the dealer sometime this week and hopefully get it resolved.
"Farting" noise in Eco-mode?......I get a booming noise in Eco-mode......maybe someone put a whoopie cushion in your engine bay.:)

Seriously, though, I have other similar problems too, such as loose rear chrome trim, and door panels not being properly aligned.

Hey, even for $60K, we have to remember this is still a Chrysler.:rolleyes:
 

·
Registered
Joined
·
6,204 Posts
That farting noise is normal for the MDS.

I had a 5.7 WK1 with the MDS and that was the normal sound under operation. I had a CMR tune on that Jeep as well and I had the tuner shut MDS off. Once tuning is cracked I'm sure they can do the same for the 6.4.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top