Cherokee SRT8 Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
138 Posts
Discussion Starter · #1 ·
As the title states, I'm experiencing a hesitation from the driveline when I launch and it only just started doing it. I decided to test my 0-60, as you do, using the motion start on my Trinity. I'll try and explain it as simple as I can.

From a standing start I punch it and for a split second it takes off, but almost instantly it hesitates like its sort of freewheeling or trying to decide what it wants to do then it chirps the tires and off she goes.

Before this phenomenon, I was doing consistent 3.57sec 0-60 times. Tonight I couldn't better a 3.96sec. Before tonight it would just take off without any hesitation and cleanly rip a 3.57 0-60. I have a BB stage II VB, vortech v3, borla S, and an unopened engine. I should also mention I always leave the TC on.

Can anyone suggest any ideas what might be causing this? Is it the transfer case/motor?

Appreciate any help
 

·
Registered
Joined
·
11,229 Posts
Sounds like you need a CMR tune to me :)

Ops sorry just saw your mods , wow strange , check your silicone hoses etc , make sure everything is nice and tight .
 

·
Premium Member
Joined
·
17,169 Posts
Is your TC light flashing? Sounds to me like the traction control is kicking in killing the power.
 

·
Registered
Joined
·
1,156 Posts
+1 on ATC kicking in ... have you tried pressing the Traction Control button " off " and launching ?
 

·
Registered
Joined
·
138 Posts
Discussion Starter · #5 ·
Hi Harrison, I'll check if the traction light is coming on. Johan did the tune and we did I think 6 or 7 revisions. Not sure what could be creating the hesitation as I also tried to launch it with the traction control off and it did the same thing. With traction on i posted a 4.24sec 0-60 and with it off I recorded a 3.96. So I'm a bit confused what the issue could be. I'll check everything is nice and tight when I go back into the garage.

Thought i'd ask a quick question now that it comes to mind. I fitted the Borla S myself only yesterday. Went in with no problems, fairly easy mod to do. Would there be any wiring up there that may be causing the transfer case motor to not engage properly? It could just be coincidental that this issue has risen now just after I fitted the exhaust. Thanks for chiming in anyway.
 

·
Registered
Joined
·
11,229 Posts
Did you by any chance mess around with your O2 sensors ? Just a thought .
 

·
Registered
Joined
·
138 Posts
Discussion Starter · #8 ·
So the hesitation is still there. Does switching off the traction control intefere at all with getting power to the ground? Should I contact Johan and get him to look at the tune? I hope any of the guys with big horsepower can chime in with what happens when they switch off the tc button. What about pulling the abs fuse? Will that kill the tc system completley?
 

·
Registered
Joined
·
802 Posts
Traction Controll off enables more power to be sent to the front wheels sooner. When I turn it off it gives a more confident launch.

Have you tried going back to your last tune (tune 5 of 6 or 6 of 7)? I would log and have Johan give it a once-over. It will at least eliminate the possibility of it being the tune.

When you get on it and it takes off, then pauses, does it cause you to lunge forward violently and then it chirps once it hooks up again?
 

·
Registered
Joined
·
138 Posts
Discussion Starter · #10 ·
Globewarmer, thanks for the reply. Its really weird. I'm wondering what it could be that would warrant looking at the tune but I'll do it anyway.

Yes, as you explained, it all happens within the first 2 or 3 seconds from a launch. I think you are right on the money how you explained what is happening. If it wasn't doing it before it must be something in the tune as you suggest. I remember when we fitted the Vortech and dyno tuned it we drove around the streets absolutely tearing up the roads.

We had a blast and I couldn't believe how this truck just shot out of the hole. No hesitation back then, just some wheel spin and off we go.

Also, will Johan know in the log if the transfer case motor is playing up?
 

·
Registered
Joined
·
138 Posts
Discussion Starter · #11 ·
Community service announcement!!!!

Well, thought i would let you know I just solved the problem of the hesitation. NOT ENOUGH TRANS FLUID!!!! Can you effing believe it? When I put the new valve body in the mechanic who installed it said the fluid level was right. WELL OBVIOUSLY IT WASN’T. I said to him probably on three or four occasions “make sure the level is spot on cause these things are super sensitive”. I don’t use this guy for high performance stuff, but he’s a good guy.

I took it to my regular speed freak today who is a professional drag racer and runs a speed shop. He was the one who installed my Vortech. First thing he said? Check the trans fluid level. And he was ****ing right.

We put in half a liter and it solved the problem instantly. This thing rips from standing start like a mofo.

Let this be a lesson to all of us, CHECK YOUR TRANNY FLUID LEVELS......lol......
 

·
Registered
Joined
·
1,750 Posts
Wow. Hopefully no damage was done in the mean time!

Thanks for the update. Nothing worse than to see these problem threads that go for a long time and then just end with no result.
 

·
Registered
Joined
·
138 Posts
Discussion Starter · #13 ·
Wow. Hopefully no damage was done in the mean time!

Thanks for the update. Nothing worse than to see these problem threads that go for a long time and then just end with no result.
I hope so too. Although i didn't beat on it because of this reason. I pretty much nursed it as it is my dd. Other than this problem the tranny behaved normally and it shifts very nicely so I hope it will hold up for a while.

I'm glad I found the problem. I was ready to pull the trigger on a new converter. Of course, with 500whp the inevitable will happen. This is a stock trans so the end result will be an upgrade to a beefier trans. Probably sooner rather than later cause I just ordered a 30 tooth pulley from Skip!

Thanks for the support.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top