Cherokee SRT8 Forum banner

Status
Not open for further replies.
1 - 20 of 186 Posts

·
Administrator
Joined
·
565 Posts
Discussion Starter #1

SRT Engineers Chat Session - 13 Jan 2010, 6:00 pm - 8:00pm EST

This thread will be opened prior to the chat to allow questions to be asked in advance.

Participant Guidelines:
  • Keep all questions on topic and related to the SRT lineup of vehicles (off-topic posts will be removed)
  • Direct ALL questions to the SRT Team AND allow the SRT Team to answer ALL questions (no member-to-member replies)
  • Before you post a question, review existing posts to avoid repeats
  • Limit each post to 1 or 2 questions and be as brief and clear as possible, including the SRT model your question references
  • Allow time for a response - questions are not answered in order of post. If it appears you were missed, AND the same question was not previously answered for someone else, you may re-post before the session ends
  • The SRT Team cannot answer questions about future product, PLEASE do NOT ask

.
 

·
Registered
Joined
·
1 Posts
Couple quick non cherokee questions, I own a 08 caliber srt4 with the mopar stage 1.

-This one has been ran into the ground but does anyone know the final production numbers of the caliber srt4? If not is there someone who we could contact?

-Also, when switching gears and when coasting going back to accelerating,, I get a loud thunk/clunk sound, a other forum members have experienced this and just wrote it off as the clutch, is this something else? do you happen to know what is this caused by and/or what could be done to lessen it?

-and if I can squeak a third question in: Is the SRT engineering group planning on attending any events this year? ...Such as the lx and beyond nationals or SRT4 nationals?

-Thanks for taking the time to do this. We greatly appreciate it.
 

·
Registered
Joined
·
4 Posts
On the RAM SRT-10, the 2004 came with different calipers than the 2005's and 2006's. What was the reason for the change

Thanks You
 

·
Registered
Joined
·
21 Posts
wassup SRT!!!!

i have an 08 caliber srt4.

Some of the owners, including myself, have noticed an issue with cold starting the car.

When i first take off in cold mornings the car bucks violently and will most likely turn off. its as if i had bad clutch/throttle modulation.

after it turns off, when i restart the car the problem is gone
It has happened maybe 10 or so times to me lately.

here's a link to some of us chatting about this issue.
http://www.caliberforums.com/forums/showthread.php?t=16305&highlight=cold+start

do you have any insite or info you could give us that would help out with this issue?

maybe a stuck throttle??? pcm is freakin out??? spark plugs???

thanks for the help SRT a.k.a. my dream job fillers!:D
 

·
Registered
Joined
·
1 Posts
First off, I’m an owner of two SRT vehicles, and I love both cars (Caliber and Challenger). I love the level of performance detail that go into SRT vehicles. So keep up the good work guys!

First question: I like many others with manual 6 speeds in the Challenger have experienced severe wheel hop after a few miles have been put on the car that did not exist when it was new. I fully realize why the wheel hop is happening on take off in first and I can manage it by feathering the clutch/acceleration but it is still quite a challenge to do so. My bigger concern is the amount of hop I get from 1st to 2nd. Is there anything that can be done to solve this issue in regards to aftermarket or other Mopar products? Its hard to break the fast shifting habits from previous and current 6 speeds (from first to second) I have and something that I quite honestly don’t want to change. In the challenger forum we have created a poll that gives a percentage of 6 speed owners that have had this issue and I would hope the SRT engineers would please look it over when you have a chance to see the results:

http://www.challengertalk.com/forums/f79/got-hop-not-post-your-results-here-31248/

Second question, like others I have started noticing a whine from the rear end after getting wheel hop that is noticeable when decelerating from 50-60 mph. I have heard that some dealerships are getting responses from Chrysler that this is normal and not a concern. In the past this type of sound usually meant the ring and pinion was going out. I would be very grateful to hear your opinion and a course of action.

Best regards and thanks for the opportunity to ask these questions directly to the SRT engineers.
 

·
Registered
Joined
·
21 Posts
asking this for many of my csrt owning peers....

do u recomend using a catch can on the csrt???

some of us who have had them installed say they catch a fair amount of blow by while others say its very lil.

what is your guys' proffessional opinion on using them or not and why?
 

·
Straight Up Beast SON!!!
Joined
·
17,143 Posts
First of all I wanted to Thank you guys for taking the time to answer on questions related to the SRT line!

1. My question is have you guys looked into the vibration issue at 70 MPH? Basically I have replaced 2 wheels in the front, multiple alignments, 2 sets of front Good year Tires, 3rd set on Toyos Proxe STII's, New front rotors, 2 outer tie rods and have replaced the rear drive shaft twice now. The vibration problem still exists at 70 MPH and has improved since I have done everything but I feel that it is only a band aid fix. My jeep has been to the dealer about 12 to 15 times for this issues and out of the 2 times it has been there for a period of 2 weeks at a time. Also when driving the jeep at 70 MPH or greater I notice that the passenger seat headrest shakes and the floor as well on the passenger side and I feel it on my floor as well (very little). So what can you recommend the Techs at the dealer check next? Also I have noticed that when the problem is present and I put the Jeep in Nuetral that the problem still exists. I thought that by doing this that the drive train is totally disengaged which leaves the tires and wheels, but they have been replaced already. I also have had the tires Road forced balanced twice since I bought the tires about a month ago and all tires are at 6 lb of Roadforced and have been balanced properly, which I myself have watched the guys with my own 2 eyes do. Currently I have 13600 miles on my Jeep and it has been doing it since 6200 miles when I bought it. As a side note I have looked on other forums and have noticed that Porchses, Mercedes, and Infiniti SUV's are having the same vibration issue so what could be the common denominator here. Are the AWD drive trains that sensative to vibration? Because I know that Porcshe will only install Michellin tires that will produce a real low Roadforce number from what they say due to high sensivtive drive trains.. So any suggestions that you may have would really be appreciated guys as I have spent a lot of money and time trying to figure this out!

2. Next I would like to know if the Gauage clusters for the 2008 Jeep SRT 8 and the 2009 Jeep SRT 8 have the same pin outs and same amount of connectors? Because I was thinking of swapping mine out so that I can have the performance gauges in the dash like the 09's or 10's do. Plus I believe the mileage would stay the same as it is stored in the PCM somewhere as non volitale memory.

Thanks guys!
 

·
Registered
Joined
·
6 Posts
First I want to thank you for taking the time to answer our questions on these forums. I own a 2009 6-speed Challenger SRT, which like most of the 6-speed cars suffers from severe wheel-hop. I know this issue has been talked about in your other chat sessions, where the SRT engineers gave several different responses. What I would like to know is if you guys are working on a fix for this problem that will be available for all the people who already own these cars and are very unhappy about the wheel hop? I love everything else about the car, but to be honest, the wheel hop takes a lot of the enjoyment out of driving this car.
 

·
Premium Member
Joined
·
596 Posts
This is for a jeep SRT8

It just started the other day. It has been cold here about 20 to 40 degrees. After I leave work, its been sitting for at least 12 hours, I pull out of a parking lot and take a right hand turn and come to a stop light in about 100 feet. Wait about a minute for the light to change then take a left hand turn. As I take off the tranny starts to slip, goes to about 2500 rpms, I let off the gas alittle to stop the slipping and because I am turning, then give it a little more gas, still a little slipping but not as much, shifts into second, third, back to second then back to third then I and off to 30 mph the speed limit. It shifts slow then hard into gear then feels like it is floating trying to find which gear it wants. I have replacated this twice now, but I tried it this morning leaving my house and it did not happen. When I leave my house I am going straight not turning. It only seems to happen when its freezing and when I turn left??? Besides this the tranny dosen't act funny or shift bad. Its been to the dealer and no codes. I'm wondering if it just because of the short first gear in these vehicle, and my feathering of the gas. If it is not slipping it is still searching to find the right gear. It runs much better in autostick.

My dealer told me there is a fix for the exhaust rattle I have. Mine happens when I take a uturn and give it gas to where it dosen't down shift and loads up the motor and drivetrain. They said it is some kind of bolt that is rubbing. Can you enlighten me?
 

·
Registered
Joined
·
1,111 Posts
It would mean a ton to us cherokee owners if you could really examine the question in post #9. More than 90% of us have it. The techs at the 2 dealers Ive had look at it have no idea what to do- and ask me to road force balance the wheels and charge me 1-1 1/2 hrs shop time to do it. They wont look at the drive shaft in my case and when I tell them it has been road forced balanced - I get a shrug. A very frustrating issue on an otherwise beautiful machine.

Refer to post #61
 

·
Registered
Joined
·
1,605 Posts
I have an 06 gcsrt and was wondering would it be easy or hard to put in a newer (touchscreen) dvd/nav unit in from a newer year? Thanks just wondering..
 

·
Registered
Joined
·
101 Posts
Do you guys have any tricks to keep the brakes from squeeling on a 07 GCSRT8 with 23K miles? I've heard the rotors glaze and there may be some braking techniques to get the glaze off. Any ideas?

Thanks for doing these sessions!!
 

·
Registered
Joined
·
58 Posts
hello and thank you for your time. I own an 07 GC srt8 with 48k miles. This winter my trans started slipping only when its cold. I can't check the fluid levels because there is no dipstick. I apologize if this is an already covered topic but I haven't seen it yet. What is my remedy? I am the original owner. Ooops I see in post #11 someone has a similar problem to mine... what gives?
 

·
Straight Up Beast SON!!!
Joined
·
17,143 Posts
Hello guys!

Just wondering how this whole adaptives thing works? Basically I have been told by tuners that if and when you do install a CMR Tune on a Jeep that once the tune is installed that I will have to disconnect the battery and press on the brakes for 30 seconds or so and then connect the battery back up. Next they told me that I would have to drive the Jeep like how I usually drive it and do a few WOT runs as the computer in the Jeep is learning the way I drive my Jeep. Is this true?
 

·
Premium Member
Joined
·
596 Posts
Is a predator or cmr "tune" bad for our vehicles.
and
Can a dealer see if you have had a tune on a vehicle. If so how?
 

·
Registered
Joined
·
36 Posts
I have a 2005 jeep grand Cherokee limited that I did an srt conversion on and I have an aftermarket navigation. I recently put the stock navigation back in now is there anyway that I can a mygig into the truck. I think that I have a low signal canbus. I know that they make a lockpick but will it work with my truck. Any information would be awsome. Thank you. Jon.
 

·
Registered
Joined
·
1 Posts
First, thanks for an awesome car!

My question:
I have a 2009 Challenger SRT8 6-speed. When I accelerate out of a corner I feel a shudder and it feels as though the power is down. As soon as I straighten the wheel out it goes away and you can feel the power pick back up. This happens in all three modes of the ESP (on, partial off, and disabled). It can be repeated in a parking lot by doing a circle, not too slow, and then pulling straight out of it.

I took the car to the dealer and took them for a test drive in my car. He felt the shudder in the car. Then we test drove a 2010 SRT8 off of the lot and it did the same thing. The dealer says that it is the computer retarding the power to protect parts. I wouldn't think think the ESP would do anything with it being disabled. Is this something I need to be worried about? Seems as though something isn’t hooking up 100%.
 
1 - 20 of 186 Posts
Status
Not open for further replies.
Top