Cherokee SRT8 Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
2006 srt8 Jeep I am getting P2100 code and P2111 code the
Red thunder bolt light (throttle body) saying stuck open /unable to close only comes on when it rain causing my car to shut off in limp mode nd sometimes it will not start back up at all until it’s dry and then it starts up fine
I have replaced the complete throttle body and the acceleration pedal as well
The only other code reading is service tire pressure system and p0430/p0420 beside the P2100/P2111 codes I have nothing Help a pal out even went to the dealership as well they stated after replacing my complete engine wiring they said my throttle body will not operate I have the dealership diagnostic attach to the form
Handwriting Font Material property Monochrome Paper

Handwriting Font Material property Writing Paper
 

·
Registered
Joined
·
192 Posts
Just check your battery and alternator and make sure your getting proper voltage to the Throttle Body, etc. Odd dealership can’t figure it out. Get another opinion and try a different dealership. If they figure out the issue is something else, would want to be reimbursed for that $1500. Hope you get it resolved soon
Wish I had more advice
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Going out to buy a wiring reader and yess I went to the dealer with this problem they replaced everything but what I asked for I didn’t know the problem was still there which was the no start/thunderbolt until it rained here but I do appreciate the knowledge you could provide enjoy
 

·
Registered
Joined
·
16 Posts
I agree with checking Battery and Alternator. I had all kinds of weird warnings and codes come up until I replaced the Battery in my 2008. Our electronics are very touchy to voltage.
 

·
BlaBlaBla
Joined
·
5,367 Posts
I would check the wiring and plugs at the throttle body and everything under the hood. Grounds included. You said they replaced all of the under hood wiring?? Looks like a couple of plug ends according to your invoice.
Only happens when it rains points in that direction.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
I would check the wiring and plugs at the throttle body and everything under the hood. Grounds included. You said they replaced all of the under hood wiring?? Looks like a couple of plug ends according to your invoice.
Only happens when it rains points in that direction.


Sent from my iPhone using Tapatalk
Not just the plugs I had the complete wiring harness replaced from the transmission to the motor and still having problems but I just checked my fuses with the tool and my ngc injector fuse 25 is blown along with ipm coils fuse is blown finto research on them two fuses
 

·
BlaBlaBla
Joined
·
5,367 Posts
Not just the plugs I had the complete wiring harness replaced from the transmission to the motor and still having problems but I just checked my fuses with the tool and my ngc injector fuse 25 is blown along with ipm coils fuse is blown finto research on them two fuses
You have a wire rubbing or rubbed bare that is shorting out or jumping when it gets wet. That would be my guess. Good luck.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
7 Posts
Not just the plugs I had the complete wiring harness replaced from the transmission to the motor and still having problems but I just checked my fuses with the tool and my ngc injector fuse 25 is blown along with ipm coils fuse is blown finto research on them two fuses
Consider using dielectric grease on the connections too, you,ve got moisture coming into the system somewhere. Have you cleaned the drain tubes from your sunroof. If clogged that could be another source of moisture(just guessing). I clean my draintubes with my shop vac every year,
 

·
Premium Member
Joined
·
2,926 Posts
It's in the wires.
 
1 - 11 of 11 Posts
Top