Cherokee SRT8 Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
So for the last month or so service 4 wd message has been intermittently been being displayed. I let the car sit over night it goes away, only to come back after my hour drive to work. Have the code read it said something about Motor current output low. Buddy of mine says change the tcase fluid. I order the fluid since the dealer by me doesn't stock it. 55 a quart.. Take truck to my buddies shop and drain the fluid, it comes out red?! The new shit is green. Could the dealer have used the wrong fluid? Why? Would that potentially be giving me the grief? Would it have hurt the motor or actuator?

It's an 08 with 42k service records don't show tcase fluid ever changed.
 

·
Registered
Joined
·
19 Posts
my guess is your TC motor is about to shit the bed. you have a motor that looks like a starter on the drivers side of your TC thats what engages the awd. On another note, No you shouldnt have red fluid in your transfer case and the new stuff shouldnt be green either, it should look almost like honey..... when its dirty and used it should almost look like a milky brown.. My guess is a dealership unknowingly put transmission fluid in your tc thinking it would be fine.. Double check your part number on the quart bottle to make sure that its fluid for a nv 146... Part number=68001758AA
 

·
Daily Driver..........
Joined
·
1,837 Posts
my guess is your TC motor is about to shit the bed. you have a motor that looks like a starter on the drivers side of your TC thats what engages the awd. On another note, No you shouldnt have red fluid in your transfer case and the new stuff shouldnt be green either, it should look almost like honey..... when its dirty and used it should almost look like a milky brown.. My guess is a dealership unknowingly put transmission fluid in your tc thinking it would be fine.. Double check your part number on the quart bottle to make sure that its fluid for a nv 146... Part number=68001758AA
i concur! red and green fluid in the tc=not good.
 

·
"guy with the crazy Jeep"
Joined
·
4,868 Posts
Sounds like the wrong fluid was used. The only fluid to use is the Mopar fluid and I forget the number of it but it's at least $45 dollars / Qt. It's more straw color and feels like baby oil.

As for the actuator motor, they do go bad. Ive replaced mine a couple years ago, but when they work, they are a very strong motor and there is really no chance of damaging it.
 

·
Registered
Joined
·
181 Posts
Red = ATF. My dealer did the transfer case service on my Jeep and replaced it with ATF. It took me two days of emails, phone calls, and escalation to Chrysler engineers to convince the dealership that they were wrong. The fluid should be Mopar NV146 fluid. The transfer case was going before they changed the fluid and I eventually got a rebuilt transfer case out of it. The WK2 Grand Cherokee transfer cases call for ATF and something is messed up in the dealer's techconnect system regarding our transfer cases.
 

·
Registered
Joined
·
611 Posts
Oh damn glad I looked at this thread. I thought all trans cases took ATF. Thanks guys.
 

·
Registered
Joined
·
2 Posts
Same Issue, 09 with about 16k on is. Just bought it last week! I got the same message, brought it right down to the dealer. They're ordering and replacing the "4wd motor" as they put it.

Seemed to be triggerd by the engaging of the ABS breaks....thoughts?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #9 ·
So yeah the dealer had used a red fluid looks like trans fluid...The nv146 was a honey or lighter color( I looked in the bottle and saw green, probably playing off the black bottle.)

No work record of them doing it so I guess no one will take ownership unless they computer store that info and will admit fault. Any suggestions would be greatly appreciated.

I changed the fluid to the nv146 2 qrts, problem went away for about 4 days and returned yesterday. You guys think wrong fluid harmed the motor/actuator?? how much those things run and anyone got a part number as im out of warranty. Looks simple enough to change anything to be forwarned about?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #10 ·
I read on here about bad earth on battery so i decided to check mine out, it was not loose, but there was some corrosion on the ground terminal. I cut it off and use a to post connect terminal after cleaning the posts wiht a wire brush. Drove the truck to work and sure as shit it came on even sooner than it normally does.. I'm going to replace the motor Tuesday and see what that does.

I also read someone fixed their issue with replacing a brake switch?! How and why would this affect case or AWD? Is the ABS tied in electronically with the Tcase motor to make braking easier, cause come to think of it the service light ALWAYS comes on when im stopping (pressing the Break) Never just cruising.
 

·
"guy with the crazy Jeep"
Joined
·
4,868 Posts
So yeah the dealer had used a red fluid looks like trans fluid...The nv146 was a honey or lighter color( I looked in the bottle and saw green, probably playing off the black bottle.)

No work record of them doing it so I guess no one will take ownership unless they computer store that info and will admit fault. Any suggestions would be greatly appreciated.

I changed the fluid to the nv146 2 qrts, problem went away for about 4 days and returned yesterday. You guys think wrong fluid harmed the motor/actuator?? how much those things run and anyone got a part number as im out of warranty. Looks simple enough to change anything to be forwarned about?
Oh, Oh.... These T-case's are particular on fluid type and capacity. You have the correct fluid but the capacity is 1.5 qts. You should drain off 1/2 qt.

Is there anyone in your area that could let you try there actuator motor?

I'm not thinking fluid could damage the motor, they are very strong... When they work. They do go bad, so that could be the problem. Or it is a problem in the ABS system as the AWD system uses information there too.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #12 ·
Oh, Oh.... These T-case's are particular on fluid type and capacity. You have the correct fluid but the capacity is 1.5 qts. You should drain off 1/2 qt.

Is there anyone in your area that could let you try there actuator motor?

I'm not thinking fluid could damage the motor, they are very strong... When they work. They do go bad, so that could be the problem. Or it is a problem in the ABS system as the AWD system uses information there too.
yea...sorry that was a bit misleading, I bought 2 qrts. I had a mechanic buddy drain and fill it. there was a almost a half qrt left, but id say closer to .25.

When i saw that ABS could be causing my grief it rang a bell in my head! I let my sister take my rig to work one day cause she was thinking about buying one and wanted to see how it drives....turns out she was driving with the ebrake up about 7 miles both ways. No issues were sustained immediately after so i didnt think too much into it. Could this have dmged the Tcase motor? Abs sensors?
Sorry I really know shit about mechanics.
 

·
"guy with the crazy Jeep"
Joined
·
4,868 Posts
I don't think driving with the E-brake on would cause any problems. A bad wheel speed sensor could cause the problem.
 

·
Marathon Man
Joined
·
3,229 Posts
I was the one who fixed it with a $7 brake switch. After the light came on I took it to the dealership and the code they pulled said it was a faulty switch. Been about 15 months since the switch replacement and haven't had it come back on since and my TC is still working just fine.
 

·
Registered
Joined
·
802 Posts
I let my sister take my rig to work one day cause she was thinking about buying one and wanted to see how it drives....turns out she was driving with the ebrake up about 7 miles both ways.
That's rough, I'd save some money now and replace your sister.

ABS sensors sometimes get dirty and cause Service AWD and ABS messages/lights to come on.
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top