Cherokee SRT8 Forum banner
1 - 20 of 27 Posts

·
Registered
Joined
·
639 Posts
Discussion Starter · #1 ·
So i am running a stock catback with a catted replacement mid resonator.I decided to delete my rear resonators in favor of getting new 5 inch black chrome tips.:)
The drone i can handle but not the following.

I went with the black 5 inch chrome tips looks amazing but as I just found out deleting your rear resonators will not only cause drone but will also cost you 4 to 5 tenths in a 0-100km.
I was always a 5 or 5.1 in similar da (roughly 4000)
with res delete i noticed loss of power and pulled a 5.5 in the 0-100km
Ive got to figure something out, to get those 4 to 5 tenths back.
That's just way to much.:mad:
Any suggestions?
 

·
Registered
Joined
·
3,440 Posts
Put your resonators back on? Also, someone on here hollowed out their cats with a similar result.
 

·
Registered
Joined
·
639 Posts
Discussion Starter · #3 ·
Put your resonators back on? Also, someone on here hollowed out their cats with a similar result.
I would but they are gone and I don't want to lose these tips lol. I wonder if a reducer somewhere along the line would help build back pressure?
 

·
Registered
Joined
·
386 Posts
So i am running a stock catback with a catted replacement mid resonator.I decided to delete my rear resonators in favor of getting new 5 inch black chrome tips.:)
The drone i can handle but not the following.

I went with the black 5 inch chrome tips looks amazing but as I just found out deleting your rear resonators will not only cause drone but will also cost you 4 to 5 tenths in a 0-100km.
I was always a 5 or 5.1 in similar da (roughly 4000)
with res delete i noticed loss of power and pulled a 5.5 in the 0-100km
Ive got to figure something out, to get those 4 to 5 tenths back.
That's just way to much.:mad:
Any suggestions?
pull stock motor and drop in 426 or 440 or boost her.... or you could save about $15k and just put ur resonators back in. im running straight pipes with cutouts and freakin love it. no power loss actually a lil gain but im far from stock.
 

·
Registered
Joined
·
639 Posts
Discussion Starter · #5 ·
pull stock motor and drop in 426 or 440 or boost her.... or you could save about $15k and just put ur resonators back in. im running straight pipes with cutouts and freakin love it. no power loss actually a lil gain but im far from stock.
Yeah I would love to but my wife would kill me lol.
I will boost one day when I come across a great deal.:)
 
  • Like
Reactions: CurbRash

·
Registered
Joined
·
386 Posts
Yeah I would love to but my wife would kill me lol.
I will boost one day when I come across a great deal.:)
life always gets in the way of fun doesnt it lol...i think the res delete like what you did was done quite a bit but many years ago with the stock motor. i think you are right that they ended up doing some type of reducer after to build the pressue. probably going to have to google that shit and spend next 4-5 days reading and beating ur head against the wall lol. anyway good luck man. ull figure out what to do
 

·
Registered
Joined
·
639 Posts
Discussion Starter · #7 ·
life always gets in the way of fun doesnt it lol...i think the res delete like what you did was done quite a bit but many years ago with the stock motor. i think you are right that they ended up doing some type of reducer after to build the pressue. probably going to have to google that shit and spend next 4-5 days reading and beating ur head against the wall lol. anyway good luck man. ull figure out what to do
yeah maybe someone whos what size and length of the reducer will chime in.Or maybe a different reso in the middle?
Also Johan said I wouldn't need a revision but I will log and see because of the loss here.
 

·
Registered
Joined
·
639 Posts
Discussion Starter · #8 ·
pull stock motor and drop in 426 or 440 or boost her.... or you could save about $15k and just put ur resonators back in. im running straight pipes with cutouts and freakin love it. no power loss actually a lil gain but im far from stock.
Headers straight piped with cutouts,dang how can you even hear yourself think lol.
just with the rears deleted I'm like wow this is loud.ha ha.
 
  • Like
Reactions: CurbRash

·
Snail On Board
Joined
·
4,366 Posts
How many miles did you log with your resonators off before you ran your 0-60? I did a resonator delete for the same reason and there was a noticeable loss of power at first but returned after logging a few hundred miles. I think the computer needs to adjust. Anyways, I have Borla now :)
 

·
Registered
Joined
·
639 Posts
Discussion Starter · #10 ·
How many miles did you log with your resonators off before you ran your 0-60? I did a resonator delete for the same reason and there was a noticeable loss of power at first but returned after logging a few hundred miles. I think the computer needs to adjust. Anyways, I have Borla now :)
Yeah Ive only put on 60-100 miles since i got them deleted.
Would be nice if that's the case.
I did reinstall my custom tune after though.
We will see,only time will tell.
 

·
Registered
Joined
·
3,440 Posts
Kaczman just posted up a pair of resos today. In case you wanted to put them back on.
 

·
Premium Member
Joined
·
3,832 Posts
Cutting mine out didn't cost me at the track at all. If you want the stock resos back you can have mine
 

·
Snail On Board
Joined
·
4,366 Posts
Cutting mine out didn't cost me at the track at all. If you want the stock resos back you can have mine
I've got a set that I can give you too! LOL Hope you get it straightened out.
 

·
Registered
Joined
·
639 Posts
Discussion Starter · #14 ·
Thx guys,I do have a set as I once thought they were blown.I just dont want to lose my 400 investment and my 5 inch black chrome tips.Roadboy did you need a revision afterwards?Or maybe its because they threw on an aftermarket mid reso earlier.
Yeah it feels like ive lost a lot of torque down low. I'm going to think of something tho.
 

·
Registered
Joined
·
355 Posts
I chopped mine too and no issues. I've heard of issues if you chop the muffler with performance loss but not the resonators...
 

·
Registered
Joined
·
639 Posts
Discussion Starter · #16 ·
I chopped mine too and no issues. I've heard of issues if you chop the muffler with performance loss but not the resonators...
maybe its because my muffler in the middle is aftermarket?
I don't really know why Ive lost and others haven't.
 

·
Registered
Joined
·
5,005 Posts
No way removing the resonators cost you like that. Do you have track numbers to back this up?? If your using the EVIC there are too many factors that can impact the results. I was basically stock and removed my rear resonators and all it did was sound better. Tune, UD pulley, cai, res delete and Id run 12.6-12.8 at the track all day
 

·
Registered
Joined
·
639 Posts
Discussion Starter · #18 ·
No way removing the resonators cost you like that. Do you have track numbers to back this up?? If your using the EVIC there are too many factors that can impact the results. I was basically stock and removed my rear resonators and all it did was sound better. Tune, UD pulley, cai, res delete and Id run 12.6-12.8 at the track all day
possibly could be something else but it started right after and I definitely feel a loss of torque.Somethings going on and thats all I have changed.
Ive done a few runs on my evic on the same spot I always do then when I get home I check da etc.Definitely loss some power.
 

·
Registered
Joined
·
639 Posts
Discussion Starter · #19 · (Edited)
5.5 in 4000 plus da and 5.4 in 3700 da where as in 4000 plus da I was consistently a 5.0 or 5.1
same spot similar da.
 

·
Registered
Joined
·
639 Posts
Discussion Starter · #20 ·
Still at a loss guys.
Can anyone think of any reason for this loss?
Happened right after res delete.
Still feel lost torque.
Johan says looks good.
Need oil change other then that can only blame reso delete.
 
1 - 20 of 27 Posts
Top