Cherokee SRT8 Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a problem. I just bought this with 78k miles on it and drove it 6 hours to my duty station in Fort Drum NY. When was driving my SRT8 the electronic throttle control came on and the temperature gauge shot cold for 3 minutes before smoke started pouring out of my engine. By that time, it shot 300 degrees and hot as hell. The engine was smoking so i pulled over to the side of the highway to see that my coolant was everywhere and my hose was corroded. Firestone has more to say about it such as it has problems cooling down, it keeps over heating, and there might be something wrong with the gasket. They tried to start it but it took about 3-5 seconds to start then finally started. It sounded like a sewing machine for 5 seconds then finally started. I don't know what to do. So i had it shipped to a Jeep dealership and currently waiting on a diagnosis. I was just wondering if anyone had any opinions or experiences with this overheating problem and not being able to start correctly/cool off. please message back asap
 

·
Registered
Joined
·
139 Posts
The only time I had an overheating problem was when I did not bleed the cooling system correctly. I replace my 2 piece upper hose with a new 1 piece hose. I also replaced the waterpump and thermostat and most importantly the thermostat housing as it had a leak on it. I also changed out the lower hose for good measure as well.

At this point, after a proper coolant air bleed, I have had no further issues and it works perfectly since I did the work myself last summer.
 

·
Premium Member
Joined
·
5,048 Posts
It could be a few items like mentioned above. Either you have trapped air, a faulty tstat, bad waterpump or possibly a bad rad fan. All easy and relatively inexpensive pieces.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
1,655 Posts
What do most of you go by the actual needle gauge or the digital reading? I know in mine... The needle will always be lower then the digital reading...I might see 230 on the digital on stop and go traffic if I use the gears, but the needle will not be on the 215.
 

·
Registered
Joined
·
1,579 Posts
Also check the tstat. I have a 180 stat in mine and love it, but I've had to replace it twice in the 8 years I've owned my Jeep. Cheap and easy fix though.


BTW, the digital readout is the oil temp. The analog gauge gives you the engine coolant temp.
 

·
Registered
Joined
·
65 Posts
if you have a JET 180* im betting thats your issue, i have changed out TONS of faulty ones, they are cheap motorad autozone made junk that JET marks up a ton and sells, replace it with a Stant 190* stat and be done with it.

I cant belive people would install a JET, have it go back, and then install another, i would not risk my engine on a cheap thermostat, i called jet several times to complain when i had new ones right out of the box that wouldnt open, they said if your engine overheats and blows up, TOO BAD, they will not cover ANYTHING
 

·
Premium Member
Joined
·
5,048 Posts
^^^^agreed. Jet sucks. I got a stant 180 and have had no issues.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
3,224 Posts
The problem is that Jet established a good reputation when it first started by producing a quality thermostat. Like most companies that get that good reputation, they then seek higher profit levels, and since they have the turnover already, they use cheaper raw materials to increase their profit margin. Lots of people think that they just got a bad one and that Jet still has that good reputation for quality products, when it really is non-existant. Companies like Briggs and Castration(Stratton) are doing the same $#!T! The product that they produce now is garbage compared to the quality that they produced originally, which gained them their reputation.. My older Jet thermostat probably pre-2010, I could put up against any of the newer thermostats and it would win hands down. No newer Jet, Mishimoto, Stant, Autozone or Napa thermostat can touch it in terms of quality or consistency of performance....It never misses a beat and runs like a well oiled machine.


if you have a JET 180* im betting thats your issue, i have changed out TONS of faulty ones, they are cheap motorad autozone made junk that JET marks up a ton and sells, replace it with a Stant 190* stat and be done with it.

I cant belive people would install a JET, have it go back, and then install another, i would not risk my engine on a cheap thermostat, i called jet several times to complain when i had new ones right out of the box that wouldnt open, they said if your engine overheats and blows up, TOO BAD, they will not cover ANYTHING
 

·
Registered
Joined
·
25 Posts
Had a Motorad one and it failed within a couple of months. Almost could have cost me a motor had I been on a highway somewhere out of town. Common common common.
 

·
Registered
Joined
·
247 Posts
I just did a Jet 180 one piece hose stant locking cap and used HP tuners to change my fan settings and im golden now highly recommended
 

·
Registered
Joined
·
1 Posts
So I kinda wanna chime in here. I've got an 07 SRT and when I first got it It had the stock 2 piece hose and After it busting on me i switched to the 1 piece one and bled the air etc. and also it was on the stock thermostat, that went out then I switched to the 180* and adjusted the fan settings everything was nice and dandy. Then I had the suspicion that my tstat had gone bad so I decided to change that and the water pump together just to have the doubt out of my mind either way. So that fixed my issue then about a month or 2 later same overheating problem again. Change the thermostat and it fixes the issue. All in all I've been through about 4 thermostats and it's starting to do the same thing again. So I'm kind of at a loss. Could it be that I'm getting junk tstats or something else? If I'm stopped and the engine is running it won't over heat but once I start moving it'll start to overheat. Only things done to it are a Bwoody 4" intake, and the canned Diablo tune. Any help would be appreciated fellas.
 

·
BlaBlaBla
Joined
·
5,281 Posts
I've been running the stock thermostat from the dealer. Zero issues. I've only had to change it once. I've never really had a want or a need to switch to a 180. My truck runs just fine on the Mopar stock T stat. You really have to give these things a good burping.
 
  • Like
Reactions: SPEEDDEMON

·
Registered
Joined
·
9 Posts
So I ran my 08 a lol hard yesterday and the trans over temp message came on the needle was taped out but the dig wasn't reading high at first...215...then jumped to 235...the rad fluid was coming out of the resavour ....knocking on the rad so could that be the thermostat not opening?? I have the rad hose cpr and felt alot of pressur then a rush of fluid. Idk what's a good way to chk the thermostat (I hear it clicking open when it's cool?) The pully for the water pump look like it's moving fine and def bleed out all the air when refilling it..i guess I'm mechicanal inclined but just don't know the signs or how to chk any help would be great thank you
 

·
Registered
Joined
·
2 Posts
I have a problem. I just bought this with 78k miles on it and drove it 6 hours to my duty station in Fort Drum NY. When was driving my SRT8 the electronic throttle control came on and the temperature gauge shot cold for 3 minutes before smoke started pouring out of my engine. By that time, it shot 300 degrees and hot as hell. The engine was smoking so i pulled over to the side of the highway to see that my coolant was everywhere and my hose was corroded. Firestone has more to say about it such as it has problems cooling down, it keeps over heating, and there might be something wrong with the gasket. They tried to start it but it took about 3-5 seconds to start then finally started. It sounded like a sewing machine for 5 seconds then finally started. I don't know what to do. So i had it shipped to a Jeep dealership and currently waiting on a diagnosis. I was just wondering if anyone had any opinions or experiences with this overheating problem and not being able to start correctly/cool off. please message back asap
what was the diagnosis from jeep ?
 
1 - 16 of 16 Posts
Top