Cherokee SRT8 Forum banner
1 - 9 of 9 Posts

· Registered
Joined
·
106 Posts
Discussion Starter · #1 ·
So, I went to go start my Jeep after work yesterday and it would start then die withing 5 seconds. A few tries later, it quit even turning over. Using my preditor, I scanned the code P0513, which says that I had an incorrect immobilizer key. I know there are a couple other topics about this on here, but they are quite inconclusive. Anyone have any idea what I can do? I tried clearing the code, disconnecting the battery, and re-flashing my tune with no luck. :confused:

Perhaps I should mention that my other key is in a different city a couple hours away, so I'm rather stranded. Thanks for the help!
 

· The Traveler
Joined
·
5,264 Posts
Do you have an after market remote start?


Sent from my iPhone 4S
 

· Registered
Joined
·
106 Posts
Discussion Starter · #3 ·
Nope, all stock as far as ignition goes..
 

· The Traveler
Joined
·
5,264 Posts
I had a couple times where my after market remote start interfered with the factory stuff.

It wouldn't recognize the key, but I'd remote start and then put the key in and it'd be fine.


Sent from my iPhone 4S
 

· Registered
Joined
·
106 Posts
Discussion Starter · #5 ·
bummer for me.. I have an 06 without remote start..
 

· The Traveler
Joined
·
5,264 Posts
Found this on another place



According to the -07 WK manuals:

Possible Causes

INCORRECT VIN PROGRAMMED IN THE PCM
NO COMMUNICATION WITH SKREEM
NO VIN PROGRAMMED IN THE PCM
IGNITION KEY
PCM

_________________

I would check the battery in the key for starters. Or try your spare key.



Sent from my iPhone 4S
 

· Registered
Joined
·
106 Posts
Discussion Starter · #7 ·
Yeah, I saw that too.. I checked the battery (remote unlock still works fine), but still took it apart and tried with / without the battery.

My spare key is @ home a couple of hours away :/

Thanks for the help though!
 

· Registered
Joined
·
106 Posts
Discussion Starter · #8 ·
Well, I think I have the problem solved here with the help of the dealer. I ended up having to get it towed, and hopefully I can prevent this from happening to someone else.

Anyways, if you try to start your Jeep (or any other modern Chrysler) with an "invalid" immobilizer key (keep in mind my key worked a few hrs before) 3 times in a row it will go into "lock out" mode and literally disable everything.

So.. To prevent this, if your car starts and dies 2 times in a row, do NOT try again! They told me that you need to keep the key in the ignition in the on position for 45min to an hour to HOPEFULLY have the key re-learn the car code. This may work, but it may not work as well.

If your car is locked out, try leaving the key in for an hour in the ignition on position, and see what happens.. It may reset itself after all, but will likely need to be towed to the dealership. What a PITA...
Apparently these are Mercedes-esque security features. Similarly, my boss has a Mercedes that requires you to leave the key in, and "on" for 24 hrs to reset the radio. (I guess if you remove the radio, you need a special code to re-enable it. if you put the wrong code in 3 times, then it needs to be reset)
 

· Marathon Man
Joined
·
3,229 Posts
wow that sucks, at least you got it working again
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top