Cherokee SRT8 Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter · #1 ·
I've had these codes P0455/P0456 for 1.5 years (popped 10 days after my factory warranty ended and the dealership wouldn't fix it), no driving issues except maybe gas mileage but decided to finally get it fixed. I swapped out the ESIM today. I was going to reset the CEL then go after the purge valve and if still an issue have a local shop do a smoke test and finally the fuel filler neck replacement (quoted ~$440).

Can anyone give me part #s for the purge valve and fuel filler neck?

Also any videos or images on DIY replacement? The ones I've found are for V6 models, where is the purge valve located?
 

·
Registered
Joined
·
10 Posts
I've had these codes P0455/P0456 for 1.5 years (popped 10 days after my factory warranty ended and the dealership wouldn't fix it), no driving issues except maybe gas mileage but decided to finally get it fixed. I swapped out the ESIM today. I was going to reset the CEL then go after the purge valve and if still an issue have a local shop do a smoke test and finally the fuel filler neck replacement (quoted ~$440).

Can anyone give me part #s for the purge valve and fuel filler neck?

Also any videos or images on DIY replacement? The ones I've found are for V6 models, where is the purge valve located?
Did you ever get this fixed and if so what did you need to end up doing? I did my oil change 2 days ago and yesterday i got the code p0456😮‍💨
 

·
Registered
Black ‘08 SRT8 w/ Borla cat-back and mopar cai
Joined
·
17 Posts
Did you ever get this fixed and if so what did you need to end up doing? I did my oil change 2 days ago and yesterday i got the code p0456😮‍💨
I have had p0455, p0456,p0457 on my wk1 for a while. Keep me posted on how its going. I replaced the gascap and code still came back. Headed to the shop in a few days to check it out
 

·
Registered
Joined
·
10 Posts
I have had p0455, p0456,p0457 on my wk1 for a while. Keep me posted on how its going. I replaced the gascap and code still came back. Headed to the shop in a few days to check it out
I cleared code but it came back😮‍💨 im going to smoke test it but i have read and seen that it could be the ESIM, vacuum purge valve hose or the cannister connected to the hose in the engine bay. Did you ever get this resolved?
 
1 - 7 of 7 Posts
Top