Cherokee SRT8 Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
630 Posts
Discussion Starter · #1 ·
Ever since it started getting cold, the first half mile will be CRAZY loud squealing! the R1 premiums and ceramics, were fine never did it before now.., hasnt been even 2000miles yet...front and backs are doing it. anyone ever have this problem?
 

·
Registered
Joined
·
532 Posts
I have R1s with Stop Tech pads. Sometimes when it is really cold out the rears squeel really loud on the first few stops, then it goes away.
 

·
Registered
Joined
·
630 Posts
Discussion Starter · #3 ·
oh ok so its not just me...maybe they just need to be warmed up a little. so its normal..thats an annoying normal. then again this is my first cold season with the rig..
 

·
Registered
Joined
·
656 Posts
I get that also and I have same setup as you.
All I do is drive slow and brake lightly at same time for 1 second and
It stops squealing.
Good luck.
 

·
Registered
Joined
·
630 Posts
Discussion Starter · #5 ·
cool, i was just making sure it wasnt just me, yeah it goes away after a couple of braking, but leaving work and having the whole parking lot stare at you lol..kind of embarrassing haha
 

·
Premium Member
Joined
·
1,050 Posts
I think you are going to see the squeal problem at some point with any performance brake setup.
 
  • Like
Reactions: Wallyb

·
Premium Member
Joined
·
98 Posts
I have the same setup with hawk hps pads, i havent noticed a squeal when the temp is cold but i get a really loud squeal when they are wet. Same situation, stop 2 or 3 times and they are fine. Its kind of embarrassing pulling out of the garage sometimes though.
 
  • Like
Reactions: Wallyb

·
Registered
Joined
·
327 Posts
brakes like ours love being used hard. that's what they were made for and will give you a bit of squeak if not used hard.
 

·
Registered
Joined
·
18 Posts
Brake noise - I just posted on a different thread and saw this one so forgive me for jumping all over (newbie on the site!) Just picked up my first SRT8 - 2007 c/w 95,000K. Dealer told me on first test drive they had just redone brakes which caused the noise, but when I went to drive off lot the noise was there and he said they'd washed it and brakes are frozen. Agree with comments above that the noise should have gone away after a few stops, but mine hasn't. Still sounds like a poor piglet in jeopardy. Might have made an expensive mistake on the purchase of this unit, but at least I can sleep now that I know others have or are living through it. Thanks for posting - you've given this newbie some hope:)
 

·
Registered
Joined
·
630 Posts
Interesting, I am getting somewhat consistent terrible squeaking from my rear Stop-Tech pads (even when not cold). I just ordered rear ceramics hoping that would help with the rear squealing but sounds like that may not be the case. I even pulled the pads, cleaned and re-applied the anti-squeal spray.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top