Cherokee SRT8 Forum banner

No throttle response in drive or reverse

9861 Views 12 Replies 6 Participants Last post by  jlsperko
I am stumped on this one. My Jeep is a 2008. Last week, I had a strange problem. I started up the Jeep, and headed out of my driveway. I was under light throttle and went to give it some gas and no response. At that point I hit the throttle a few times, and nothing, no rise in rpms, no acceleration, nothing. It was like the gas pedal was disconnected. I pulled over and it idled normally. I shut it down, restarted, and all was fine.

I drove it all the way to work (combo of 20+ miles highway and city), parked it for the day and didn't think much of it. Left that afternoon, and it did the same thing. Shutdown and restart fixed it again. The third time this happened, I got a check engine light. Hooked up my Diablo to look at the codes, and nothing other then my normal O2 sensors codes ("high flow" cats).

I got it home, disconnected the battery for a few hours, reconnected and took it for a drive. It drove fine at first although I was feathering the throttle (maybe 1/4 mile), then the same problem... no throttle response and a check engine light. No codes. I am thinking / hoping that maybe the star scan will pick up codes that my Diablo won't?

I have messed with various things after reading around on the forums. I tried a different throttle body, put a canned tune back on it (as opposed to custom Johan tune), tried to read the "DTC Report" from key dance (didn't show anything), checked all connections I could think of and see, etc. I read that 2008 and beyond have a different ESM (shift module) so I can't clean that as mentioned in other posts.

This happens every time I start the Jeep now. I can start it, it idles normally, put it in gear, and it normally responds the first time. It is not until I give it some throttle where it starts bogging / dying, or when I hit the brakes and come to a stop and the throttle becomes completely unresponsive. I can put it in park or neutral, give it throttle and the rpms rise, but nothing in drive / reverse. If I am in neutral give it a little throttle, then slap it into gear while the rpms are a bit above normal, I can usually baby it and make it back home (these are all just "test" runs).

I was wondering if the gas pedal sensor was bad, so I hooked up my Diablo and monitored the "ACC PDL POS", "THR BLADE" and "THR POS %". I am assuming the "ACC PDL POS" is telling me how far the gas pedal is engaged, the "THR BLADE" and "THR POS %" are telling me how far my throttle body is opening. Sure enough, the "ACC PDL POS" seems to be in sync with engagement of the gas pedal, however the "THR BLADE" and "THR POS %" are not moving accordingly.

I took a video, here is the link : https://drive.google.com/file/d/0B0KaUbyCmBcBSnBWZE0tMUxmOGM/view At the start, I have it floored. You can see when I floor it and "ACC PDL POS" is at 100, there is no change in "THR POS %" or rpms on the dash (and somewhat erratic idle). I do this multiple times. You then see me knock the Diablo... and that is when I put it in neutral. You can then see it respond to the throttle and the "THR POS %", "THR BLADE", and rpms raise and lower with the pedal position. I then put it in gear again and am holding the brake, and you see the "ACC PDL POS", "THR POS %", "THR BLADE", and rpms all correlate. It goes back down to idle, I do it again... and dead again. No throttle response.

Other notables : Once I disconnected the battery after the second time this happened, it engages louder / harder when putting it into gear. This makes me wonder if it has something to do with the TCM.

Any thoughts / suggestions would be greatly appreciated. I have gotten so much from this site and normally can figure this stuff out, but this one has me stumped.
See less See more
1 - 13 of 13 Posts
I had the same issue and my TB was bad. Disconnect it and move the blade if you feel it having dead spots or it isn't smooth it's smoked.


Sent from my iPhone using Tapatalk
I tried a different stock throttle body and it didn't appear to make a difference at all. I can try it again, disconnect the battery and let everything reset to see if it makes a difference.
Well, I tried a new gas pedal assembly, two different throttle bodies, putting the stock tune back on, Mopar Performance TCM, checked tranny fluid level, checked all connections. Nothing.

My neighbor works at a Dodge / Jeep dealer and told me to bring it up and that one of his guys would look at it. I did that today since I was out of ideas. When he did the diagnosis, at first, everything looked fu**ed. Nothing was communicating and he was sure how the rig was even running. He said the PCM wasn't even showing a registered VIN. He set / cleared whatever and got it to at least register. I can only guess that this is why I wasn't able to get any codes off the dash or my Diablo Trinity??

Once that was settled, and stuff was communicating, it then came down to a bad input speed sensor on the valve body. We will see if that fixes it. Just wanted to update for anyone who has faced something similar.
See less See more
Just wanted to close this loop. It was my valve body.
  • Like
Reactions: 1
Thanks for updating.


Sent from my iPhone using Tapatalk
Just wanted to close this loop. It was my valve body.
Hi mate

As I am experiencing the same symptoms, was it the speed sensor in the gearbox or the actual valve body. Reason being in Australia where I am from I have the MY13 VM Motori Diesel with the nag1 or W5A580 5 speed box, a combination not sold in the USA

As I said exactly the same symptoms including the Bluedriver scanner sometimes saying unknown vehicle and other times registering the Vin number

Thanks in advance

Bob
I was told it was a sensor on the valve body.
wow thanks.. this is happening to me right now.

I too thought throttle body.

I know this was months ago jlsperko but do you happen to have the part # he used to fix it?

Thanks!
I just researched it and it requires the valve body to be removed from the case in order to replace the sensor if anyone was wondering.
I know this is an old thread, but have seen a few people post elsewhere with similar issues and also on this thread that I missed. This was a sensor on the actual valve body in the transmission. I couldn't order / replace just that sensor and had to replace the entire valve body. Hope that clears up some of the questions.
1 - 13 of 13 Posts
Top