Cherokee SRT8 Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
143 Posts
Discussion Starter #1 (Edited)
I just got back to the office from running an errand & my Jeep was running strong. After I pulled into a parking space, I turned it off & took the key out of the ignition & the seat slid back as usual. A few seconds later, the seat moved forward by itself, so I turned the key back to ON to reset my seat, but nothing happened. I started the car & no gauges work, the tach, speedometer & fuel gauge are all at 0. I don't know if it's a problem with the cluster, another module or what. I'm waiting on a mechanic to call me back to see if he can look at it today, because this is the only vehicle I have & can't drive with no speedometer or fuel gauge.

I was hit by someone in a 95 Acura on my driver's side last Sat. & had scrapes on the door & fender & the front wheel is damaged, but could that impact have damaged any control module? The other thought is could it need a new battery & would a low battery cause something like this? I bought my truck last July, it's a 2007 with 48,800 miles on it (before the odometer stopped showing:D) & I doubt that the scumbag dealership I got it from even checked the battery, since the air box was loaded with pine needles & the fluids in the differentials & transfer case hadn't even been checked.

Sorry for the little rant, I'm just frustrated with my collision damage because the adjuster called to tell me they've approved $170 for my repairs, which doesn't even take into account the damaged lip on my front wheel, but I'll have to let the body shop discuss that with the insurance company. Oh well, it can always be worse, at least I had no major damage & can still drive my baby until I get it in for the collision repair.

I'd appreciate any suggestions anyone can offer.

I just went out again & it's working. I pulled 3 diagnostic codes: U0114, U1403 & U1411
 

·
Premium Member
Joined
·
17,140 Posts
U codes are connection codes. Something somewhere isn't connecting right. Found this on a Commander site. Don't know if the codes are the same between the Commander and the GCSRT though.

U0114 = Lost communication with Final Drive Control Module

U1403 = Implausible Fuel Level Signal Received

U1411 = Implausible Fuel Volume Signal Received
 
1 - 2 of 2 Posts
Top