Cherokee SRT8 Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter · #1 ·
:mad:Hi everyone,

Heres the problem....the heater blower fan stopped working altogether for 2 days after one day of severe cold -20C. I put the truck in the garage and the next day it starts working again. But now 2 days later while sitting in the garage nothing works anymore. I hear a sort of clicking sound as if the switch controls are engaging but the blower is dead. Can anyone help? This a 2010 model SRT8.
 

·
Registered
Joined
·
2,169 Posts
Yep dealer for sure. You shouldn't be having problems this early.
 

·
Registered
Joined
·
3,353 Posts
If you're out of miles on the warranty then do not go to the dealer, they will empty the college fund for HVAC.

Chances are it is just the resistor and not the motor. I don't know specifically for this model Jeep, but when I did my wife's Jeep it took $20 and 2 min to change out the resistor. It isn't necessarily the resistor, but I'd say 90% of the time it is.

Does it not work at all? Have you tried all of the fan settings? (Hi-Lo (auto and not))
 

·
"guy with the crazy Jeep"
Joined
·
4,862 Posts
If you're out of miles on the warranty then do not go to the dealer, they will empty the college fund for HVAC.

Chances are it is just the resistor and not the motor. I don't know specifically for this model Jeep, but when I did my wife's Jeep it took $20 and $20 to change out the resistor. It isn't necessarily the resistor, but I'd say 90% of the time it is.

Does it not work at all? Have you tried all of the fan settings? (Hi-Lo (auto and not))
Same thing happened to my kid's Jeep's and it was the resister that was bad in both.
 

·
Registered
Joined
·
196 Posts
:mad:Hi everyone,

Heres the problem....the heater blower fan stopped working altogether for 2 days after one day of severe cold -20C. I put the truck in the garage and the next day it starts working again. But now 2 days later while sitting in the garage nothing works anymore. I hear a sort of clicking sound as if the switch controls are engaging but the blower is dead. Can anyone help? This a 2010 model SRT8.
Hi,
my bet is you got some moisture inside blower motor control module's socket frozen.
You don't have resistor, it's a canbus controlled module.
Try to unplug it and let it dry. It's located beneath th glove compartment.
 

·
Premium Member
Joined
·
377 Posts
:mad:Hi everyone,

Heres the problem....the heater blower fan stopped working altogether for 2 days after one day of severe cold -20C. I put the truck in the garage and the next day it starts working again. But now 2 days later while sitting in the garage nothing works anymore. I hear a sort of clicking sound as if the switch controls are engaging but the blower is dead. Can anyone help? This a 2010 model SRT8.
Did you happen to reverese over a snow bank?
Common issue with the GC would cause ice to build up in fan shroud and stop fan from moving.. heat up, and melt the motor. Look at the white plastic thingy in the center of the fan and see if theres any portion which turned black.

-Jim
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #8 ·
Thanks for the feedback

Truck is in my garage right now and I am gonna check out all the things you mentioned here. My truck has 25,000 km on it so if I cant figure out it myself then I will bring it to the dealer. It's just the time of going to the dealer and all and waiting is a b****! Thanks for the help.
 
1 - 8 of 8 Posts
Top