Cherokee SRT8 Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
400 Posts
Discussion Starter · #1 ·
So, some strange issues have been going on with my vehicle, and it seems the competence of the wonderful dealership nearby has gone down the drain, as nobody there seems to think it is abnormal to them. I know what is abnormal on MY vehicle, as I have driven it for the last 41 thousand miles. I will not take "that is normal" from someone about MY vehicle one more time. If you're in texas/dfw area...don't go to Grapevine CJD. They've gone down the drain. I'm beginning to think that it is because of THIS dealership that I have grown to MUCH dislike my Jeep as of lately. It's too bad the new 650-horse GT-500 is not til 2013, as if it were out now...i'm beginning to think that this jeep would be long gone.

Now that i've vented, on to the subject at hand. Please help me with whatever insight you may have...perhaps it may ease my being upset with the darn vehicle and I might get some enjoyment out of it again.

When I drive the vehicle mildly aggressively(as in for overtaking a vehicle) or pretty aggressively(beating the thing up), the vehicle seems as if it has an extra hesitation. It has a mild power loss, and the RPM's will bounce up and down as I try to push the vehicle to accelerate. It is VERY audible, as the Borla exhaust makes it like a sore thumb. My friends have even complained about the AWFUL irritating sound from the exhaust pitch/tone jumping up and down constantly when the vehicle shifts itself down on the highway. While the sound is bouncing up and down, you can visibly see the RPM's bouncing up and down on the Tachometer.

It does this mostly at speeds between 40 to 80, and may do it at higher speeds, but I have not tried to yet, so I cannot confirm.

If i do it in Manual Shifting operation, it is MUCH more apparent. At 60, a quick jab of the throttle (about 40% depressed and holding it) will leave the RPMs bouncing like a ball in any gear that can be used at the speed...third fourth and fifth.


during gentle driving...the issue is not apparent, but it does peak its ugly nose out once in a while.


BEAR IN MIND that the vehicle starts normally. Idles normally. Shifts exactly as it always has(quickly, firmly). It is throwing NO codes. Never had this sort of issue before.
 

·
Marathon Man
Joined
·
3,229 Posts
How long has this been going on?

My jeep sort of did the same thing for about 3-4 days when my throttle body started to go bad. I then got the red lightning bolt on the dash when trying to go up a steep hill.

Of course the dealership blamed my meth system for the problem even though I wasn't trying to get them to pay for a new one.
 

·
Registered
Joined
·
400 Posts
Discussion Starter · #5 ·
The issue has been goin on for about 3 weeks. it hasn't really gotten any worse, nor any better. It just started happening, and has stayed that way. I'll attempt to clean the maf tomorrow, thanks
 

·
Straight Up Beast SON!!!
Joined
·
17,142 Posts
The issue has been goin on for about 3 weeks. it hasn't really gotten any worse, nor any better. It just started happening, and has stayed that way. I'll attempt to clean the maf tomorrow, thanks
Yeah I have seen this type of issue with a bad MAF sensor, but I don't think our Jeeps have one..
 

·
Registered
Joined
·
1,671 Posts
The Jeeps dont have a MAF... video/sound clip could help...
 

·
Registered
Joined
·
8,243 Posts
Are you running a stock throttle body or aftermarket? What other mods do you have? Any CEL's?
 

·
That guy..
Joined
·
1,281 Posts
Sounds like the throttle body needs cleaned. Take a video for us.
 

·
Registered
Joined
·
400 Posts
Discussion Starter · #11 ·
will try to take a video when I get a chance.

The vehicle has exhaust and an intake. does not have a tune on it; hasn't for months in fact.

stock throttle body, stock everything else. No CEL though! and no codes to be pulled up on the predator either.
 

·
Registered
Joined
·
458 Posts
This is strange? I am experiencing almost the same thing. There is a hesitation between shifts and almost seems to shift to fast. I have all the mods listed below and even took the TB off, cleaned the heck out of it and the inside of the manifold, made sure that the catch can was empty and it was was, good fresh 93 mobile gas etc. Can't seem to figure this one out. Few weeks ago, I ran a 0-60 at 4.4 last night 5.0 with that annoying hesitation. Drives totally normal and runs good until I open it up from a standing start. When I though it into 1st and manually go though the gears, 1 shifts to 2nd pretty quick with this hesitation then again from 3rd to 4th etc. Any ideas would be greatly appreciated.
 

·
Registered
Joined
·
400 Posts
Discussion Starter · #14 ·
My problems have been solved finally. The bouncing rpms under load was due to the torque converter crapping out. Strange shifts were due to the trans clutches going out. All caused from the trans pump going bad and not feeding enough pressure.

One new trans, converter, pump, and trans cooler later..... All is flawless.
 

·
Registered
Joined
·
458 Posts
OK, latest up date, after explaining this to Jose, Knuckles he recommended raising the setting under rev limiter, drive up to 500, it was at 0. I did that and wholly crap, it's good as gold. screams. Thanks Jose.
 

·
Straight Up Beast SON!!!
Joined
·
17,142 Posts
OK, latest up date, after explaining this to Jose, Knuckles he recommended raising the setting under rev limiter, drive up to 500, it was at 0. I did that and wholly crap, it's good as gold. screams. Thanks Jose.
Anytime bro!
 

·
Straight Up Beast SON!!!
Joined
·
17,142 Posts
is that a predator type change or more customish?
He did it on the Predator and then can email his tuner to send him a revision tune with the change he did if he wants..
 

·
Registered
Joined
·
458 Posts
Check your Rev limiter and see where it is set at? It worked for me. If in fact you see that was the issue, I went back in and zeroed it out and emailed my last tune to Johan and he made the change. I re entered the tune and it works great.
 
1 - 20 of 22 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top