Cherokee SRT8 Forum banner

1 - 20 of 31 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I'm trying to install a Mopar TCM in my 2010 srt8. I've read most of the posts online and when I look for it under the dash it is no where to be found. Could it be located somewhere else other then the area around the steering column? I have the Mopar unit so I'm aware of what it looks like, but I don't see it.

Thanks

Steve
 

·
Super Moderator
Joined
·
10,999 Posts
Behind the steering column on the right hand side behind some sound insulation. Look and you will see a wire loom going behind it. You will have to rip or cut the insulation to get it out
 

·
Premium Member
Joined
·
5,199 Posts
Can it be under one of the front seats?


Sent from my Autoguide iPhone app
 

·
Straight Up Beast SON!!!
Joined
·
17,141 Posts
Can it be under one of the front seats?


Sent from my Autoguide iPhone app
Nope..... Its high up in there like Chad said....
 

·
Premium Whore (Lifetime)
Joined
·
3,065 Posts
It's in there, just not visible.;) Kinda in a little pouch of insulation above the steering column, against the dash. Reach your arm waaaay up there, you'll feel it. There is enough slack in the wiring to bring it down to the access panel to work on it, just have to untangle it from all the crap under there first.
 

·
Super Moderator
Joined
·
10,999 Posts
  • Like
Reactions: SRT8VIC...

·
Straight Up Beast SON!!!
Joined
·
17,141 Posts

·
Registered
Joined
·
5,009 Posts
Where's the double face palm?
 

·
Registered
Joined
·
65 Posts
Yeah, I thought the same thing when I looked under there. I stuck my hand up there thinking I could just pull it out and plug the new one in. Just grab the insulation and start pulling. ONce you get that out of the way it takes 30 seconds. Side note, I wasn't sure what to expect, but have been pleased with it. I know a lot of people weren't happy with them, and I wasn't super impressed when I first put it in. But after a few days I can really tell a difference. I pulled out a few days ago from a spot I frequent and have to cross six lanes of traffic. Felt nasty, in a good way. :)
 

·
Premium Member
Joined
·
260 Posts
Steve, I just put in a mopar TCM today and used Johan's new crom file to raise the shift points and set the rear axle ratio. It worked fine on my Trinity. It is still just a beta version: trinity_dcx_gas-1t08da_update.crom. Diablo has not released it yet but if interested send Johan an email at [email protected] and I am sure he will send you a copy. I think there is also a crom file for the pred.

Kent
 

·
Premium Member
Joined
·
5,199 Posts
i have a question about this mtcm. i put it in on monday and i THINK i did the learn process right but still not sure. im told i should ne pretty hard on the truck right now.. should i bee and should i be driving it around in autostick doing upshifts and downshifts or just leave it in auto and try to drive the truck hard?? i wanna make sure i get this thing set correctly. thnaks in advance
 

·
Premium Member
Joined
·
5,199 Posts
Soo I just need to do wot runs? What about part throttle/ around town stuff??


Sent from my Autoguide iPhone app
 

·
Premium Member
Joined
·
5,199 Posts
how long does it take to learn and be all set?? how does urs shift at wot thru the gears?? mine sounds almost like the truck farts when it shifts.lol. ur too?
 

·
Registered
Joined
·
2,487 Posts
how long does it take to learn and be all set?? how does urs shift at wot thru the gears?? mine sounds almost like the truck farts when it shifts.lol. ur too?
not sure how long it takes, have read its a slow learning tcm. WOT upshifts geting firmer and more direct with every run, downshifts are getting very solid after the run. was getting some logs today for Johan and was coasting from 120mph ish to a stop and when it downshifted it just about put me into the steering wheel wasnt ready at all for that. been working on it for a little over a week now and it keeps getting better, farting though cant say mine does that
 

·
Premium Member
Joined
·
5,199 Posts
ok soo the last few days ive been doing a ton of wot's and logging them. and this mtcm dosnt seem right at the WOT shifts.. its shifting at around 6200 in first then 6400 the rest of the gears but it still dosnt seem like firm shifts to me at all. can i be wrong? the truck still kinda sounds like its letting out a small fart when it shifts.. can there be something wrong with the tcm or does it still need more time to adjust?????? also not too mention when i run my evic time im running slow as hell and my evic is on point with the track times. its giving me 12.5 and higher when i was running 12.1-12.2's before:(
 

·
Straight Up Beast SON!!!
Joined
·
17,141 Posts
ok soo the last few days ive been doing a ton of wot's and logging them. and this mtcm dosnt seem right at the WOT shifts.. its shifting at around 6200 in first then 6400 the rest of the gears but it still dosnt seem like firm shifts to me at all. can i be wrong? the truck still kinda sounds like its letting out a small fart when it shifts.. can there be something wrong with the tcm or does it still need more time to adjust?????? also not too mention when i run my evic time im running slow as hell and my evic is on point with the track times. its giving me 12.5 and higher when i was running 12.1-12.2's before:(
You shift points sound normal too me as this MPTCM is known for short shifting.... The way I get around short shifting is to reset the tcm adaptives and right after beat the living hell out of your beast.... Also you can try to remove the abs pump fuse as I believe it could help in the short shifts only for track use only though. As far as the firmness of the shifts mine does shift hard, but not as hard as if I had the stock TCM installed..... Also the reason why you ran 12.5 today vs. your 12.1 is cuz the weather is in the 50's probably so.the DA is higher vs. The -1400 DA you ran your 12.1 in....
 
  • Like
Reactions: A.V.GCSRT8
1 - 20 of 31 Posts
Top