Cherokee SRT8 Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi all. I have a 2014 GC SRT with 160K miles on it. About 10K ago, I noticed that it was sometimes misfiring when I accelerate from a stop. At least, that is what it feels like. But there are no codes generated. Dealer drove it and said he suspected that it needed plugs. I replaced then with the same model NGKs that were in it. And no change. I replaced the coil packs too, and no change. If I drive it in ECO mode, it is way way worse...I can just feel it...pop...pop...pop...pop...pop. In SPORT mode, it is way better, and sometimes seems to go away completely. The engine sounds good, and I don't hear anything mechanical brewing in it. Anyone have any ideas? If it was really misfiring, wouldn't I see a code being set?
 

·
Registered
Joined
·
7 Posts
I have the very same issue. I'm gona try fuel, throttle body and upper intake cleaning treatments. See if things improve.
 

·
Premium Member
2013 Wk2 Srt8
Joined
·
163 Posts
Could be perhaps injector issue did you change octane rating or quality of the fuel around that time or could be a small vacuum leak which would be obvious in the auto mode where fuel tables and timing is more on the lean side
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Please keep me posted!? I have now replaced the injectors with new OEM, and no change. Throttle Body was a little dirty, so I cleaned that too...no change! I drive it every day, but it is so frustrating!
 

·
Registered
Joined
·
5 Posts
I've had misfires on a 2015 GC SRT (124k miles) that did not trigger CEL. But it did show up on a fancy scan tool when WOT. It was a ceased lifter on cylinder 7. The weird thing is that there was ticking, but it was very faint. I thought it was an exhaust leak. But the misfires and hesitation got worse over time until I decided to take the car to a mechanic.

I switched to a non-mds cam and lifters, and changed all the related gaskets and valve seals while we were in there.

I hope your issue is not as serious.
 

·
Registered
Joined
·
7 Posts
I'm getting no DTC codes so no misfires in my case. It's looking more and more like a rear differential issue.

I will be changing the fluid and adding the slipping agent during this oil change. Does anyone know if the SRT has some kind of clutches built into the rear differential? Are these a ware item or if they fail you replace the whole differential case?
 
1 - 6 of 6 Posts
Top