Cherokee SRT8 Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi guys I been having some bad stress lately
My Jeep has been over heating pass the 215 with the ac on
I put a new thermostat 180 about a month ago
I just did a flush last week
This weekend I put it new radiator and new water pump
I drove it a bit today after picking it up from Mecanics
Turn on the ac and slowly started To up again around the 220 arrow
Fans are working good.
theres a lot of pressure on the hose looks like the water/coolant isn’t circulating right even when the truck is cold
Only has 80K miles
Mechanic is telling me the motor is the problem ?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Mechanic installed it tbh I’m not so sure
This weekend after replacing radiator and water pump he actually took off the thermostat he told me to run it like that this week bc there’s too much pressure on The water hose
Telling me most likely is gona be the heads
But right now jeep has no thermostat
 

·
Registered
Joined
·
44 Posts
I had the same issue with mine a while back. Changed everything you did and turned out that the heads went bad from the consistent overheating. I would get something fixed, then overheated, fixed something else happened again. Finally went to a stealership that specialized in srt vehicles and was told the heads where bad from the on and off overheating. Fixed the top end of the jeep haven't had any issues since and its been a few years.
 

·
Registered
Joined
·
44 Posts
It wasn't cheap it was a few grand if i recall. But again no issues since. On a side note I never had an leaking from the head gasket or oil leaking out, just all the different shops never fixing the overall program or figuring it out until it was to late = warped alum heads
 

·
Registered
Joined
·
16 Posts
HEY I Used to have the same issue!!!!!

I 180 thermostat i put in caused the same issues. I would even have issues where the radiator cap would spew out under pressure..

just replace the thermostat with a new OEM 210 unit and the problem should go away..

ALSO THE MOST IMPORTANT THING NOBODY HAS YET TO MENTION!!!!!! REPLACE THE UPPER HOSE WITH A 5.7 HEMI Grand Cherokee hose!!!!!!

The plastic 45* elbow WILL BREAK !!!!!

the 5.7 hose is a one piece unit, u just have to trim the shrowd some

Hi guys I been having some bad stress lately
My Jeep has been over heating pass the 215 with the ac on
I put a new thermostat 180 about a month ago
I just did a flush last week
This weekend I put it new radiator and new water pump
I drove it a bit today after picking it up from Mecanics
Turn on the ac and slowly started To up again around the 220 arrow
Fans are working good.
theres a lot of pressure on the hose looks like the water/coolant isn’t circulating right even when the truck is cold
Only has 80K miles
Mechanic is telling me the motor is the problem ?
 

·
Registered
Joined
·
442 Posts
Did you adjust the fan settings? Don't know if someone mentioned already

Sent from my SM-G965U using Tapatalk
 

·
Registered
Joined
·
667 Posts
Most of us running a 180 have our fan settings adjusted with a Diablosport handheld tuner , myself I have my fans set @high speeds @192 @low speeds @177 and @mid speeds @192
 

·
Registered
Joined
·
998 Posts

There is no MS fan, so just worry about the LS & HS as stated above
 

·
BlaBlaBla
Joined
·
5,197 Posts
OEM stock thermostat works just fine. I’ve been driving, racing and beating on my Jeep since day one. The thermostat has never been an issue.
I don’t know, but seems to me that issues start when the system is modified.


[email protected]
 

·
Registered
Joined
·
5,015 Posts
Did you or your mechanic make sure all the air is out of the system? It sounds like you may have an air pocket somewhere.
 
1 - 17 of 17 Posts
Top