Cherokee SRT8 Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
736 Posts
Discussion Starter · #1 ·
I dropped my truck at the dealer this morning for a water pump because coolant was leaking from there. Dealer calls me and tells me they did the water pump and they also changed the thermostat because "it wasn't opening"

I told them that it had an aftermarket thermostat at a lower temp rating and i didn't want the stock one back in it...

he's looking to see if they have the old stat and he's going to call me back.

What a PITA.
 

·
Registered
2010 WK1 coming soon......
Joined
·
1,508 Posts
I dropped my truck at the dealer this morning for a water pump because coolant was leaking from there. Dealer calls me and tells me they did the water pump and they also changed the thermostat because "it wasn't opening"

I told them that it had an aftermarket thermostat at a lower temp rating and i didn't want the stock one back in it...

he's looking to see if they have the old stat and he's going to call me back.

What a PITA.

Did you give them approval to change the thermostat? If not they have no right to replace it. If they cant find the old one they will have to buy you a new one:D
 

·
Registered
Joined
·
736 Posts
Discussion Starter · #3 ·
Did you give them approval to change the thermostat? If not they have no right to replace it. If they cant find the old one they will have to buy you a new one:D
I only authorized the water pump. I get the fact that i might get a new stat out of this but what a PITA either way.
 

·
Registered
Joined
·
736 Posts
Discussion Starter · #5 ·
Yeah, I agree. Hopefully they will fix the issue, but I'd make sure they install it and not just tell you they did.

well...i'll know inside of ten minutes when my temp gauge will either be pointing towards the low side like it normally does or if it's pegged back in the middle.
 

·
Straight Up Beast SON!!!
Joined
·
17,141 Posts
Your problem was probably the Jet 180 all along I would asume.... I had my water pump changed and the jet 180 was left alone... Then I ended up changing it right after cuz it was not .opening anymore as well....
 

·
Registered
Joined
·
736 Posts
Discussion Starter · #7 ·
damn it. now i'm paranoid about this whole thing and i'm going to end up buying another stat and changing it out just to make sure.....

f*cking dealerships....
 

·
Registered
Joined
·
736 Posts
Discussion Starter · #8 ·
Your problem was probably the Jet 180 all along I would asume.... I had my water pump changed and the jet 180 was left alone... Then I ended up changing it right after cuz it was not .opening anymore as well....
so what did you change it to? cause i'm going to end up up changing the thermostat now anyway just to be safe...
 

·
Registered
Joined
·
6,210 Posts
Go to autozone and give them this part number "4128" its a motorad 180 tstat. Reuse the gasket from the tstat in the Jeep now.

I have that tstat in my Jeep.
 

·
Registered
Joined
·
181 Posts
Go to autozone and give them this part number "4128" its a motorad 180 tstat. Reuse the gasket from the tstat in the Jeep now.

I have that tstat in my Jeep.
+1, I ran the Motorad 4128 in my 300C and swapped it over to my Jeep, going on over 1.5 yrs and no problems.
 

·
Straight Up Beast SON!!!
Joined
·
17,141 Posts
so what did you change it to? cause i'm going to end up up changing the thermostat now anyway just to be safe...
I installed another Jet 180* T-stat and just purchased another one as a backup. Also note that the one that went bad on me was in the Jeep for close to 2 years already....
 
  • Like
Reactions: m4xm1l10n

·
Straight Up Beast SON!!!
Joined
·
17,141 Posts
+1, I ran the Motorad 4128 in my 300C and swapped it over to my Jeep, going on over 1.5 yrs and no problems.
Good to know that is a reliable 180* T-stat as well man...
 

·
Premium Member
Joined
·
16,354 Posts
well...i'll know inside of ten minutes when my temp gauge will either be pointing towards the low side like it normally does or if it's pegged back in the middle.
True.....

I installed another Jet 180* T-stat and just purchased another one as a backup. Also note that the one that went bad on me was in the Jeep for close to 2 years already....
Yeah, mine has been warmer than normal. I bought one 2 weeks ago and waiting to install it when I get home.
 

·
Straight Up Beast SON!!!
Joined
·
17,141 Posts
True.....



Yeah, mine has been warmer than normal. I bought one 2 weeks ago and waiting to install it when I get home.
Should fix you up Johnny....
 

·
Straight Up Beast SON!!!
Joined
·
17,141 Posts
Not saying that it has any relationship to the failed pump in this thread, but anyone remember this old thread and the statement from Chrysler?

http://www.cherokeesrt8.com/forums/showthread.php?t=47273
Thanks for thr reminder Ted as I had missed that thread! My Jeep was in the stealership cuz the waterpump was leaking, but I guess the tech missed that I had a Jet 180 T-stat in there. At the time when my T-stst was going bad the needle would sit at 215< so thats probably why he did not think anything of it would be my guess.
 

·
Registered
Joined
·
736 Posts
Discussion Starter · #17 ·
I installed another Jet 180* T-stat and just purchased another one as a backup. Also note that the one that went bad on me was in the Jeep for close to 2 years already....
I assume you knew it went bad when your coolant temp got super hot correct?
 

·
Straight Up Beast SON!!!
Joined
·
17,141 Posts
I assume you knew it went bad when your coolant temp got super hot correct?
Yup! It got so hot that it hit the Red one time and after that I did not go WOT anymore or else taht engine would blow up.... I did not say anything to the stealership since they were replacing my waterpump already, so I said I can afford 34 bucks for a new T stat myself.. There was no way I was going to tell the stealership the Jet 180 was in there... Signs of a T-stat going bad is when it can not keep a stable engine temp and it keeps drifting on you especially if it goes past 215*...
 

·
Premium Member
Joined
·
5,199 Posts
usually its the gasket that gives u the problem. not so much the t-stat.
 

·
Administrator
Joined
·
5,880 Posts
Not saying that it has any relationship to the failed pump in this thread, but anyone remember this old thread and the statement from Chrysler?

http://www.cherokeesrt8.com/forums/showthread.php?t=47273
I'd say it has a lot to do with that thread and that the OP is lucky they didn't deny the warranty claim. Overall I think the OP has a good dealer, other dealers wouldn't honour it I'm sure. Be thankful for that and just buy another one yourself.

Bernie
 
1 - 20 of 21 Posts
Top