Cherokee SRT8 Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter · #1 ·
So I was using the outlet the other day for my laptop while recording some logs and now suddenly it won't turn on anymore. The light comes on on the dash for about 2 seconds then dims off when i press the button. It wont stay on. I checked all the fuses I believed to be the outlet both inside the jeep and under the hood but all seem fine. I checked the relay and seems fine as well. Can someone identify what fuses exactly are for that rear outlet and if anyone has had a similar problem and the solution. What a bummer! Thought it was cool I didnt have to bring my invertor anymore for the laptop. Guess not!:confused:
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #3 ·
Seems likely it would be a fuse but i dont see one blown anywhere. The fact that it worked a week ago or so tells me something changed recently after I used it. Weird.:rolleyes:
 

·
Premium Member
Joined
·
94 Posts
exact same thing happened to me when i was using a power outlet air pump... I found one bad fuse for the cigarette lighter but after i replaced it and now only that one works. The other two power outlets still do not work... I have checked all the fuses in the car and still nothing???
 

·
Registered
Joined
·
589 Posts
Me too! I thought it was the crappy plug I bought.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top