Cherokee SRT8 Forum banner

1 - 20 of 52 Posts

·
Registered
Joined
·
170 Posts
Discussion Starter · #1 ·
Ok guys, I did my research and looked over a lot of the forums mentioning this problem with the upper hose coming off while you are driving on our SRT8s. The problem is the plastic bend that connect the hose that either cracks or the hose slides off of. I also noticed a huge amount of guys having that same issue. My hose has come off 2 times in the last 3 weeks or so and also the first time because of the amount of coolant that I lost it slipped my belt so hard I lost power steering. If a lot of people are having this issue and it can lead to you loosing power steering at some point while the vehicle is moving this would be a safety issue and could result in a recall on these things for our cars. I'm sorry I don't mind spending $15 on an aftermarket hose but after sitting there detailing my engine bay for the second time in 3 weeks I'm fed up with this issue. I want to start a list of how many people had this issue happen to them (the upper radiator hose coming off). I will with the help of some members send this thread to Chrysler Group LLC and try to get this issue resolved as a recall for the car.

I don't know how effective this will be but once you have this issue and look at your cars engine bay this will be the thread you go cry to :D

Thanks

KAMIL
 

·
Registered
Joined
·
812 Posts
happened to me 4 times in one week and i spent easily over 150 bucks on coolant and not to mention the 3 details on the motor she currently still has coolant spray on the bay till this stops. I replaced one of the clamps where it has been coming off from and it hasn't happened since but I'm still replacing the whole hose I don't want to be affraid to nail it on the highway and break down.
 

·
Registered
Joined
·
170 Posts
Discussion Starter · #3 ·
I just ordered a hose as well from rock auto but I rather have an OEM replacement that actually holds. Too bad these things happen.
 

·
Registered
Joined
·
907 Posts
Hey everybody, i made a post earlier tonight about me buying the one piece upper hose from dayco, im installing it tomorrow and will post pictures afterwards.
 

·
Registered
Joined
·
907 Posts
roughly 45min-1hr, i took my time and took off my bwoody intake and moved it out of the way so i could access the thermostat housing easier.
 

·
Registered
Joined
·
91 Posts
Mine came off, blew shit everywhere, I thought the thermostat gave up so i replaced it with a stocker, took me about 20 min, took longer to bleed all the air out
 

·
Registered
Joined
·
673 Posts
My 180 t stat is on its way out....everytime I pin it and run it out hard it builds up heat and pressure and then boom!

I cracked the lip off the end of the elbow when it blew last so now its just a matter of time before it happens again. Unfortunately the elbows come as one piece with the hose, and its over $100 f'ing bucks from the stealer...just to have it happen again at some point in the future. Wtf

Where is this one piece hose people speak of...link? Does anyone make an aluminum elbow?
 

·
Registered
Joined
·
907 Posts
just go to ebay or rock auto and type in "dayco 72226" hose, it'll bring it up, its available on several websites, like amazon and ownster, so take your pick. :)
 

·
Registered
Joined
·
907 Posts
if you get a chance, look at my post on this hose, i posted pics today, and what i had to do to get it to work, didnt take much and it works great
 

·
Registered
Joined
·
170 Posts
Discussion Starter · #13 ·
Just picked up mine from NAPA and it fits fine. No cutting needed at all. I put 2 rubber seals on the radiator cover where the hose comes into contact so that it does not get damaged. Other than that perfect fit. on the receipt it says part number 9700 but not sure if that is correct.

Good Luck. I made multiple hard launches with the car and also drove it around to test if it would not come off (so far so good)
 

·
Straight Up Beast SON!!!
Joined
·
17,141 Posts
I have had my rig for 3 years now and never had any issues with the stock upper hose hitting any pulley... I have tracked my beast many times too... Good find on the 1 piece upper hose you found.....
 

·
Registered
Joined
·
159 Posts
Just had this happen to me today. Fortunately i caught it before the temp rose above 240. I have the motorad 180 tstat and Stant 18lb locking cap. Kamil, what parts do I need to replace that crappy plastic elbow? What's the consensus on the problem, is it the tstat or the cap? Anyone have better luck with the Jet tstat? I never want this to happen again...I figure it doesn't take much overheating to really do some damage and warp heads.
 

·
Registered
Joined
·
907 Posts
Me and Kamil pretty much did the same thing, just the one pc hose from your choice of vendors that we have posted on here (dayco, napa, rockauto, etc) and a coupld of GOOD clamps, that should be about it, sir, hope you're install on your hose goes well, let us know!!!!
 

·
Registered
Joined
·
170 Posts
Discussion Starter · #17 ·
Hey Guys, I ended up buying 2 hoses one from rock auto and the other from a local NAPA auto parts store. I have a brand new dayco 72226 upper radiator hose that I can sell someone since I have the same exact thing already on the car. If anyone is interested you can PM me and we can work out a deal. I also have the Valvoline ZEREX coolant that is pre mixed and you can use if you had this happen. I bought 3 GAL of it and only ended up using 3/4 of 1 gal because of my blowout. Willing to give someone a deal on the hose and the coolant since I know what kind of pain this really is.
 

·
Registered
Joined
·
2,597 Posts
Thanks for this post. I've read other threads about the upper radiator hose.problems but this definitely persuaded me to install the one piece as soon as I have time to get under the hood. I just have hose clamps that seem to be holding for now but definitely don't want to be detailing my engine bay anymore than I have to or worrying about my engine overheating.....I do find myself worrying about it all the time and check it every week when I wash my car.

Kris
 

·
Registered
Joined
·
196 Posts
Also had problems with upper hose during extreme cold (-40F=-40С). Some amount of antifreeze spilled exactly at plastic elbow area. Bought Dayco one-piece hosefrom rockauto . Will install it next weekends.
 

·
Registered
Joined
·
673 Posts
Just had this happen to me today. Fortunately i caught it before the temp rose above 240. I have the motorad 180 tstat and Stant 18lb locking cap. Kamil, what parts do I need to replace that crappy plastic elbow? What's the consensus on the problem, is it the tstat or the cap? Anyone have better luck with the Jet tstat? I never want this to happen again...I figure it doesn't take much overheating to really do some damage and warp heads.
The problem is that almost all 180 t stats are junk. They're only good for about 6mo to a year.

They start taking a long time to open up under wide open throttle....the temps and pressure rises until BOOM goes the upper hose, which usually splits the end/lip off the plastic elbow while sending high-dollar coolant everywhere.

Even when you get your new hose, I wouldn't romp on it until you replace your t stat with a new one. I did this upgrade and plan on posting a thread on the "how-to" with pics for the newbs.
 
1 - 20 of 52 Posts
Top