Cherokee SRT8 Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have 2006 WK1 with some interesting electrical issues. Occasionally when I start my Jeep, the horn, brights or fog lights (or combination of the three) will turn on and stay on until I disconnect the battery. Turning the Jeep off, removing the key, turning the switches on/off, etc all have no effect.


Are all of these systems on a single switch or relay? That would be my first thought. Other than that possible wiring gone bad or even the ECM? Anyone had this problem before?

Thanks all
 

·
Registered
Joined
·
3,353 Posts
I don't know about a relay being bad, if I recall correctly, a relay performs a single function. For example - turn signals or fuel pump. If a relay does more than 1 function it would power 2 devices simultaneously.

Though... you have no less than 3 things turning on (which falls in line with the symptoms I described earlier), that isn't how a relay works.

The headlights are on a switch. The horn is on a switch, same goes for the fogs. They may all be functions within the MFS (Multi Function Switch), which if it went bad or has a short somewhere could potentially cause what you're experiencing. Maybe you got water in the fuse box and a bunch of relays went bad.

Does your horn work when you want it to? Does your cruise control work? The rest of the steering wheel functions? IF, when the problem is occurring, you turn the steering wheel from lock to lock (all the way back and forth) does the noise continue?
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top