Cherokee SRT8 Forum banner

1 - 20 of 34 Posts

·
Premium Member
Joined
·
1,406 Posts
Discussion Starter #1
Soo i been thinking dat my cam is installed wrong..frist i thought is it even possible to install it wrong..then i emailed Johan n he said its possible for a incorrect degree or somthing...since i got it installed i always ran slower times then b4 da cam... Soo im thinking when i go to king motorsport for da sc ill ask em to check it out..but can it damage anything if i still drive it wit it installed wrong?

Thanks
 

·
That guy..
Joined
·
1,281 Posts
You can install it off a tooth.. Who did the install?

And yes you can potentially harm your engine parts by driving it if its retarded or advanced.
 
  • Like
Reactions: Rufjatt

·
Registered
Joined
·
8,340 Posts
I don't think it can be a good thing if its in there wrong
 
  • Like
Reactions: Rufjatt

·
Premium Member
Joined
·
1,406 Posts
Discussion Starter #4
I got it installed near my place it was called performace driven but now they out of business n i have no other performace shops dat i knw of around here :(
 

·
That guy..
Joined
·
1,281 Posts
Sounds like you need to find a shop to tear the front cover off. Or take it off yourself.

Must be why they went out of business.
 

·
Straight Up Beast SON!!!
Joined
·
17,141 Posts
Soo i been thinking dat my cam is installed wrong..frist i thought is it even possible to install it wrong..then i emailed Johan n he said its possible for a incorrect degree or somthing...since i got it installed i always ran slower times then b4 da cam... Soo im thinking when i go to king motorsport for da sc ill ask em to check it out..but can it damage anything if i still drive it wit it installed wrong?

Thanks
What was your ET before and after the cam?
 

·
Premium Member
Joined
·
1,406 Posts
Discussion Starter #7
What was your ET before and after the cam?
Well my 0-60 b4 was 4.2 now with da cam its 4.4.. plus i got the 114 +4 which i heard is supposed spin all ur tires.no tires spinning here
 

·
Registered
Joined
·
8,340 Posts
Well my 0-60 b4 was 4.2 now with da cam its 4.4.. plus i got the 114 +4 which i heard is supposed spin all ur tires.no tires spinning here
Something isn't right.....
 

·
Premium Member
Joined
·
1,406 Posts
Discussion Starter #9

·
Registered
Joined
·
8,340 Posts
Soo u think somthing wrong with da install right?
I mean, i doubt its the tune.... the only thing that would even partially explain a higher 0-60 would be if you were spinning tires.... and you say your not... Unless the 4.2 was on a colddd day and the 4.4 was on a hot day... But it seems like something isn't right with the install, cause i doubt johan f'd up a tune....


Does it drive ok?
 

·
Premium Member
Joined
·
1,406 Posts
Discussion Starter #11
I mean, i doubt its the tune.... the only thing that would even partially explain a higher 0-60 would be if you were spinning tires.... and you say your not... Unless the 4.2 was on a colddd day and the 4.4 was on a hot day... But it seems like something isn't right with the install, cause i doubt johan f'd up a tune....


Does it drive ok?
Yeah it drives normall just seems lil slow...or im just going nuts
 

·
Premium Whore (Lifetime)
Joined
·
3,065 Posts
Whats your A/F ratio like? Do you have any STKR or LTKR in your logs? Have you tried adding 2 degrees of timing and logging? As asked above, were the 0-60 runs done on the same DA?
 

·
Straight Up Beast SON!!!
Joined
·
17,141 Posts
Well my 0-60 b4 was 4.2 now with da cam its 4.4.. plus i got the 114 +4 which i heard is supposed spin all ur tires no tires spinning here
I have the 0* Little boy and my feels real strong off the line... A few days ago I took my jeep for a spin and it was late at nite around high 40's to low 50's and my traction control kicked in from 1st to 2nd gear, which has never happened before. Normally mine will spin the tires even in 90* weather.... This is also on a tune running 24* tops as well.... If I was you I would take your Jeep to a dragstrip just to see how your jeep runs... I see you run a Borla Type S versus me who runs a Corsa with headers...
 

·
Premium Whore (Lifetime)
Joined
·
3,065 Posts
I have first hand experience with a botched cam install, I was sent the 5.7 version of the cam I ordered and never noticed, neither did my installer. Fortunately it was the same specs but with 113+2 LSA instead of 113. The Jeep would rip off the line and then run out of steam in the high rpm.
 

·
Premium Member
Joined
·
1,406 Posts
Discussion Starter #16
Its going get lil cold this week ill go to da same place n see how it pulls...my a/f is 12 at wot normal driving is like 14.9 to 15.2
 

·
Registered
Joined
·
14,287 Posts
Is it a "top end" cam? How does it pull at high rpms?

Are you throwing check engine lights?

Going into limp mode?

What are the cam specs?
 

·
Registered
Joined
·
11,237 Posts
Who did u buy the CAM from ?
 

·
Premium Member
Joined
·
1,406 Posts
Discussion Starter #19
I got it from mwfp chris i think is his name he helped me out
 
1 - 20 of 34 Posts
Top