Cherokee SRT8 Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
1,156 Posts
Discussion Starter #1
Im hoping this is the right place to post.. I just recently noticed that the blue backlight on my instument panel is no longer working.

Is this anything you have encountered before ? :confused:

note: its the blue light that runs around the tach, speedo, gas gauge and water temp
 

·
Registered
Joined
·
1,156 Posts
Discussion Starter #3 (Edited)
really ?!? haha well isnt that slightly embarassing ... I could swear it used to light up at night :s

any reason why I can't see it at all now though ? - perhaps I should check my optical perscription
 

·
Registered
Joined
·
1,156 Posts
Discussion Starter #5
hahaha ... Just checked, its still there :lol:



So just to clarify, the blue ring is not visble outside of daylight ? - I can see it during the day but nothing when its dark
 

·
Registered
Joined
·
1,156 Posts
Discussion Starter #7
that long weekend must have done me in .... sheesh !!! :lol:
 

·
Registered
Joined
·
1,249 Posts
I think it does sort of reflect light in a weird way, but it's not internally lit. This isn't as embarrassing as your performance in the ALDS so don't worry about it. . .
 

·
Registered
Joined
·
8,340 Posts
I thought the same thing for a while.... lol.
 

·
Registered
Joined
·
1,156 Posts
Discussion Starter #11
well I'm glad I gave you all a chuckle on this fine Tuesday evening :p
 

·
Registered
Joined
·
5,047 Posts
You can mark you calendar off this question popping up

Every three months or so

Some one should do a pole as to how many of us thought the the rings lit up, I was one :D
 

·
Registered
Joined
·
567 Posts
When I first bought mine I swore they lite up too. I wish they did, I think it would look pretty cool. That's one cool thing about the 2012, the gauge cluster looks awesome.
 
1 - 13 of 13 Posts
Top