Cherokee SRT8 Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter #1
I purchased a 2 bar map part #050332224ab for my 2007, when i plug it in i immediately get a low baro cel and the tps red lightning bolt, the instant i unplug it both issues go away, this happens with either 1 bar or 2 bar tune from diablotoona so my first assumption is a pinout issue as the connectors are 180° different as far as the alignment ridge, has anyone had this issue? The part number crosses to a 2014 ish dodge but is the pinout different on a 2007 jeep?
Thanks for your help guys!
 

·
Registered
Joined
·
9 Posts
Had this exact same issue with Johan tuning my buddies whipple Durango. Ended up using the stock sensor but now the engine is built and we are about to fire it up. He blamed it on diablo T1000 not playing nice. Now have tune loaded with T2 module but waiting on some fuel fittings to find out if issue will be resolved. Guessing it’s not the SW being your having same problem with HP
 

·
Registered
Joined
·
83 Posts
Discussion Starter #8
Had this exact same issue with Johan tuning my buddies whipple Durango. Ended up using the stock sensor but now the engine is built and we are about to fire it up. He blamed it on diablo T1000 not playing nice. Now have tune loaded with T2 module but waiting on some fuel fittings to find out if issue will be resolved. Guessing it’s not the SW being your having same problem with HP
Map reading is 25 inhg spot on but baro reading is 32 inhg,
I'm hoping that the cmr program allows to custom scaling to get baro to 25 inhg, i know i can do it with my diesel tuning software so i don't think there would be an issue with cmr software allowing it as well, just for reference my digital barometer shows 24.48 inhg.
 

·
Registered
Joined
·
9 Posts
We were seeing both MAP and Baro readings maxed out to like negative 99 or something so problem may be a little different.

I imagine CMR allows for scaling like the HP tuners I’m used to. But it’s probably much more complicated
 

·
Registered
Joined
·
83 Posts
Discussion Starter #11
We were seeing both MAP and Baro readings maxed out to like negative 99 or something so problem may be a little different.

I imagine CMR allows for scaling like the HP tuners I’m used to. But it’s probably much more complicated

What map sensor are you using?
 

·
Registered
Joined
·
7,777 Posts
Do you know if cmr software allows separate baro scaling?


I’ve ran a 2 bar on my jeep and it was scaled correctly with CMR and it has been time and time again for others running much more boost than I was.


If I remember correctly it was a SRT-4 2 BAR sensor that needed to be mounted upside down because of its angle. Additionally the wiring harness was a little tight so I extended it a bit.
 

·
Registered
Joined
·
83 Posts
Discussion Starter #14
Do you know if cmr software allows separate baro scaling?


I’ve ran a 2 bar on my jeep and it was scaled correctly with CMR and it has been time and time again for others running much more boost than I was.


If I remember correctly it was a SRT-4 2 BAR sensor that needed to be mounted upside down because of its angle. Additionally the wiring harness was a little tight so I extended it a bit.
Thanks for the information!!!!!!!!, I'll try that today.
 

·
Registered
Joined
·
83 Posts
Discussion Starter #15
Do you know if cmr software allows separate baro scaling?


I’ve ran a 2 bar on my jeep and it was scaled correctly with CMR and it has been time and time again for others running much more boost than I was.


If I remember correctly it was a SRT-4 2 BAR sensor that needed to be mounted upside down because of its angle. Additionally the wiring harness was a little tight so I extended it a bit.
I have 1 more question for you, you are just using the srt4 map right, not this tips adapter thing or anything else right? Your map is directly bolted to your manifold? Sorry to bug you so much viking757 but you are a wealth of information on these jeeps. Thanks again!!!!
 

·
Registered
Joined
·
9 Posts
Can’t speak for Viking, but we are using factory 2 bar SRT4 sensor straight into manifold. Low and behold, same thing happened half hour ago with Johan tuning. Hoping to find a solution very soon
 

·
Registered
Joined
·
83 Posts
Discussion Starter #19
2 bar works now, got my walboro 455lph pump installed, not sure how my jeep was even running the o ring in the basket was just powder n pieces although it did run inconsistent, stacked 3 o rings in for good measure and runs waayy harder than before, getting ready to start the procharger install!!! Thanks for all the info!!!!
 

·
Registered
Joined
·
83 Posts
Discussion Starter #20
Can’t speak for Viking, but we are using factory 2 bar SRT4 sensor straight into manifold. Low and behold, same thing happened half hour ago with Johan tuning. Hoping to find a solution very soon
He should have the fix for you now, i gave him lots of data and he did mine in 1 tune.
 
1 - 20 of 20 Posts
Top