Cherokee SRT8 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
I don't know if anyone here would have any ideas on what it could be. Any help would be great appreciated since the wife is not happy:(
 

·
Straight Up Beast SON!!!
Joined
·
17,141 Posts
Remove the battery fuse if not one of the battery terminals for a few minutes and reconnect them to see if it comes back to life. If not then you have to keep checking down the path until you get to a speaker. Also if under warranty still tak it in or swap head units with a buddy and see if the sounds comes back.
 

·
PWR - Boosted & Stroked
Joined
·
8,565 Posts
If you have the Kicker system make sure they got you the correct Kicker amp & not the regular one. With the Kicker system you can select stereo or surround in the EVIC. That option won't show up if the wrong amp is installed. I had to have the amp replaced in my 09 with Kicker & they put the wrong one in the first time, others have had the same problem in the past.
 

·
Registered
Joined
·
2 Posts
If you have the Kicker system make sure they got you the correct Kicker amp & not the regular one. With the Kicker system you can select stereo or surround in the EVIC. That option won't show up if the wrong amp is installed. I had to have the amp replaced in my 09 with Kicker & they put the wrong one in the first time, others have had the same problem in the past.
I think this post/answer is an old one but I'm seriously over no sound. I also have 2009 and radio power with no sound. What do I do to fix?? I'm out of options no
 
1 - 5 of 5 Posts
Top