New WK2 Owner - Dash lights up! ABS, Serv 4wd, ACC, Park sense failure - Cherokee SRT8 Forum
WK2 SRT8 Troubleshooting / Problems Discussion / Dealer Service If you are having some problems with your WK2 SRT8 and need assistance in troubleshooting and diagnosing the problem, this is the proper place to discuss it. Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 02-17-2019, 02:18 PM Thread Starter
Junior Member
 
Join Date: Jun 2016
Posts: 28
Thanks: 0
Thanked 3 Times in 3 Posts
New WK2 Owner - Dash lights up! ABS, Serv 4wd, ACC, Park sense failure

OK so a few weeks ago my wife and I bought a used 2014 WK2. I was hesitant to buy it considering the issues we had with our last WK1, but the the wife really wanted it. So yesterday it started acting up by giving us multiple faults. Just my luck. Here is what the faults are that it displays at startup:

ABS Failure
Park Assist failure
Blind spot failure
ACC failure
Service 4wd system - vehicle operates in 2wd only now

So basically all the systems stopped working and of course its snowing out and my wife needs to get kids up and down the mountain and now with only 2wd. Sounds like a wiring issue to me or maybe something got some moisture in it due to the snow we have been getting. Did a quick inspection under the hood and didn't find anything loose or unusual. All grounds seems tight as well. I plugged in with my pocket code reader, but was unable to see any fault codes. I was going to start by washing it really well to get the snow and ice off of it then do a visual under the chassis to see if I can find something, but in the meantime was going to pull the negative battery cable for a bit and see if I can reset the system. Any issues with disconnecting the battery? I know some cars will literally lock you out of functions and system once the battery has been disconnected and require a dealer reset. Our Chrysler dealer is horrible and I will avoid taking anything to them at all costs. (They had our WK1 for 7 weeks over a clock spring in the steering column.....worthless)

Well if anyone has seen this before or has any other ideas for me let me know. When I did some searching it seems i'm not the only one that has seen this issue when it rains or snows. Thanks!
Switch is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-20-2019, 05:39 AM Thread Starter
Junior Member
 
Join Date: Jun 2016
Posts: 28
Thanks: 0
Thanked 3 Times in 3 Posts
Update - Still haven't had a chance to get it in the garage yet, but after having the wife wash the car the warnings reset and went away. They have come on and offer intermittently the last few days so I'm fairly certain I am chasing a loose connection or lose wheel speed sensor. I'll add to the thread when I hunt down the issue and hopefully this helps someone in the future with this issue.
Switch is offline  
post #3 of 5 (permalink) Old 02-24-2019, 10:10 AM
Member
 
Lokeybrandon's Avatar
 
Join Date: May 2018
Location: North Carolina
Posts: 65
Thanks: 2
Thanked 1 Time in 1 Post
Had a similar issue three days after purchasing my ‘12. It was the front sensor I forget the name of it but it was the sensor that handles the adaptive cruise. It set off tons of issues like what you mentioned. They replaced it for free since I had just purchased the car. For which I am lucky. I’ve only had to spring for a thermostat ps pump and a rack and pinion since purchase ... smh.
Lokeybrandon is offline  
 
post #4 of 5 (permalink) Old 02-28-2019, 07:40 AM Thread Starter
Junior Member
 
Join Date: Jun 2016
Posts: 28
Thanks: 0
Thanked 3 Times in 3 Posts
Ya, the dealer I bought it from is worthless and won't do anything (curse of living in the northwest. All the dealers in the region are horrible). Got it into a local shop that has a better scan tool than mine and sure enough one of the rear speed sensors failed. Will confirm that that clears everything up today when the part comes in, but I bet she will be working fine. Now I just have to find the mystery coolant leak that no one can find either lol.
Switch is offline  
post #5 of 5 (permalink) Old 04-13-2019, 07:04 PM
Member
 
Lokeybrandon's Avatar
 
Join Date: May 2018
Location: North Carolina
Posts: 65
Thanks: 2
Thanked 1 Time in 1 Post
Quote:
Originally Posted by Switch View Post
Ya, the dealer I bought it from is worthless and won't do anything (curse of living in the northwest. All the dealers in the region are horrible). Got it into a local shop that has a better scan tool than mine and sure enough one of the rear speed sensors failed. Will confirm that that clears everything up today when the part comes in, but I bet she will be working fine. Now I just have to find the mystery coolant leak that no one can find either lol.
Any update on your coolant leak?
Lokeybrandon is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Service 4wd and ACC/FCW ? 2014 srt SrtTONY1320 WK2 SRT8 Troubleshooting / Problems Discussion / Dealer Service 14 10-26-2018 11:01 AM
Lane Sense Plus versus Lane Sense Shark WK2 SRT8 General Discussion 4 09-19-2016 01:06 PM
Help - Service 4WD, ABS Light, Taction Control Light, FCW Disabled, Service Park Mongoose9400 WK2 SRT8 Troubleshooting / Problems Discussion / Dealer Service 9 09-14-2013 09:12 PM
HELP! Service 4WD system, ABS, ESP and TCM lights on the dash! carfreak493 WK1 Troubleshooting / Problems Discussion / Dealer Service 5 08-25-2013 09:12 PM
Trouble Shifting, Service 4WD System & ABS, ESP/BAS, Traction Control Lights on SML9284 WK1 Troubleshooting / Problems Discussion / Dealer Service 15 12-08-2011 11:11 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome