P0441 Evaporative Emission Control System Incorrect Purge Flow - Cherokee SRT8 Forum

Auto Insurance

» Featured Product
Go Back   Cherokee SRT8 Forum > WK1 Jeep Grand Cherokee SRT8 Discussion (2006-2010) > WK1 Troubleshooting / Problems Discussion / Dealer Service

WK1 Troubleshooting / Problems Discussion / Dealer Service If you are having some problems with your Jeep Grand Cherokee SRT8 and need assistance in troubleshooting and diagnosing the problem, this is the proper place to discuss it. Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

CherokeeSRT8.com is the premier Jeep Cherokee Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 05-13-2013, 03:30 PM
jricher82's Avatar
jricher82 jricher82 is offline
Senior Member
 
Join Date: Mar 2012
Location: New Jersey
Posts: 257
Thanks: 19
Thanked 10 Times in 10 Posts
P0441 Evaporative Emission Control System Incorrect Purge Flow

Check engine light came on last night out of the blue. Hooked up to an OBDII reader this afternoon, pulled the code P0441 Evaporative Emission Control System Incorrect Purge Flow. I erased the code from the system to see if I could replicate it, hasn't come back up yet. Has anyone thrown this code before?

Supposedly the code is supposed to designate that some part of the EVAP control system is no longer functioning correctly. The EVAP system consists of many parts, including (but not limited to) the gas cap, fuel lines, carbon canister, purge valve, and other hoses.

I checked the gas cap, it felt a little loose but wasn't falling off or anything so I have it a few turns so it clicked, maybe that had something to do with it. Just wanted to see if anyone else had experienced anything similar. Thanks.
__________________
JP - "If you're not first, you're last."


2008 Jeep Grand Cherokee SRT8 - Magnaflow Exhaust / BT Oil Catch Can / Coil Over suspension / SRT Grill Badge / Pilot Stubby Antenna / Taillight Solutions Wire Harness
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-13-2013, 04:43 PM
DrSheldonCooper's Avatar
DrSheldonCooper DrSheldonCooper is offline
Major Contributing Member
 
Join Date: Nov 2012
Location: Chicago
Posts: 1,192
Thanks: 153
Thanked 228 Times in 164 Posts
Garage
Check to make sure all your hoses are still connected.
__________________
Dan
2010 YEEP
Reply With Quote Quick reply to this message
  #3  
Old 05-13-2013, 05:36 PM
LASRT's Avatar
LASRT LASRT is offline
Elite Contributing Member
 
Join Date: Sep 2007
Location: Baton rouge louisiana
Posts: 2,188
Thanks: 217
Thanked 174 Times in 151 Posts
Would be my guess^^^
__________________
Adam salsbury - 2010 srt8, pwr camshaft installed at stage 6 running 12.6's
Reply With Quote Quick reply to this message
  #4  
Old 05-13-2013, 05:58 PM
Btelander's Avatar
Btelander Btelander is online now
Senior Contributing Member
 
Join Date: Jul 2011
Location: Des Moines Iowa
Posts: 802
Thanks: 47
Thanked 53 Times in 47 Posts
I had the same code pop up today. I tightened my gas cap and check my hoses. Hopefully it was only the gas cap.

Sent from AutoGuide.com Free App
__________________
2009 BRILLIANT BLACK JEEP SRT8-HHP Forged 6.1 / Stage II Cam / Vortech / OBX Headers / Magnaflow Catback-reso delete /Stage 2 Buider Bill VB / R1 Concepts Crossed/Slotted / Eibach Springs / 6k HID lows/fogs / Rear LED's / TLS Rear Harness / Motivos 275/315

2014 BRILLIANT BLACK JEEP SUMMIT

Brian
Reply With Quote Quick reply to this message
  #5  
Old 05-13-2013, 07:04 PM
WIPLASH's Avatar
WIPLASH WIPLASH is offline
Elite Contributing Member
 
Join Date: Jun 2009
Posts: 3,607
Thanks: 320
Thanked 395 Times in 317 Posts
Check them hose, you don't want them hose lose. They cause problems when they are lose.
__________________


I'm gettting frustrated with modding
Reply With Quote Quick reply to this message
  #6  
Old 05-13-2013, 07:12 PM
Btelander's Avatar
Btelander Btelander is online now
Senior Contributing Member
 
Join Date: Jul 2011
Location: Des Moines Iowa
Posts: 802
Thanks: 47
Thanked 53 Times in 47 Posts
Oops mine wad p0455 evaporitive emissions system leak detected

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #7  
Old 05-13-2013, 07:21 PM
jricher82's Avatar
jricher82 jricher82 is offline
Senior Member
 
Join Date: Mar 2012
Location: New Jersey
Posts: 257
Thanks: 19
Thanked 10 Times in 10 Posts
I'll definitely trace the hoses and make sure they're all on there good, just hoping that the gas cap was the culprit and I don't see the code again. I hate seeing that light on, I get all "OCD" about stuff like that and my cars.
Reply With Quote Quick reply to this message
  #8  
Old 05-13-2013, 11:18 PM
DrSheldonCooper's Avatar
DrSheldonCooper DrSheldonCooper is offline
Major Contributing Member
 
Join Date: Nov 2012
Location: Chicago
Posts: 1,192
Thanks: 153
Thanked 228 Times in 164 Posts
Garage
A loose fuel cap will not cause a P0441. It will set an EVAP leak code. Two different codes.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
P0700 Transmission Control System Mil Request Sleeper WK1 Troubleshooting / Problems Discussion / Dealer Service 1 04-27-2008 09:47 AM
Stability control system I driving me nuts! PropDr WK1 Troubleshooting / Problems Discussion / Dealer Service 2 02-28-2008 07:40 PM
Throttle Control System Warning Light ON Cdog WK1 Troubleshooting / Problems Discussion / Dealer Service 1 03-11-2007 12:34 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 11:02 PM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
© AutoGuide