Jeep hard starting up? - Cherokee SRT8 Forum

Auto Insurance

Go Back   Cherokee SRT8 Forum > WK1 Jeep Grand Cherokee SRT8 Discussion (2006-2010) > WK1 Troubleshooting / Problems Discussion / Dealer Service

WK1 Troubleshooting / Problems Discussion / Dealer Service If you are having some problems with your Jeep Grand Cherokee SRT8 and need assistance in troubleshooting and diagnosing the problem, this is the proper place to discuss it. Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

CherokeeSRT8.com is the premier Jeep Cherokee Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 02-17-2013, 02:39 PM
sully83699's Avatar
sully83699 sully83699 is online now
Major Contributing Member
 
Join Date: Aug 2011
Location: Erie PA
Posts: 1,019
Thanks: 186
Thanked 79 Times in 65 Posts
Jeep hard starting up?

Turned the key and took a good 3 seconds before it finally turned over. Starter was replaced a little over the year ago could it be the battery?

Sent from my DROID RAZR using AutoGuide.Com Free App
__________________
0-60 sec 4.27 sec
1/4 mi. 12.78 sec at 110 mph
and getting faster!!!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-17-2013, 03:20 PM
gitrdun's Avatar
gitrdun gitrdun is offline
One, two, GIT SUM!!
Lifetime Premium Member
 
Join Date: Jul 2012
Posts: 1,382
Thanks: 27
Thanked 121 Times in 98 Posts
could be a number of things. first place to start is the battery, you wont be able to test it yourself without a load-tester, take it to a parts store and they can check it there. next you could have dirty spark plugs, if the battery is fine, check a few of them. if that doesnt work, check the fuel filter, you could not be getting adequate pressure right away from restriction in it, it takes a few seconds to build up. then if that doesnt work, maybe you might have a tiny leak in the fuel rail, that would also take a few seconds for the air to purge out (doubt thats the issue though or youd smell fuel all the time )

hope this helps
__________________
'09 Jeep GC SRT8 Red Rock,6k hid fogs and high beams with 6 high mod,6k LED Interior,Billet Flat Black Shorty Antenna, Black Rims, Drilled/Slotted R1's w/ StopTechs, Red BT Catch Can, Resonator Delete with Borlas, Johan Tuned, JackHammer Paddle Shifters(first in the world)

'08 Yamaha R6, TwoBrothers Slip On, Fender Eliminator

'71 Volkswagen 1600cc Air Cooled DuneBuggy, now running and kicking ass !
Reply With Quote Quick reply to this message
The Following User Says Thank You to gitrdun For This Useful Post:
sully83699 (02-17-2013)
  #3  
Old 02-17-2013, 05:57 PM
sully83699's Avatar
sully83699 sully83699 is online now
Major Contributing Member
 
Join Date: Aug 2011
Location: Erie PA
Posts: 1,019
Thanks: 186
Thanked 79 Times in 65 Posts
Went to advanced and they said battery has a clean bill of health and i dont smell anything but the mopar fart when i get on it good so if it does it anymore ill see whats going on with the plugs. shouldnt be do im only at 50k miles
Reply With Quote Quick reply to this message
  #4  
Old 02-18-2013, 07:38 AM
ekaz's Avatar
ekaz ekaz is offline
Elite Contributing Member
 
Join Date: Feb 2007
Posts: 4,815
Thanks: 271
Thanked 573 Times in 427 Posts
Could be the cam position sensor. If it's going it'll take longer for the computer to know where the cam is and start. Sensor is around $20 and takes only a few minutes to replace. It's on the left side of the timing cover.
__________________
Join the Caravan for SF10!
Facebook: https://www.facebook.com/SF10caravan
Twitter: @SF10Caravan
Web: sf10caravan.com

2012 300SRT--Mods so far....CMR tune from Toona, tinted taillights, Kooks LTs and high flow cats, soon to be released catback, Mopar lowering springs, HIDs in the driving lights, tinted windows, LMI true CAI, and a bunch of BT bling.
ng.


Powered by PWR Tooned by Johan Blinged by Billet Technologies
Reply With Quote Quick reply to this message
  #5  
Old 02-18-2013, 07:56 AM
blahson's Avatar
blahson blahson is offline
Senior Contributing Member
 
Join Date: Aug 2011
Location: MIA
Posts: 625
Thanks: 72
Thanked 75 Times in 67 Posts
I get this same problem too. Usually takes 1-3 clicks and I'm up and running, othertimes it take a solid 2-3 seconds.

In my case, it happens a little bit more often when it's cold out. It definitely happens when I don't drive the rig for a couple days. I left town for a week and it took about 10 minutes to start. The longer it sits, the longer it takes to wake up.

Any ideas?? Anyone??????
__________________
~~~~~~~~~~~~~
Joeyyyyy
06 Jeep SRT8

Reply With Quote Quick reply to this message
  #6  
Old 02-18-2013, 07:59 AM
PITTZ's Avatar
PITTZ PITTZ is online now
Contributing Member
 
Join Date: Nov 2010
Location: New Market, Md
Posts: 1,912
Thanks: 48
Thanked 421 Times in 342 Posts
Jeep hard starting up?

There is something in the manual about hard starts and being cold out.


Sent from AutoGuide.com Free App
__________________
Black 06 Srt8... Kooks 1 7/8 Headers, High Flow Cats, Cam, B&B Exhaust, Catch Can. 08-10 Conversion Front &. Rear, Cree high beams.... Not quick!!
Reply With Quote Quick reply to this message
  #7  
Old 02-18-2013, 08:20 AM
blahson's Avatar
blahson blahson is offline
Senior Contributing Member
 
Join Date: Aug 2011
Location: MIA
Posts: 625
Thanks: 72
Thanked 75 Times in 67 Posts
I just assumed that cold starts may take a big longer. What I don't get is why when I leave for 2 days, it takes a few tries to get 'er up and running. When I'm gone for a week, it takes 10 minutes to start. It wasn't cold out either, actually about 80*f
Reply With Quote Quick reply to this message
  #8  
Old 02-18-2013, 08:33 AM
matt2extreme's Avatar
matt2extreme matt2extreme is offline
Junior Member
 
Join Date: Jun 2012
Location: Mechanicsville, Maryland
Posts: 11
Thanks: 2
Thanked 0 Times in 0 Posts
My jeep does the same thing and one day it starts fine and the next it takes a few turns of the key before it even turns over
Reply With Quote Quick reply to this message
  #9  
Old 03-04-2013, 01:27 PM
sully83699's Avatar
sully83699 sully83699 is online now
Major Contributing Member
 
Join Date: Aug 2011
Location: Erie PA
Posts: 1,019
Thanks: 186
Thanked 79 Times in 65 Posts
Re: Jeep hard starting up?

Well wasnt nothing cuz jeep died today fml lol

Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
  #10  
Old 03-04-2013, 04:49 PM
gitrdun's Avatar
gitrdun gitrdun is offline
One, two, GIT SUM!!
Lifetime Premium Member
 
Join Date: Jul 2012
Posts: 1,382
Thanks: 27
Thanked 121 Times in 98 Posts
Quote:
Originally Posted by PITTZ View Post
There is something in the manual about hard starts and being cold out.


Sent from AutoGuide.com Free App
Yeah it's cold mode, it shuts down cylinders and alternates between them to make them all work harder thus generates more heat, that's where the rough feeling run comes from. Also turns up the idle speed while doing that. Just wanted tonshed somelight on this for everyone, it is ok for your engine. The concept came from keeping heat in diesel engines , I was surprised when it was on something this small actually lol
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard Starting after Cam install PEORIASRT WK1 Troubleshooting / Problems Discussion / Dealer Service 5 02-04-2013 07:28 AM
Jeep not starting, not even cranking. Deraynged WK1 Troubleshooting / Problems Discussion / Dealer Service 4 10-31-2012 12:10 AM
trouble starting jeep srt8manny WK1 Troubleshooting / Problems Discussion / Dealer Service 0 06-14-2012 02:47 PM
the Jeep is starting to get famous! retro-king Track Talk 23 05-09-2012 09:30 AM
trouble starting jeep dsalogia WK1 SRT8 General Discussion 1 03-22-2009 05:39 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 10:19 PM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
© AutoGuide