engine cuts off for a split second. - Page 2 - Cherokee SRT8 Forum

Auto Insurance

Go Back   Cherokee SRT8 Forum > WK1 Jeep Grand Cherokee SRT8 Discussion (2006-2010) > WK1 Troubleshooting / Problems Discussion / Dealer Service

WK1 Troubleshooting / Problems Discussion / Dealer Service If you are having some problems with your Jeep Grand Cherokee SRT8 and need assistance in troubleshooting and diagnosing the problem, this is the proper place to discuss it. Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

CherokeeSRT8.com is the premier Jeep Cherokee Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #11  
Old 12-11-2012, 06:15 PM
Harrison@Stage6 Harrison@Stage6 is offline
Supporting Vendor
Lifetime Premium Member
 
Join Date: Jan 2008
Location: Down South in Florida
Posts: 16,903
Thanks: 1,528
Thanked 2,489 Times in 1,180 Posts
Garage
What year is the Jeep? Is it like you turned off the key and everything resets or like the engine has a blip?
__________________
Quickest and Fastest AWD Jeep period........ for now.
8.95@156.99 1.46 60'
2012 Mercedes S63-- sittin' low on 22's and stock(kinda)

Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #12  
Old 12-11-2012, 07:27 PM
SrtGuy's Avatar
SrtGuy SrtGuy is offline
Senior Member
 
Join Date: Nov 2009
Location: Odessa Tx
Posts: 138
Thanks: 0
Thanked 0 Times in 0 Posts
its a 08 with 59k miles. its like the engine has a blip
Reply With Quote Quick reply to this message
  #13  
Old 12-12-2012, 09:12 PM
SrtGuy's Avatar
SrtGuy SrtGuy is offline
Senior Member
 
Join Date: Nov 2009
Location: Odessa Tx
Posts: 138
Thanks: 0
Thanked 0 Times in 0 Posts
ok i plugged my programmer in and zero codes.... i really need some help with this guys. i recently changed my spark plugs. and it seems like thats were my problems started? any input would really help guys
Reply With Quote Quick reply to this message
  #14  
Old 12-12-2012, 11:01 PM
Knuckles's Avatar
Knuckles Knuckles is online now
Straight Up Beast SON!!!
Lifetime Premium Member
 
Join Date: Oct 2008
Location: Chicagorilla!!
Posts: 16,654
Thanks: 2,567
Thanked 1,063 Times in 867 Posts
Quote:
Originally Posted by SrtGuy View Post
ok i plugged my programmer in and zero codes.... i really need some help with this guys. i recently changed my spark plugs. and it seems like thats were my problems started? any input would really help guys
What are your mods and what did you Gao the plugs at? Also you sure your jot hitting the Rev limiter @ WOT?
__________________
Knuckles
Mods: Bwoody CAI/FRI Lil boy Cam/ SW Headers/CORSA exhaust/SLP UD Pulley/Black Ops Autoworks Ported Intake Manny/90MM TB/ Johan aka Diablotoona Custom Tune
Reply With Quote Quick reply to this message
  #15  
Old 12-13-2012, 12:55 PM
bushmaster3000's Avatar
bushmaster3000 bushmaster3000 is offline
Senior Member
 
Join Date: Oct 2010
Location: Houston
Posts: 486
Thanks: 6
Thanked 44 Times in 37 Posts
Quote:
Originally Posted by SrtGuy View Post
ok i plugged my programmer in and zero codes.... i really need some help with this guys. i recently changed my spark plugs. and it seems like thats were my problems started? any input would really help guys
I'm with knuckles, see what the plugs are gaped at. Could definitely see this being a problem. If you don't have a go-no go gauge to check then autozone has them for like 10 bucks. If it still acts up monitor misfires using your trinity. Also see if it has any pending codes.
__________________
~~~~~ Special Thanks to~~~~
Skip at Demon Performance
Bada$$ Tuner Johan!
Reply With Quote Quick reply to this message
  #16  
Old 12-13-2012, 04:29 PM
jumpback's Avatar
jumpback jumpback is online now
Major Contributing Member
 
Join Date: Jan 2012
Location: So Cal
Posts: 1,645
Thanks: 423
Thanked 156 Times in 150 Posts
Garage
Maybe your loosing traction and the esp is shuttering?
But i would check the gaps on the plugs too
__________________
~Jeep SRT8~
Reply With Quote Quick reply to this message
  #17  
Old 02-06-2013, 08:24 PM
hussler hussler is offline
Junior Member
 
Join Date: Sep 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Yeah mine did the same thing for the first time.. scared the crap out of me!! pulled out to pass then just bogged for a second then caught again..any idea why??
Reply With Quote Quick reply to this message
  #18  
Old 02-06-2013, 09:44 PM
SrtGuy's Avatar
SrtGuy SrtGuy is offline
Senior Member
 
Join Date: Nov 2009
Location: Odessa Tx
Posts: 138
Thanks: 0
Thanked 0 Times in 0 Posts
It was the stupid spark plugs....I put the factory plugs back in and problem solved... DO NOT I REPEAT DO NOT!!!! Use bosh platinum 4 plugs for anything!!!! They were the root cause of my problem
Reply With Quote Quick reply to this message
  #19  
Old 02-06-2013, 10:06 PM
hussler hussler is offline
Junior Member
 
Join Date: Sep 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by SrtGuy View Post
It was the stupid spark plugs....I put the factory plugs back in and problem solved... DO NOT I REPEAT DO NOT!!!! Use bosh platinum 4 plugs for anything!!!! They were the root cause of my problem
Thanx SrtGuy!!! I think it still has the factory plugs, I will try change them out though, would I have to Gap them??
Reply With Quote Quick reply to this message
  #20  
Old 02-07-2013, 06:00 AM
SrtGuy's Avatar
SrtGuy SrtGuy is offline
Senior Member
 
Join Date: Nov 2009
Location: Odessa Tx
Posts: 138
Thanks: 0
Thanked 0 Times in 0 Posts
No problem.... Gap them to 50
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
jeep just cuts out nyjoed WK1 Audio/Video/Nav/UConnect/Electronics 16 11-29-2012 04:07 PM
Looking for a company with DMH low profile cuts in stock Blkoutsrt8 WK1 SRT8 General Discussion 3 06-13-2012 05:05 PM
Dealer techs taking short cuts digi WK1 Troubleshooting / Problems Discussion / Dealer Service 15 10-02-2010 08:34 PM
B&B's split a seam... 12SECUV WK1 SRT8 General Discussion 41 02-20-2007 07:58 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 07:51 PM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
© AutoGuide