coolant hose pop - Cherokee SRT8 Forum

Auto Insurance

Go Back   Cherokee SRT8 Forum > WK1 Jeep Grand Cherokee SRT8 Discussion (2006-2010) > WK1 Troubleshooting / Problems Discussion / Dealer Service

WK1 Troubleshooting / Problems Discussion / Dealer Service If you are having some problems with your Jeep Grand Cherokee SRT8 and need assistance in troubleshooting and diagnosing the problem, this is the proper place to discuss it. Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

CherokeeSRT8.com is the premier Jeep Cherokee Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 11-29-2012, 01:12 AM
USMC03GRUNT USMC03GRUNT is offline
Junior Member
 
Join Date: Jul 2012
Location: Killadelphia
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
coolant hose pop

This is my first post, and it sucks it has to be in this category. I did a quick search but didn't see what I was looking for, so I guess I need help. I have a 2008 JGC SRT obviously, bought it at 42K on the clock, now have 48K on it, first problem ever, but things fail and I understand that. So my friend has a CTS-V and we were messing around on the Blvd, I smoked him off the line and I'd say the end of what would be a 1/4 mile he caught up and walked away from me, I'm cool with that, lighter and supercharged whatever. But my problem is, the bullsh1t spring clamp on the hose going to the thermostat popped off, causing me to blow coolant. Now I clamped it back up, added a gallon of water, and drove it to where I had to go. The digital temp guage read 215, which is fine, the dash guage in the right hand corner kept bouncing into the read. So I seen this and pulled over, in the digital section it said Trans over heating. The thing shifted fine. Is the sensor not responding propperly because of the pop? Maybe antifreeze spilling all over? I'd hate to bring it to the dealer, but if I have too then so be it. Barbera Dodge/Chrysler/Jeep is the closest. I have an aftermarket warranty through Police and Fire credit union, but still. I plan on changing my clamps to the screw down types, I place a lot more trust in them. I wanted to do a trans flush anyways. Is my jeep fubar'd up?
My mods are a BWoody Intake, Borla exhaust, and a diablo tuner. I really baby this thing as as aposed to my 2010 Camaro SS i traded it in for, If I drove the Jeep first it would of been a rap, no Camaro lol. Just asking for some thoughts...thank you for those who read this long A$$ post.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-29-2012, 01:30 AM
J&D's SRT's's Avatar
J&D's SRT's J&D's SRT's is offline
PWR - Boosted & Stroked
Lifetime Premium Member
 
Join Date: Apr 2010
Posts: 8,527
Thanks: 1,987
Thanked 1,532 Times in 1,199 Posts
The digital temp in the EVIC is your oil temp. Check to see if the plastic elbow on the top radiator hose is cracked, that is a fairly common problem also. If your going to replace your clamps you also should get the two that run through the fire wall on the passenger side those are known to pop off also. Not to sure why you would be getting a tranny over temp warning but watch that closely, heat will kill the tranny very very fast. Good luck & I hope its nothing too serious.

Jim
__________________
Reply With Quote Quick reply to this message
  #3  
Old 11-29-2012, 01:34 PM
USMC03GRUNT USMC03GRUNT is offline
Junior Member
 
Join Date: Jul 2012
Location: Killadelphia
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally Posted by J&D's SRT's View Post
The digital temp in the EVIC is your oil temp. Check to see if the plastic elbow on the top radiator hose is cracked, that is a fairly common problem also. If your going to replace your clamps you also should get the two that run through the fire wall on the passenger side those are known to pop off also. Not to sure why you would be getting a tranny over temp warning but watch that closely, heat will kill the tranny very very fast. Good luck & I hope its nothing too serious.

Jim
do you think the trans was running hotter because the radiator wasn't completely full? since the two are so close together? I'm going to order that one piece hose and slap on some worm clamps to everything coolant related while i can now. Hopefully this is the fix. I also have a 180 jet tstat thats been sitting around that i never threw on. We'll see I guess
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
coolant leaking from coolant reservoir? pnut WK1 Troubleshooting / Problems Discussion / Dealer Service 6 07-20-2012 10:01 AM
Can I mix Zerex G-05 Coolant and Mopar Coolant? SRT8Xcy WK1 General Performance Discussion 2 06-10-2012 10:24 PM
Question about WK1 Rad hose YKPizzaGuy WK1 SRT8 General Discussion 0 02-21-2012 03:28 PM
radiator hose imanngcsrt8 WK1 Troubleshooting / Problems Discussion / Dealer Service 6 09-27-2011 11:11 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 02:26 PM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
© AutoGuide