And so it continues - Page 3 - Cherokee SRT8 Forum

Auto Insurance

Go Back   Cherokee SRT8 Forum > WK1 Jeep Grand Cherokee SRT8 Discussion (2006-2010) > WK1 Troubleshooting / Problems Discussion / Dealer Service

WK1 Troubleshooting / Problems Discussion / Dealer Service If you are having some problems with your Jeep Grand Cherokee SRT8 and need assistance in troubleshooting and diagnosing the problem, this is the proper place to discuss it. Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

CherokeeSRT8.com is the premier Jeep Cherokee Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #21  
Old 11-24-2012, 11:31 AM
Tim H Calgary's Avatar
Tim H Calgary Tim H Calgary is offline
Post whoring since 2011
Premium Member
 
Join Date: Jun 2011
Posts: 1,567
Thanks: 636
Thanked 320 Times in 242 Posts
On a possibly related note: I noticed the power for the new fuel hat (dual walbro 405's) is directly off the battery. Could those pumps be running while keyed off? it seems like a very likely source of my issue given the timing.
__________________
Procharged D-1 @ 8 psi, SHR trans, Wavetrac rear diff, Converter,PWR Cam, kooks headers, Corsa exhaust, fore innovations hat, cf from black ops and dual projector headlights/Fogs from DC Customs. PWR 393 and ? #'s of boost come spring .
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #22  
Old 11-24-2012, 11:40 AM
DemonPerformance's Avatar
DemonPerformance DemonPerformance is offline
Supporting Vendor
 
Join Date: Dec 2011
Location: Coastal Carolina
Posts: 5,098
Thanks: 1,101
Thanked 1,419 Times in 905 Posts
Didn't he run the ignition switch to the FC2 relay box? Ask Dan...just to make sure of course
__________________
Skip Demon Performance
Sales@DemonPerformance.com
1-888-312-3666
I wonder if they have Outback Steakhouses in the Outback?


2012-2013 Demon Performance Procharger Kits on sale now!!

Last edited by DemonPerformance; 11-24-2012 at 11:41 AM.
Reply With Quote Quick reply to this message
  #23  
Old 11-24-2012, 12:41 PM
Tim H Calgary's Avatar
Tim H Calgary Tim H Calgary is offline
Post whoring since 2011
Premium Member
 
Join Date: Jun 2011
Posts: 1,567
Thanks: 636
Thanked 320 Times in 242 Posts
Yah he said they shouldn't come on unless it's keyed on. I bet he did man but I will ask.
Reply With Quote Quick reply to this message
  #24  
Old 11-24-2012, 12:50 PM
Knuckles's Avatar
Knuckles Knuckles is offline
Straight Up Beast SON!!!
Lifetime Premium Member
 
Join Date: Oct 2008
Location: Chicagorilla!!
Posts: 16,557
Thanks: 2,498
Thanked 1,013 Times in 832 Posts
Quote:
Originally Posted by Tim H Calgary View Post
On a possibly related note: I noticed the power for the new fuel hat (dual walbro 405's) is directly off the battery. Could those pumps be running while keyed off? it seems like a very likely source of my issue given the timing.
If the pumps were on even after you turned the Jeep off then you would hear them.... Based on the Fuse box that came with the Fore Fuel hat it looks pretty simple..... So I assume the positive wire that went to the stock fuel hat is now your remote wire that is triggering the 2 relays that are on the small circuit board..... Take .it back to the shop that installed it and have them double check the install on the fuel hat.... No need to bust your head on theres one if you already paid for an install.... You know?
__________________
Knuckles
Mods: Bwoody CAI/FRI Lil boy Cam/ SW Headers/CORSA exhaust/SLP UD Pulley/Black Ops Autoworks Ported Intake Manny/90MM TB/ Johan aka Diablotoona Custom Tune
Reply With Quote Quick reply to this message
  #25  
Old 11-24-2012, 01:18 PM
Tim H Calgary's Avatar
Tim H Calgary Tim H Calgary is offline
Post whoring since 2011
Premium Member
 
Join Date: Jun 2011
Posts: 1,567
Thanks: 636
Thanked 320 Times in 242 Posts
I keyed it and it started doing this:

http://s1286.beta.photobucket.com/us..._0158.mp4.html

Is that just from the super low battery?. I suspect something is touching that shouldn't be.
Reply With Quote Quick reply to this message
  #26  
Old 11-24-2012, 01:20 PM
Tim H Calgary's Avatar
Tim H Calgary Tim H Calgary is offline
Post whoring since 2011
Premium Member
 
Join Date: Jun 2011
Posts: 1,567
Thanks: 636
Thanked 320 Times in 242 Posts
Quote:
Originally Posted by Knuckles View Post
If the pumps were on even after you turned the Jeep off then you would hear them.... Based on the Fuse box that came with the Fore Fuel hat it looks pretty simple..... So I assume the positive wire that went to the stock fuel hat is now your remote wire that is triggering the 2 relays that are on the small circuit board..... Take .it back to the shop that installed it and have them double check the install on the fuel hat.... No need to bust your head on theres one if you already paid for an install.... You know?
Very true Knuckles just trying to troubleshoot as its kinda bugging me lol. I was planning on some datalogging today, not looking good.
Reply With Quote Quick reply to this message
  #27  
Old 11-24-2012, 05:25 PM
Eric:-) Eric:-) is offline
Senior Member
 
Join Date: Jun 2012
Location: Calgary, AB
Posts: 303
Thanks: 24
Thanked 10 Times in 7 Posts
Sorry to hear that happening again bro. Lots of things can kill the battery in 3 days so it might not be something very serious. If you have the time you can disconnect the positive side of the battery and put an amp meter on it. If there's a significant current with the truck off start disconnecting the loads (fuel hat, alarm system) and fuses one by one until you see that current drop. That's should help isolate the problem.


Sent from my iPhone using AutoGuide.com App
Reply With Quote Quick reply to this message
  #28  
Old 11-24-2012, 05:54 PM
J&D's SRT's's Avatar
J&D's SRT's J&D's SRT's is offline
PWR - Boosted & Stroked
Lifetime Premium Member
 
Join Date: Apr 2010
Posts: 8,551
Thanks: 1,935
Thanked 1,525 Times in 1,193 Posts
Just a thought but you don't have a trinity that you leave in it & its not turning off is it. I think I remember done posts about them draining the battery if they weren't set right.

Jim
__________________
Reply With Quote Quick reply to this message
  #29  
Old 11-24-2012, 06:57 PM
LAFNGAS@TTC's Avatar
LAFNGAS@TTC LAFNGAS@TTC is offline
Supporting Vendor
 
Join Date: Apr 2009
Location: Red Deer, AB Canada
Posts: 1,350
Thanks: 5
Thanked 214 Times in 178 Posts
just a quick idea, did this happen anytime after installing your headlights as well? i ask because on my cavalier with the hids, for some reason it would do its own thing and kick the motor/ballast on for some reason and would kill the battery.

if it just started lately after the fuel hat, i would say that for some reason theres a signal/draw kicking around somewhere.

ive left my jeep for literally MONTHS on end due to work and id show up and could start it with no problem no matter how cold it had been outside.

Tim, you as well as anyone else is more than welcome by the shop or if youve got questions feel free to message/text me anytime
__________________

2009 Brilliant Black-Powertrain: TTC 6262 Kit, Stage 6 2Step, Demon Fuel, Wavetrac & Axles, Full Paramount Driveline, Jet 180* Stat & Lock Cap, Borla S:Appearance: DC Headlights, Tinted Tails , Smoothed Moldings, Murdered, Black Reps, CF Venom Hood, Venom Green Brake Calipers, Eibachs
10's Best Be Coming
Reply With Quote Quick reply to this message
  #30  
Old 11-25-2012, 11:42 AM
Tim H Calgary's Avatar
Tim H Calgary Tim H Calgary is offline
Post whoring since 2011
Premium Member
 
Join Date: Jun 2011
Posts: 1,567
Thanks: 636
Thanked 320 Times in 242 Posts
Quote:
Originally Posted by LAFNGAS@TTC View Post
just a quick idea, did this happen anytime after installing your headlights as well? i ask because on my cavalier with the hids, for some reason it would do its own thing and kick the motor/ballast on for some reason and would kill the battery.

if it just started lately after the fuel hat, i would say that for some reason theres a signal/draw kicking around somewhere.

ive left my jeep for literally MONTHS on end due to work and id show up and could start it with no problem no matter how cold it had been outside.

Tim, you as well as anyone else is more than welcome by the shop or if youve got questions feel free to message/text me anytime

Thanks Scott, hopefully it doesn't come to that. She's going back in today. Hopefully this is the last of it!

I do have my OT2 wideband for for my AFR plugged in and I noticed it was litup when I went in the compartment under the steering wheel. I will unplug it going forward. Hilariously I also found a pair of wire strippers!. I opened it and they fell onto my foot lol...

Last edited by Tim H Calgary; 11-25-2012 at 11:46 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
And the modding continues CentralTexHemi WK1 Interior/Exterior Visual Modifications 38 04-30-2013 11:10 PM
The Build Continues JayZilla WK2 SRT8 General Performance Discussion 8 09-22-2012 03:52 AM
She continues to impress MichaelSRT8 Track Talk 6 09-26-2009 10:37 PM
6.1L continues for 2010? mandan007 WK1 SRT8 General Discussion 43 11-26-2008 02:46 PM
My AAC headlight nightmare continues.... Mango WK1 Lighting Discussion 24 06-22-2007 07:40 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 02:34 AM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
© AutoGuide