HELP!!!!P2138 code :-( - Cherokee SRT8 Forum

Auto Insurance

Go Back   Cherokee SRT8 Forum > WK1 Jeep Grand Cherokee SRT8 Performance Discussion > WK1 Tuning/CMR/Dyno/DataLogging/Gauges

WK1 Tuning/CMR/Dyno/DataLogging/Gauges This section is for all discussions related to hand held tuners, CMR tuning, Dyno tuning, Data Logging & Gauges.

CherokeeSRT8.com is the premier Jeep Cherokee Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 11-21-2012, 02:45 PM
RED_ROCK_SRT's Avatar
RED_ROCK_SRT RED_ROCK_SRT is offline
Senior Member
 
Join Date: Jul 2012
Location: San fernando valley
Posts: 186
Thanks: 22
Thanked 3 Times in 3 Posts
HELP!!!!P2138 code :-(

My buddies rig had his ceck engine light on i belive and this code came up
,"P2138 throttle/ pedal position sensor switch d/e voltage".
Wtf is that everytime he wot hos rigg it bogs at high rpms we tried switching his t/b with another one off of my buddies rigg and same thing can anyone chime me in on this any input guys thanxxx!!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-21-2012, 03:03 PM
hotrodcalvert's Avatar
hotrodcalvert hotrodcalvert is offline
Senior Contributing Member
 
Join Date: Jul 2011
Location: Paducah, KY
Posts: 907
Thanks: 432
Thanked 156 Times in 132 Posts
sensor underneath the pedal may be faulty, its a cheap fix, start with the easy stuff first and go from there
__________________
Colby

The "Silver Bullet" ---- 2006 Jeep SRT8 - Gone but definitely not forgotten
Reply With Quote Quick reply to this message
  #3  
Old 11-21-2012, 03:15 PM
RED_ROCK_SRT's Avatar
RED_ROCK_SRT RED_ROCK_SRT is offline
Senior Member
 
Join Date: Jul 2012
Location: San fernando valley
Posts: 186
Thanks: 22
Thanked 3 Times in 3 Posts
Ok tnx i will try that i will post back in a bit thatnxx bro!!
Reply With Quote Quick reply to this message
  #4  
Old 11-21-2012, 03:54 PM
SwassAC SwassAC is offline
Senior Member
 
Join Date: Oct 2012
Location: Saratoga Springs NY
Posts: 156
Thanks: 28
Thanked 10 Times in 9 Posts
I had same problem

Easy fix for me... I had exact same problem and symptoms, ended up being water and corrosion at the connector to the ecu... cleaned up contacts plugged back in and no more issues... hope this helps
__________________
07 Steel Blue JGCSRT8 * K&N CAI * BT CC * Spectre Racing Upper Rad Hose * R1 Concepts Prem D&S Rotors W Stop Techs * HF Cats * Borla S * Nitto 420's * Paramount HIGH Performance, High Torque TC By Builder BILL * Magic Performed by Kaila with a Spell from Grand Master Wizard JerseyBoy!!!! PB ?? 12.244 @ 109.44
Reply With Quote Quick reply to this message
  #5  
Old 11-21-2012, 05:42 PM
RED_ROCK_SRT's Avatar
RED_ROCK_SRT RED_ROCK_SRT is offline
Senior Member
 
Join Date: Jul 2012
Location: San fernando valley
Posts: 186
Thanks: 22
Thanked 3 Times in 3 Posts
Found the problem T/b is bad :-( now we need a used t/b !
Reply With Quote Quick reply to this message
  #6  
Old 11-26-2012, 07:11 PM
RED_ROCK_SRT's Avatar
RED_ROCK_SRT RED_ROCK_SRT is offline
Senior Member
 
Join Date: Jul 2012
Location: San fernando valley
Posts: 186
Thanks: 22
Thanked 3 Times in 3 Posts
[QUOTE=SwassAC;964631]Easy fix for me... I had exact same problem and symptoms, ended up being water and corrosion at the connector to the ecu... cleaned up contacts plugged back in and no more issues...
We swaped pedal sensors and now ot just dnt go he wot it and it seems like hes just cruisin it lol like hes not even on the gas and a new code came up p2127 throttle position sensor cuircit e low input we cleaned out plug from ecu amd same thing we goin crazy over here lol any input will help thanxx guys
Reply With Quote Quick reply to this message
  #7  
Old 11-26-2012, 08:32 PM
Harrison@Stage6 Harrison@Stage6 is online now
Supporting Vendor
Lifetime Premium Member
 
Join Date: Jan 2008
Location: Down South in Florida
Posts: 16,944
Thanks: 1,570
Thanked 2,594 Times in 1,210 Posts
Garage
He needs to recalibrate the TB. Give me a few and I'll see if I can find a link to how to do it.
__________________
Quickest and Fastest AWD Jeep period........ for now.
8.95@156.99 1.46 60'
2012 Mercedes S63-- sittin' low on 22's and stock(kinda)

Reply With Quote Quick reply to this message
The Following User Says Thank You to Harrison@Stage6 For This Useful Post:
RED_ROCK_SRT (11-26-2012)
  #8  
Old 11-26-2012, 08:34 PM
RED_ROCK_SRT's Avatar
RED_ROCK_SRT RED_ROCK_SRT is offline
Senior Member
 
Join Date: Jul 2012
Location: San fernando valley
Posts: 186
Thanks: 22
Thanked 3 Times in 3 Posts
Quote:
Originally Posted by Harrison@Stage6 View Post
He needs to recalibrate the TB. Give me a few and I'll see if I can find a link to how to do it.
Perfect thanxx bro im sitting by my phone lol we tried everything from re flashing his rigg to disconnecting battery to checking ecu cleaning out all the plugs and no luck so yea thanxx for everything guys!!!
Reply With Quote Quick reply to this message
  #9  
Old 11-26-2012, 08:36 PM
Harrison@Stage6 Harrison@Stage6 is online now
Supporting Vendor
Lifetime Premium Member
 
Join Date: Jan 2008
Location: Down South in Florida
Posts: 16,944
Thanks: 1,570
Thanked 2,594 Times in 1,210 Posts
Garage
Here you go...... try this.

1. Turn the key in On position, do not start the engine.
2. Depress accelerator pedal and hold it fully depressed for 5 sec.
3. Turn the key in OFF position, while keeping pedal depressed. Do not remove the key.
4. Take your foot from the pedal, leave the key in for 2 minutes.
5. Remove the key.

This should reset Drive-by-wire (Accelerator+Throttle) adaptives.
Reply With Quote Quick reply to this message
The Following User Says Thank You to Harrison@Stage6 For This Useful Post:
RED_ROCK_SRT (11-26-2012)
  #10  
Old 11-26-2012, 08:52 PM
RED_ROCK_SRT's Avatar
RED_ROCK_SRT RED_ROCK_SRT is offline
Senior Member
 
Join Date: Jul 2012
Location: San fernando valley
Posts: 186
Thanks: 22
Thanked 3 Times in 3 Posts
Nope same thing we are thinking of taking it to the dealer ship but we doin everything we can not to but if anything comes up ill keep everyone posted thanxx
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Code -__- Amoose25 WK1 Troubleshooting / Problems Discussion / Dealer Service 10 09-07-2012 11:48 AM
P2138 code... flashing ETC light pimpski25 WK1 Troubleshooting / Problems Discussion / Dealer Service 2 12-19-2011 11:19 AM
CEL is on with new code oman srt8 WK1 Troubleshooting / Problems Discussion / Dealer Service 5 01-31-2009 04:03 AM
Need help with code Power Ported Performance WK1 General Performance Discussion 9 06-01-2008 04:56 AM
Jeep SRT 8 colour code / paint code bbigman2000 WK1 Troubleshooting / Problems Discussion / Dealer Service 10 04-22-2008 09:29 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 01:16 AM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
© AutoGuide