TCM problem perhaps? - Page 4 - Cherokee SRT8 Forum

Auto Insurance

Go Back   Cherokee SRT8 Forum > WK1 Jeep Grand Cherokee SRT8 Discussion (2006-2010) > WK1 Troubleshooting / Problems Discussion / Dealer Service

WK1 Troubleshooting / Problems Discussion / Dealer Service If you are having some problems with your Jeep Grand Cherokee SRT8 and need assistance in troubleshooting and diagnosing the problem, this is the proper place to discuss it. Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

CherokeeSRT8.com is the premier Jeep Cherokee Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #31  
Old 11-20-2012, 09:41 PM
Dave_MacKinnon's Avatar
Dave_MacKinnon Dave_MacKinnon is offline
Member
 
Join Date: Aug 2009
Location: Burlington, Ontario
Posts: 34
Thanks: 0
Thanked 3 Times in 3 Posts
Well that ain't good news!
__________________
Dave MacKinnon
Product Manager - Clarion Canada Inc. - www.clarion.com
Proprietor - Of Sound Mind Labs - www.osmlabs.com
Contributing Editor - Performance Auto & Sound Magazine - www.pasmag.com
Contributing Editor - RPM Motoring Monthly Magazine - www.rpmcanada.ca
2007 GC SRT-8
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #32  
Old 11-20-2012, 10:04 PM
Knuckles's Avatar
Knuckles Knuckles is offline
Straight Up Beast SON!!!
Lifetime Premium Member
 
Join Date: Oct 2008
Location: Chicagorilla!!
Posts: 16,597
Thanks: 2,514
Thanked 1,024 Times in 839 Posts
Quote:
Originally Posted by Dave_MacKinnon View Post
Well that ain't good news!
Yup.............
__________________
Knuckles
Mods: Bwoody CAI/FRI Lil boy Cam/ SW Headers/CORSA exhaust/SLP UD Pulley/Black Ops Autoworks Ported Intake Manny/90MM TB/ Johan aka Diablotoona Custom Tune
Reply With Quote Quick reply to this message
  #33  
Old 11-21-2012, 06:25 AM
Tim H Calgary's Avatar
Tim H Calgary Tim H Calgary is offline
Post whoring since 2011
Premium Member
 
Join Date: Jun 2011
Posts: 1,576
Thanks: 638
Thanked 323 Times in 244 Posts
Quote:
Originally Posted by Dave_MacKinnon View Post
Well gang.. Today my PLX Wiki 2 showed up, so I was playing with the Palmer Dashcommand app and decided to check and see if here were any codes in the ECU, even though there was no light? Lo and behold, we have a U0404 - Invalid Data from fear shift control module A in there... Guess I know what's wrong.. Any idea what these suckers cost?
factorymoparparts.com Part# 68004143AF

440.00 best deal around. I just replaced mine. Thanks to Hotrodcalvert for saving me some money . Dealership up here wanted 1300.00!!!
__________________
Procharged D-1 @ 8 psi, SHR trans, Wavetrac rear diff, Converter,PWR Cam, kooks headers, Corsa exhaust, fore innovations hat, cf from black ops and dual projector headlights/Fogs from DC Customs. PWR 393 and ? #'s of boost come spring .

Last edited by Tim H Calgary; 11-21-2012 at 08:06 AM.
Reply With Quote Quick reply to this message
The Following User Says Thank You to Tim H Calgary For This Useful Post:
hotrodcalvert (11-21-2012)
  #34  
Old 11-21-2012, 02:49 PM
Dave_MacKinnon's Avatar
Dave_MacKinnon Dave_MacKinnon is offline
Member
 
Join Date: Aug 2009
Location: Burlington, Ontario
Posts: 34
Thanks: 0
Thanked 3 Times in 3 Posts
Yeah, local dealership here in Mississauga was $1100 and change..

Dorman makes a replacement part, looks like the best price is about $275.. I'm going to take mine apart and see what it's problem is first... Does anyone know of cleaning instructions? I have seen other forums make reference to them....
Reply With Quote Quick reply to this message
  #35  
Old 11-21-2012, 02:59 PM
Tim H Calgary's Avatar
Tim H Calgary Tim H Calgary is offline
Post whoring since 2011
Premium Member
 
Join Date: Jun 2011
Posts: 1,576
Thanks: 638
Thanked 323 Times in 244 Posts
Quote:
Originally Posted by Dave_MacKinnon View Post
Yeah, local dealership here in Mississauga was $1100 and change..

Dorman makes a replacement part, looks like the best price is about $275.. I'm going to take mine apart and see what it's problem is first... Does anyone know of cleaning instructions? I have seen other forums make reference to them....
http://eugenesklyar.com/2012/09/18/s...dule-jeep-srt8

That's the write up I followed. Cleaning did buy me some time.

Good luck!
Reply With Quote Quick reply to this message
  #36  
Old 11-21-2012, 08:05 PM
Dave_MacKinnon's Avatar
Dave_MacKinnon Dave_MacKinnon is offline
Member
 
Join Date: Aug 2009
Location: Burlington, Ontario
Posts: 34
Thanks: 0
Thanked 3 Times in 3 Posts
Perfect! Thanks very much Tim.. Just need it to behave until January.. I'll be in Vegas for a week, and I can grab the replacement unit then...
Reply With Quote Quick reply to this message
  #37  
Old 11-23-2012, 06:10 PM
Dave_MacKinnon's Avatar
Dave_MacKinnon Dave_MacKinnon is offline
Member
 
Join Date: Aug 2009
Location: Burlington, Ontario
Posts: 34
Thanks: 0
Thanked 3 Times in 3 Posts
Ok, gave her a cleanup tonight.. Took about 20 minutes...

Definitely some contamination between the slider traces.. I'd say that is likely the problem.. If it happens again, I have a glass fiber brush/eraser at work for prepping circuit board traces for soldering. I'll be making some more aggressive cleaning in between..

Has anyone mentioned that designs with moving parts are destined to fail?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HID problem :( dirtrcr WK1 Lighting Discussion 9 04-26-2012 10:24 AM
TCM Problem? housemouse100 WK1 Troubleshooting / Problems Discussion / Dealer Service 5 04-25-2012 08:14 AM
Diablo Tuner Problem/tcm Problem SRTB WK1 Troubleshooting / Problems Discussion / Dealer Service 6 08-22-2009 02:28 PM
Big Problem.... frankofiore WK1 Troubleshooting / Problems Discussion / Dealer Service 8 09-05-2008 03:25 PM
I Think I Just May Have A Problem OurZoo WK1 SRT8 General Discussion 29 08-20-2007 03:06 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 01:04 PM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
© AutoGuide