Low "Clicking/Popping" Sounds During Light Acceleration - Cherokee SRT8 Forum

Auto Insurance

Go Back   Cherokee SRT8 Forum > WK1 Jeep Grand Cherokee SRT8 Discussion (2006-2010) > WK1 Troubleshooting / Problems Discussion / Dealer Service

WK1 Troubleshooting / Problems Discussion / Dealer Service If you are having some problems with your Jeep Grand Cherokee SRT8 and need assistance in troubleshooting and diagnosing the problem, this is the proper place to discuss it. Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

CherokeeSRT8.com is the premier Jeep Cherokee Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 07-27-2012, 08:13 AM
Jenya's Avatar
Jenya Jenya is offline
Member
 
Join Date: Jul 2012
Location: Edmonton, AB, Canada
Posts: 50
Thanks: 2
Thanked 12 Times in 4 Posts
Low "Clicking/Popping" Sounds During Light Acceleration

When I am at a dead stop and slowly speed up I can hear a popping or a clicking sound (continuous) that comes from the underneath of the vehicle (driver side by the sound of it). It seems to only be happening when I am accelerating since there are no sounds at idle.

Usually I only hear these faint sounds when I am cruising beside a wall, a tall curb or other cars... otherwise I never noticed anything. There are a few open threads about this with no clarity as to what the problem ended up being. Maybe someone can contribute who had this sort of problem before.

I bought the truck with about 100,000 km and it was dealer maintained all its life. Stock tires, stock everything.

Last edited by Jenya; 07-27-2012 at 08:19 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-27-2012, 08:26 AM
Btelander's Avatar
Btelander Btelander is online now
Major Contributing Member
 
Join Date: Jul 2011
Location: Des Moines Iowa
Posts: 1,087
Thanks: 78
Thanked 98 Times in 82 Posts
Is it throwing any engine codes?
__________________
2009 BRILLIANT BLACK JEEP SRT8-HHP Forged 6.1 / Stage II Cam / Vortech / OBX Headers / Magnaflow Catback-reso delete /PTCM/SHR/ FTI/ ATI / R1 Concepts Crossed/Slotted / Eibach Springs / 6k HID lows/fogs / Rear LED's / TLS Rear Harness / Motivos 275/315

2014 BRILLIANT BLACK JEEP SUMMIT

Brian
Reply With Quote Quick reply to this message
  #3  
Old 07-27-2012, 08:48 AM
Jenya's Avatar
Jenya Jenya is offline
Member
 
Join Date: Jul 2012
Location: Edmonton, AB, Canada
Posts: 50
Thanks: 2
Thanked 12 Times in 4 Posts
Nothing on the dash. Or anywhere really - drives well too. Whats the procedure to getting codes out of it?
Reply With Quote Quick reply to this message
  #4  
Old 07-27-2012, 08:37 PM
sparksftball69 sparksftball69 is offline
Senior Member
 
Join Date: Feb 2012
Posts: 235
Thanks: 15
Thanked 16 Times in 16 Posts
Exhaust leak??? You'll prob hear it more with the walls or curbs...


Sent from my iPhone using AG Free
__________________
-2006 Grand Cherokee SRT8 426, -V-3 SI Trim, ATI 17% OD, 30t pulley, AR Long Tube Headers, Gibson Exhaust, Custom Tips, 180 T-Stat, Catch Can, LC-1, Custom Tune
-IN THE WORKS meth injection
-05 RAM SRT 10 QC - 10000k HID head/fog lights, JMB Catless w/Maggie Cat Back, Ported Throttle Body, Caltracs, Rear Bushings, Suncoast Valve Body w/GM solenoid/TransGo Shift kit,170 T-stat, SCT Tuned By Torrie, B&B Headers, Cutouts, 2400 Stall, built tranny, Justin's E-Fan, Hard Radiator Pipes.
Reply With Quote Quick reply to this message
  #5  
Old 07-29-2012, 05:17 PM
sidehatch's Avatar
sidehatch sidehatch is offline
Member
 
Join Date: Dec 2008
Posts: 64
Thanks: 0
Thanked 0 Times in 0 Posts
I have the same issue. posted here

http://www.cherokeesrt8.com/forums/s...ad.php?t=66368

started happening just after 30k mile major service with tc/diff check/fluid replace. calling the dealer tomorrow to schedule an appt. =\

it's definitely coming from the front of the car, sounds like from near the engine, which is of course where the front diff is.
Reply With Quote Quick reply to this message
  #6  
Old 07-30-2012, 10:05 AM
Jenya's Avatar
Jenya Jenya is offline
Member
 
Join Date: Jul 2012
Location: Edmonton, AB, Canada
Posts: 50
Thanks: 2
Thanked 12 Times in 4 Posts
Quote:
Originally Posted by sidehatch View Post
I have the same issue. posted here

http://www.cherokeesrt8.com/forums/s...ad.php?t=66368

started happening just after 30k mile major service with tc/diff check/fluid replace. calling the dealer tomorrow to schedule an appt. =\

it's definitely coming from the front of the car, sounds like from near the engine, which is of course where the front diff is.
Mine comes and goes. It's pretty dodgy and I haven't been able to replicate it since it happened. I am just going to service my front and rear axles as well as the TC and hopefully that will make the truck happy.
Reply With Quote Quick reply to this message
  #7  
Old 07-31-2012, 08:50 AM
Ewalk214 Ewalk214 is offline
Member
 
Join Date: Apr 2012
Location: Brooklyn
Posts: 36
Thanks: 0
Thanked 3 Times in 2 Posts
Have the exact same issue, noticed it after I changed the transfer case motor after a service 4wd system message. I'm curious to find out what the issue is. I've got an 06 with 67k recently serviced the tc and all the diffs and trans.
Reply With Quote Quick reply to this message
  #8  
Old 08-06-2012, 03:20 PM
sidehatch's Avatar
sidehatch sidehatch is offline
Member
 
Join Date: Dec 2008
Posts: 64
Thanks: 0
Thanked 0 Times in 0 Posts
okay, so I managed to get the truck to reproduce the noise with a tech riding with me - thankfully. it is VERY faint, so I was worried they wouldn't believe me.

they felt a wait and see course was best. because it make the noise when really warmed up and in park and neutral as well, they ruled out TC/Diff, thankfully. they felt it could be internal to the exhaust. if it gets louder or worse I will take it back and they will take a look.

sorry for nothing more conclusive. part of me does hope exhaust, it'll be an excuse to get an aftermarket system.
Reply With Quote Quick reply to this message
  #9  
Old 08-07-2012, 07:31 AM
Jenya's Avatar
Jenya Jenya is offline
Member
 
Join Date: Jul 2012
Location: Edmonton, AB, Canada
Posts: 50
Thanks: 2
Thanked 12 Times in 4 Posts
I am strongly starting to believe it has something to do with the exhaust as well.
Reply With Quote Quick reply to this message
  #10  
Old 08-09-2012, 07:39 AM
sidehatch's Avatar
sidehatch sidehatch is offline
Member
 
Join Date: Dec 2008
Posts: 64
Thanks: 0
Thanked 0 Times in 0 Posts
he said it could be the cat starting to go, since it has an internal structure. we'll see. I plan to put more miles than normal on it in the next 2 months due to some trips. figure that'll aggravate it enough if it's actually something deteriorating.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
popping or clunking or clicking noise front end tyroone WK1 Troubleshooting / Problems Discussion / Dealer Service 12 05-17-2013 07:57 AM
Had a "phantom acceleration" incident. . . Wintermute WK1 SRT8 General Discussion 4 01-31-2012 05:05 AM
Getting a "surging" sound under acceleration GrumpyTX WK1 Troubleshooting / Problems Discussion / Dealer Service 3 06-22-2010 08:37 AM
B&G Can Turn Off The Long Tube Header "Check Engine" Light! tbyrne WK1 General Performance Discussion 5 07-22-2007 12:22 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 06:52 AM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
© AutoGuide