Innovate MTX-L Issues - Cherokee SRT8 Forum

Auto Insurance

Go Back   Cherokee SRT8 Forum > WK1 Jeep Grand Cherokee SRT8 Performance Discussion > WK1 Tuning/CMR/Dyno/DataLogging/Gauges

WK1 Tuning/CMR/Dyno/DataLogging/Gauges This section is for all discussions related to hand held tuners, CMR tuning, Dyno tuning, Data Logging & Gauges.

CherokeeSRT8.com is the premier Jeep Cherokee Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 05-21-2012, 09:30 PM
Texas SRT8's Avatar
Texas SRT8 Texas SRT8 is offline
Major Contributing Member
 
Join Date: Jun 2011
Location: Houston, TX
Posts: 1,313
Thanks: 618
Thanked 219 Times in 168 Posts
Innovate MTX-L Issues

After I hit the track, my MTX-L threw a E8 code. I believe this means the O2 sesnsor is defective? Is it common for AFR O2 sensors to go bad so soon? I've had it for less than a year. I turned off the jeep, turned it back on, and the E8 went away. It has been reading AFR normally since.

Also, after the E8, I can no longer read AFR on my DS Trinity. I tried resetting the analog input and unplugging/plugging the audio jack but still no AFR. I'm guessing the audio jack cable has become defective. Can I still salvage it by switching from analog input 1 to 2 or do I need a whole new cable?
__________________

Last edited by Texas SRT8; 05-21-2012 at 09:32 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-21-2012, 09:37 PM
A.V.GCSRT8 A.V.GCSRT8 is online now
Elite Contributing Member
 
Join Date: Nov 2009
Location: Antelope Valley, Ca
Posts: 2,335
Thanks: 325
Thanked 175 Times in 158 Posts
Is the sensor in at angle in the pipe? Moisture will kill it if it can't burn off. I don't think you can kill the wire though. Try switching the analogs doesn't hurt and won't cost anything to try. I've heard the AEM having issues but not the innovate

Last edited by A.V.GCSRT8; 05-21-2012 at 09:42 PM.
Reply With Quote Quick reply to this message
The Following User Says Thank You to A.V.GCSRT8 For This Useful Post:
Texas SRT8 (05-23-2012)
  #3  
Old 05-21-2012, 11:48 PM
HoustonHemi's Avatar
HoustonHemi HoustonHemi is offline
Major Contributing Member
 
Join Date: Oct 2009
Location: Houston, TX
Posts: 1,739
Thanks: 59
Thanked 109 Times in 82 Posts
Double check your wiring and grounding. Also it may just come back on after a pwer cycle. Those codes were fairly common when I had Innovate stuff.
__________________
2008 SBM SRT8
It's got a cop motor, a 440 cubic inch plant.
Texas HouseofHemi.
Reply With Quote Quick reply to this message
The Following User Says Thank You to HoustonHemi For This Useful Post:
Texas SRT8 (05-23-2012)
  #4  
Old 05-23-2012, 07:53 AM
Texas SRT8's Avatar
Texas SRT8 Texas SRT8 is offline
Major Contributing Member
 
Join Date: Jun 2011
Location: Houston, TX
Posts: 1,313
Thanks: 618
Thanked 219 Times in 168 Posts
Quote:
Originally Posted by A.V.GCSRT8 View Post
Is the sensor in at angle in the pipe? Moisture will kill it if it can't burn off. I don't think you can kill the wire though. Try switching the analogs doesn't hurt and won't cost anything to try. I've heard the AEM having issues but not the innovate
Sesnor is placed between the 9 o'clock and 12 o'clock part of the midpipe.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Innovate, Innovate or nonvate duke50 WK1 Tuning/CMR/Dyno/DataLogging/Gauges 15 09-22-2011 07:18 PM
Innovate MTX-L Installed!! CentralTexHemi WK1 Tuning/CMR/Dyno/DataLogging/Gauges 13 02-17-2011 06:12 PM
TPMS issues and replacement issues brianm WK1 Troubleshooting / Problems Discussion / Dealer Service 2 12-14-2010 06:18 AM
Innovate A/f Meter.... veyronSRT8@TTCreations WK1 SRT8 General Discussion 6 07-22-2008 05:19 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 10:34 AM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
© AutoGuide