Frozen MYgig - Cherokee SRT8 Forum

» Auto Insurance

Go Back   Cherokee SRT8 Forum > WK1 Jeep Grand Cherokee SRT8 Discussion (2006-2010) > WK1 Audio/Video/Nav/UConnect/Electronics

WK1 Audio/Video/Nav/UConnect/Electronics Use this section to discuss all topics related to car audio & video, UConnect, navigation & electronics.

CherokeeSRT8.com is the premier Jeep Cherokee Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 10-01-2010, 12:11 PM
landsteam landsteam is offline
Senior Member
 
Join Date: Feb 2010
Location: Huntington, NY
Posts: 121
Thanks: 6
Thanked 0 Times in 0 Posts
Frozen MYgig

The Mygig froze this morning while I was using the bluetooth.
Hours later it is still frozen, even with the car off the radio display stays on, the buttons do nothing and the radio doesn't work.
If I remove the negative battery cable will this reset it?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-01-2010, 12:47 PM
ekaz's Avatar
ekaz ekaz is offline
Elite Contributing Member
 
Join Date: Feb 2007
Posts: 4,812
Thanks: 266
Thanked 572 Times in 426 Posts
Quote:
Originally Posted by landsteam View Post
The Mygig froze this morning while I was using the bluetooth.
Hours later it is still frozen, even with the car off the radio display stays on, the buttons do nothing and the radio doesn't work.
If I remove the negative battery cable will this reset it?
Remove the battery cable for 20 minutes, resets everything. Positive cable IIRC.
__________________
Join the Caravan for SF10!
Facebook: https://www.facebook.com/SF10caravan
Twitter: @SF10Caravan
Web: sf10caravan.com

2012 300SRT--Mods so far....CMR tune from Toona, tinted taillights, Kooks LTs and high flow cats, soon to be released catback, Mopar lowering springs, HIDs in the driving lights, tinted windows, LMI true CAI, and a bunch of BT bling.
ng.


Powered by PWR Tooned by Johan Blinged by Billet Technologies
Reply With Quote Quick reply to this message
  #3  
Old 10-09-2010, 11:29 PM
ResumeSpeed's Avatar
ResumeSpeed ResumeSpeed is offline
Sur Askdalotte
Lifetime Premium Member
 
Join Date: Feb 2006
Location: Somewhere between here and there
Posts: 2,475
Thanks: 3
Thanked 129 Times in 60 Posts
Quote:
Originally Posted by landsteam View Post
If I remove the negative battery cable will this reset it?
NO! If you have a non-nav MyGIG radio (model REN) NEVER disconnect the battery without first pulling the fuse.

Use this method:

1. With the vehicle ignition off, pull IOD fuse to remove power to head unit (fuse # 28 in the IPM, see http://www.wkjeeps.com/wk_fuses.htm#IPM )

2. Press Open/Close hardkey on upper left of head unit, hold for 10 seconds to discharge capacitors in head unit

3. Replace IOD fuse after 20 minutes and turn ignition on ensure head unit works properly.
Reply With Quote Quick reply to this message
  #4  
Old 10-10-2010, 07:55 AM
hawkman996's Avatar
hawkman996 hawkman996 is offline
CROW HUNTER
Premium Member
 
Join Date: Nov 2008
Location: Western, MI
Posts: 6,044
Thanks: 10
Thanked 204 Times in 151 Posts
Quote:
Originally Posted by ResumeSpeed View Post
NO! If you have a non-nav MyGIG radio (model REN) NEVER disconnect the battery without first pulling the fuse.

Use this method:

1. With the vehicle ignition off, pull IOD fuse to remove power to head unit (fuse # 28 in the IPM, see http://www.wkjeeps.com/wk_fuses.htm#IPM )

2. Press Open/Close hardkey on upper left of head unit, hold for 10 seconds to discharge capacitors in head unit

3. Replace IOD fuse after 20 minutes and turn ignition on ensure head unit works properly.
Mine use to freeze up a lot and I would do as resumespeed describes above and it worked everytime. You should update your software, there is a thread about it. Search mygig update 2.302. Since I updated my software I have experienced no problems.
__________________
2008 Cognac Crystal Pearl Chrysler Aspen---not fast----family hauler
2008 Steel Blue SRT8 Jeep---11.86@114----sold
2006 Inferno Red SRT8 Jeep--12.7@104---my first love taken from me
Reply With Quote Quick reply to this message
  #5  
Old 06-07-2012, 05:30 PM
lr9's Avatar
lr9 lr9 is offline
Senior Member
 
Join Date: Jun 2010
Location: Charlotte, NC
Posts: 182
Thanks: 17
Thanked 4 Times in 4 Posts
Mine froze today when a call came in, and 3 hours later the screen hasn't changed and won't shut off even with the ingnition off and key removed. It still reads "incoming call", and the time on the screen is frozen. No buttons or functions work.

I do have NAV, does it matter which method I use?
Is there anything I can do to prevent this from happening again?



Quote:
Originally Posted by ResumeSpeed View Post
NO! If you have a non-nav MyGIG radio (model REN) NEVER disconnect the battery without first pulling the fuse.

Use this method:

1. With the vehicle ignition off, pull IOD fuse to remove power to head unit (fuse # 28 in the IPM, see http://www.wkjeeps.com/wk_fuses.htm#IPM )

2. Press Open/Close hardkey on upper left of head unit, hold for 10 seconds to discharge capacitors in head unit

3. Replace IOD fuse after 20 minutes and turn ignition on ensure head unit works properly.
__________________
Reply With Quote Quick reply to this message
  #6  
Old 06-07-2012, 07:04 PM
lr9's Avatar
lr9 lr9 is offline
Senior Member
 
Join Date: Jun 2010
Location: Charlotte, NC
Posts: 182
Thanks: 17
Thanked 4 Times in 4 Posts
I disconnected the battery for 20 minutes and reconnected it and all appears to be back to normal.
Do you guys think a software update in now in order?
Reply With Quote Quick reply to this message
  #7  
Old 06-07-2012, 08:29 PM
ASLEEPER's Avatar
ASLEEPER ASLEEPER is online now
Elite Contributing Member
 
Join Date: Dec 2008
Location: Squamish, BC
Posts: 2,243
Thanks: 106
Thanked 253 Times in 234 Posts
Send a message via MSN to ASLEEPER
I would definately do the update. 2.402 is the latest one.
__________________
'09 Brilliant Black, all options, dual Kicker Sub, ambient interior lighting kit, cabin filter, Escort 9500ix w/Stealth mirror cord, Blendmount mirror mount & ZR4 Shifters, Mopar PDA holder, Weathertech Mats w/SRT Logos, Mopar CAI, BT Catch Can w/underhood dress up kit, Jeep rear cargo tray, HID fogs w/functioning rear fogs, shorty 8" black antenna, 6.1 Hemi Badges (fenders), SRT8 badges (doors), Intune & Johan Tune
Reply With Quote Quick reply to this message
The Following User Says Thank You to ASLEEPER For This Useful Post:
lr9 (06-07-2012)
  #8  
Old 06-07-2012, 09:10 PM
BOYCHIKS's Avatar
BOYCHIKS BOYCHIKS is offline
Lifetime Premium Member
Lifetime Premium Member
 
Join Date: Jan 2009
Location: Richmond, VA
Posts: 16,371
Thanks: 266
Thanked 432 Times in 374 Posts
Garage
Yep, mine froze up once every few months, (hasn't in a while) but a simple unplug of the neg cable for a few it would work fine.
__________________
2008 Jeep SRT-8 Red Rock 2.4 Whipple SOLD
2013 Ford Raptor Super Crew 6.2 SOLD
www.youtube.com/BOYCHIKS
Reply With Quote Quick reply to this message
  #9  
Old 06-08-2012, 07:07 AM
lr9's Avatar
lr9 lr9 is offline
Senior Member
 
Join Date: Jun 2010
Location: Charlotte, NC
Posts: 182
Thanks: 17
Thanked 4 Times in 4 Posts
Quote:
Originally Posted by ASLEEPER View Post
I would definately do the update. 2.402 is the latest one.
Thanks! BTW, is there a way to know if I already have this version?
Reply With Quote Quick reply to this message
  #10  
Old 06-08-2012, 08:54 AM
lr9's Avatar
lr9 lr9 is offline
Senior Member
 
Join Date: Jun 2010
Location: Charlotte, NC
Posts: 182
Thanks: 17
Thanked 4 Times in 4 Posts
Ok, I downloaded the latest MyGig (version 2.403) and all is well for now.
I also think that because I had not synced my iphone 3 in while, it may have contributed to the freezing issue. It was not operating very smoothly which Iphones will do if not synced regularly.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The end is near and hell has frozen over CentralTexHemi Off-Topic Discussion 16 12-24-2009 07:21 PM
whats up from Frozen Tundra of Minnesota lbcya New Member Introductions 5 04-28-2009 12:53 AM
Frozen rear shocks? Can it be? kokanee13 WK1 SRT8 General Discussion 12 03-14-2009 02:21 PM
Raced the beast on a frozen river today! kokanee13 WK1 SRT8 General Discussion 9 02-17-2009 09:48 AM
New guy from the land of 10,000(frozen) lakes get8 New Member Introductions 13 01-05-2009 04:33 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 12:28 PM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
© AutoGuide