Why Shifter Lever Assy breaks on Jeeps - Page 5 - Cherokee SRT8 Forum

Auto Insurance

Go Back   Cherokee SRT8 Forum > WK1 Jeep Grand Cherokee SRT8 Discussion (2006-2010) > WK1 Troubleshooting / Problems Discussion / Dealer Service

WK1 Troubleshooting / Problems Discussion / Dealer Service If you are having some problems with your Jeep Grand Cherokee SRT8 and need assistance in troubleshooting and diagnosing the problem, this is the proper place to discuss it. Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

CherokeeSRT8.com is the premier Jeep Cherokee Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #41  
Old 08-20-2010, 04:44 PM
KranZ KranZ is offline
Member
 
Join Date: Mar 2006
Location: Austin, TX
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Didow View Post
so for you guys that did this clean, has it worked for all for all of you? and how frequently were you guys getting the CEL and symptoms? cause right now my symptoms will happen every ohhh 2 days. so im wondering if its the ESM that needs to be replaced or if cleaning this shift assembly should fix it.
I did this fix and it worked. CEL went away and haven't had any issues in almost two months. Before, it was almost every day. I highly recommend you do this if you're seeing these symptoms.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #42  
Old 08-20-2010, 04:59 PM
Didow Didow is offline
Member
 
Join Date: Mar 2009
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
was it difficult or just as simple as it looks?
Reply With Quote Quick reply to this message
  #43  
Old 08-20-2010, 06:04 PM
KranZ KranZ is offline
Member
 
Join Date: Mar 2006
Location: Austin, TX
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
It was pretty easy. I got the board out, I used electronics contact cleaner and q-tips to scrub between and on the graphite plates.
Reply With Quote Quick reply to this message
  #44  
Old 08-21-2010, 11:52 AM
What Neon?'s Avatar
What Neon? What Neon? is offline
Senior Member
 
Join Date: Jun 2009
Location: Chicagoland IL
Posts: 329
Thanks: 0
Thanked 0 Times in 0 Posts
I haven't had 1 issue since the cleaning. almost a year now I think.
__________________

Member www.ChicagolandSrtClub.com
Reply With Quote Quick reply to this message
  #45  
Old 08-21-2010, 01:45 PM
Didow Didow is offline
Member
 
Join Date: Mar 2009
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Wtf

ok so i am at the stage of sliding the shifter assy over where the knob is. but it is stuck on there like a mofo. I removed two visible screws but the right hand side is STUCK so im assuming there is two more screws underneath the assy that cant be seen cause they are covered by the part of the shifter assembly you can see while driving that has the PRND on it. how the hell do i remove that to get to the two remaining screws... there are two clips on the left side but one is like 100% specifically designed not to come off... im so confused now.
Reply With Quote Quick reply to this message
  #46  
Old 08-21-2010, 02:18 PM
Didow Didow is offline
Member
 
Join Date: Mar 2009
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Angry Wtf

ok here is where i am at... HOW do i get this off now!??!?!?
Attached Thumbnails
photo.jpg  
Reply With Quote Quick reply to this message
  #47  
Old 08-21-2010, 05:12 PM
robpp's Avatar
robpp robpp is offline
Elite Contributing Member
 
Join Date: Sep 2007
Location: Colorado
Posts: 3,987
Thanks: 0
Thanked 0 Times in 0 Posts
REMOVAL





1. Remove any necessary console parts for access to shift lever assembly and shifter cables. (Refer to 23 - BODY/INTERIOR/FLOOR CONSOLE - REMOVAL)
2. If necessary, remove the bolts holding the shield, covering the gearshift and park lock cables, to the shifter assembly and remove the shield.
3. Shift transmission into PARK.
4. Disconnect the transmission shift cable (3) at shift lever (1).
5. Remove the shift cable retainer (4) from the notch in the shifter assembly.
6. Verify the key is in the LOCK position and disconnect the park lock cable (5) from the shifter mechansim cam and the notch in the shifter assembly.




7. Disengage all wiring connectors (2, 3) from the shifter assembly (1).
8. Remove all bolts (2) holding the shifter assembly (1) to the floor pan .
9. Remove the shifter assembly (1) from the vehicle.
__________________

Reply With Quote Quick reply to this message
  #48  
Old 08-21-2010, 06:23 PM
Tcnj80's Avatar
Tcnj80 Tcnj80 is offline
Senior Contributing Member
 
Join Date: Nov 2008
Location: Jersey
Posts: 685
Thanks: 56
Thanked 23 Times in 18 Posts
I did this and no more limp mode/codes, just follow the directions and don't rush or you may break something.
Reply With Quote Quick reply to this message
  #49  
Old 08-26-2010, 06:55 AM
a137 a137 is offline
Senior Member
 
Join Date: Oct 2007
Location: Almaty, Kazakhstan
Posts: 196
Thanks: 0
Thanked 3 Times in 2 Posts
Quote:
Originally Posted by Didow View Post
ok so i am at the stage of sliding the shifter assy over where the knob is. but it is stuck on there like a mofo. I removed two visible screws but the right hand side is STUCK so im assuming there is two more screws underneath the assy that cant be seen cause they are covered by the part of the shifter assembly you can see while driving that has the PRND on it. how the hell do i remove that to get to the two remaining screws... there are two clips on the left side but one is like 100% specifically designed not to come off... im so confused now.
there are two more screws ander the rubber insert in the "phone" pocket to the left of the shifter
__________________
Black GC SRT8, 2006
Dashhawk, rear fogs mod, double shocks at rear, Philips LED DRL, Muth mirrors, upgraded audio
Black Toyota 4runner, 2003, Ltd, AWD, V8
X-REAS, K&N CAI, Magnaflow exhaust, Unichip, JAOS skidplate, Muth mirrors, rear fogs mod, front fogs mod, low beam HIDs, upgraded audio
Reply With Quote Quick reply to this message
  #50  
Old 08-31-2010, 10:22 AM
djw340 djw340 is offline
Junior Member
 
Join Date: Aug 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
OK....You have no idea how much I appreciate this info! I have a 2005 Laredo and have had this problem for 2 yrs now. When I took it to the dealership, they said it could be one of two things wrong and that I would just have to drive it until it got worse for them to be able to tell the fix. I thought this was the craziest thing I had ever heard. For me the problem comes and goes. Sometimes it will be a couple of months and other times it is a constant problem and I'm scared to pull out into traffic. I plan on working on this fix real soon. I can't wait to do this and I can't thank you guys enough....well, if it works.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 03:01 AM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
© AutoGuide