Transmission Issues - Page 5 - Cherokee SRT8 Forum

Auto Insurance

Go Back   Cherokee SRT8 Forum > WK2 Jeep Grand Cherokee SRT8 Discussion (2012+) > WK2 SRT8 Troubleshooting / Problems Discussion / Dealer Service

WK2 SRT8 Troubleshooting / Problems Discussion / Dealer Service If you are having some problems with your WK2 SRT8 and need assistance in troubleshooting and diagnosing the problem, this is the proper place to discuss it. Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

CherokeeSRT8.com is the premier Jeep Cherokee Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #41  
Old 12-28-2012, 02:06 PM
Kadonny's Avatar
Kadonny Kadonny is offline
Senior Member
 
Join Date: Oct 2011
Location: Pennsylvania
Posts: 447
Thanks: 41
Thanked 46 Times in 42 Posts
Quote:
Originally Posted by barish93 View Post
Sorry to post in an old thread, but today i noticed that i was getting some bad slip from the trans. One time i was going up a hill and using the paddles and there was just no power for some reason. I downshifted all the way to 2 and was close to full throttle and i barely made it up the hill. After i stopped the car it acted fine for awhile. On my way home, a deer ran across the road, and i slammed on the brakes and when i pushed the accelerator down nothing happened for a good 2-3 seconds. I let off and went back on it again and it was all fine. Any suggestions on what to do.
Sounds just like my issue. I'm not sure it's the actual trans slipping, or if it's the computer and throttle. Does the engine race when you push on the acclerator? Mine does not.

As of this date, I still have not found a solution. Mine only happens occasionally but I still want it fixed. I had a pedal relearn and that seemed to fix it for a few months, but now the problem is back.

My suggestion? See if your dealer will put a recording device on the Jeep and see if you can "capture" a recording of the computer when it happens.

Keep us posted, I'll do the same if I find anything.
__________________
2012 Jeep GC SRT8 WK2
Deep Cherry Red
Lux Group II, SRT Audio, Pano Roof
20% Tint, De-badged doors, Billet catch can, SRT front badge
Previous car CTS-V sedan
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #42  
Old 12-28-2012, 02:30 PM
barish93 barish93 is offline
Senior Member
 
Join Date: Apr 2012
Location: New Jersey
Posts: 443
Thanks: 4
Thanked 20 Times in 18 Posts
Quote:
Originally Posted by Kadonny View Post
Sounds just like my issue. I'm not sure it's the actual trans slipping, or if it's the computer and throttle. Does the engine race when you push on the acclerator? Mine does not.

As of this date, I still have not found a solution. Mine only happens occasionally but I still want it fixed. I had a pedal relearn and that seemed to fix it for a few months, but now the problem is back.

My suggestion? See if your dealer will put a recording device on the Jeep and see if you can "capture" a recording of the computer when it happens.

Keep us posted, I'll do the same if I find anything.
I'm going away next week and I'm leaving the jeep with the dealer for the week for them to sort it out. Hopefully they can find something. But knowing them I will get the "could not replicate the problem" answer.


Sent from my iPhone using AutoGuide.com App
Reply With Quote Quick reply to this message
  #43  
Old 12-31-2012, 10:47 AM
Kadonny's Avatar
Kadonny Kadonny is offline
Senior Member
 
Join Date: Oct 2011
Location: Pennsylvania
Posts: 447
Thanks: 41
Thanked 46 Times in 42 Posts
Quote:
Originally Posted by barish93 View Post
I'm going away next week and I'm leaving the jeep with the dealer for the week for them to sort it out. Hopefully they can find something. But knowing them I will get the "could not replicate the problem" answer.


Sent from my iPhone using AutoGuide.com App
Yup, that's what you'll get. If you push for the recorder, at least you can record what the computer is doing when it happens next.

Good luck, keep me/us posted.
Reply With Quote Quick reply to this message
  #44  
Old 12-31-2012, 11:05 AM
A.V.GCSRT8 A.V.GCSRT8 is offline
Elite Contributing Member
 
Join Date: Nov 2009
Location: Antelope Valley, Ca
Posts: 2,307
Thanks: 324
Thanked 172 Times in 155 Posts
Do either one of you guys have the trinity? I have been logging different things and depending on how sensitive I have the throttle booster I get the same result, in the log you can see the throttle position and pedal position change even when my foot is to the floor. I have it set at 5% now and all is good. No issues, not able to move the pedal and not accelerate, no movement of the sensors while at WOT. I had issues in the logs even on the stock tune just fyi
__________________

PB: 8.05@85.25 1/8 mile

Last edited by A.V.GCSRT8; 12-31-2012 at 11:07 AM.
Reply With Quote Quick reply to this message
  #45  
Old 01-01-2013, 08:50 AM
barish93 barish93 is offline
Senior Member
 
Join Date: Apr 2012
Location: New Jersey
Posts: 443
Thanks: 4
Thanked 20 Times in 18 Posts
Quote:
Originally Posted by A.V.GCSRT8 View Post
Do either one of you guys have the trinity? I have been logging different things and depending on how sensitive I have the throttle booster I get the same result, in the log you can see the throttle position and pedal position change even when my foot is to the floor. I have it set at 5% now and all is good. No issues, not able to move the pedal and not accelerate, no movement of the sensors while at WOT. I had issues in the logs even on the stock tune just fyi
I'll have to give that a try. Thanks.


Sent from my iPhone using AutoGuide.com App
Reply With Quote Quick reply to this message
  #46  
Old 01-01-2013, 09:03 AM
A.V.GCSRT8 A.V.GCSRT8 is offline
Elite Contributing Member
 
Join Date: Nov 2009
Location: Antelope Valley, Ca
Posts: 2,307
Thanks: 324
Thanked 172 Times in 155 Posts
Quote:
Originally Posted by barish93 View Post
I'll have to give that a try. Thanks.


Sent from my iPhone using AutoGuide.com App
Yours may like it in a different % so try different ones. That got rid of my hesitation after launch as well
Reply With Quote Quick reply to this message
  #47  
Old 01-01-2013, 02:25 PM
aaronman aaronman is offline
Junior Member
 
Join Date: Jun 2012
Posts: 1
Thanks: 0
Thanked 1 Time in 1 Post
I had a similiar trans shifting/slipping issue with my wife's SRT8 GC. Our local dealer called worked with the SRT8 engineers and they changed out the valve body about 30 days ago. So far, so good. Hope you get your issues resolved.
Reply With Quote Quick reply to this message
The Following User Says Thank You to aaronman For This Useful Post:
Kadonny (01-14-2013)
  #48  
Old 01-05-2013, 03:55 PM
denver denver is offline
Junior Member
 
Join Date: Jan 2013
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Interesting... My SRT8 makes clunking noises (in the rear) when I go over bumps. Since I've had it (3 1/2 months) the dealer has had to replace the sway bars, cv axel (leaking), clips that hold the bumper & quarter panel siding on, paint job (yes there was a paint flaw in my brand new SRT8) and now it's clunking - a lot. I drove another SRT8 on the lot because someone from Chrysler said it was normal and this SRT8 was as 'quite as a church mouse.' Pretty disappointing for a $64K car. Looking for a better resolution then that's normal.

Last edited by denver; 01-05-2013 at 03:57 PM. Reason: adding specifics
Reply With Quote Quick reply to this message
  #49  
Old 01-14-2013, 06:29 AM
Kadonny's Avatar
Kadonny Kadonny is offline
Senior Member
 
Join Date: Oct 2011
Location: Pennsylvania
Posts: 447
Thanks: 41
Thanked 46 Times in 42 Posts
Quote:
Originally Posted by A.V.GCSRT8 View Post
Do either one of you guys have the trinity? I have been logging different things and depending on how sensitive I have the throttle booster I get the same result, in the log you can see the throttle position and pedal position change even when my foot is to the floor. I have it set at 5% now and all is good. No issues, not able to move the pedal and not accelerate, no movement of the sensors while at WOT. I had issues in the logs even on the stock tune just fyi
Nope, no Trinity. Stock tune here.

I always wondered if the problem could be tuned out. Interesting. My Jeep has been having this problem more and more lately.
Reply With Quote Quick reply to this message
  #50  
Old 01-14-2013, 07:24 AM
barish93 barish93 is offline
Senior Member
 
Join Date: Apr 2012
Location: New Jersey
Posts: 443
Thanks: 4
Thanked 20 Times in 18 Posts
Quote:
Originally Posted by A.V.GCSRT8 View Post
Do either one of you guys have the trinity? I have been logging different things and depending on how sensitive I have the throttle booster I get the same result, in the log you can see the throttle position and pedal position change even when my foot is to the floor. I have it set at 5% now and all is good. No issues, not able to move the pedal and not accelerate, no movement of the sensors while at WOT. I had issues in the logs even on the stock tune just fyi
Just remembered this post haha. Gave it a try and now everything is perfect. I originally had it set to 15% and that's when the issues started to come up. Now I put it back to stock throttle setting and all is well. Thanks.


Sent from my iPhone using AutoGuide.com App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission issues teacher54 WK1 Troubleshooting / Problems Discussion / Dealer Service 3 01-14-2012 06:45 AM
TPMS issues and replacement issues brianm WK1 Troubleshooting / Problems Discussion / Dealer Service 2 12-14-2010 05:18 AM
T/C, Transmission, Braking Issues? VETE8R WK1 Troubleshooting / Problems Discussion / Dealer Service 4 12-03-2009 08:08 AM
transmission issues frenchified WK1 Troubleshooting / Problems Discussion / Dealer Service 16 12-16-2008 04:07 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 05:43 PM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
© AutoGuide