Moved te IAT sensor downstream - Page 2 - Cherokee SRT8 Forum

Auto Insurance

Go Back   Cherokee SRT8 Forum > WK2 Jeep Grand Cherokee SRT8 Performance Discussion > WK2 SRT8 Intake/Exhaust Discussion

CherokeeSRT8.com is the premier Jeep Cherokee Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #11  
Old 12-01-2012, 02:44 PM
A.V.GCSRT8 A.V.GCSRT8 is online now
Elite Contributing Member
 
Join Date: Nov 2009
Location: Antelope Valley, Ca
Posts: 2,320
Thanks: 324
Thanked 172 Times in 155 Posts
Just keep your jeep Jim even after the warranty is up and just add another ride to the stable
__________________

PB: 8.05@85.25 1/8 mile
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #12  
Old 12-05-2012, 07:03 PM
A.V.GCSRT8 A.V.GCSRT8 is online now
Elite Contributing Member
 
Join Date: Nov 2009
Location: Antelope Valley, Ca
Posts: 2,320
Thanks: 324
Thanked 172 Times in 155 Posts
Quote:
Originally Posted by A.V.GCSRT8 View Post
WOT doesnt seem to like it. I see some more knock than I normally do and saw some lt and I never get lt. So plugged the hole and back to stock location
I take this back, was a faulty IAT sensor. Used the one that came with the Jeep and all is good at WOT now, no weird knock issues.
Reply With Quote Quick reply to this message
  #13  
Old 12-05-2012, 08:22 PM
Mongoose9400's Avatar
Mongoose9400 Mongoose9400 is offline
The Traveler
Lifetime Premium Member
 
Join Date: Dec 2010
Location: Dallas, TX
Posts: 5,225
Thanks: 462
Thanked 667 Times in 516 Posts
Quote:
Originally Posted by A.V.GCSRT8 View Post
I take this back, was a faulty IAT sensor. Used the one that came with the Jeep and all is good at WOT now, no weird knock issues.
Was the supplied IAT different from the OEM or what? A bought a new OEM for my bwoody install and it was only like $10-15 at the dealer.


Sent from my iPhone using AutoGuide.com App
__________________
Zac
2012 WK2 SRT8 Mineral Gray | BT Catch Can | BT Underhood Goodies | Painted Engine Bay | Bwoody CAI | Custom Washer Setup | Shaved Jeep/Color Matched Liftgate Brow| Chrome Delete | Debadge-ReBadged | 5% Tint All Around | 78% Windshield Tint | Passport 9500ix | TLS Rear Fogs | 5k HID Fogs | 6k LED Running Lights | 8k Bi-Xenon | 6K LED Plate Lights | 6k Interior LED Swap | Borla ATAK | WK1 Borla Reso Swap | Matching eBrake Pedal | Trinity | Modified DS 93 Tune
SOLD 2007 Silver Jeep SRT8

Reply With Quote Quick reply to this message
  #14  
Old 12-05-2012, 08:28 PM
A.V.GCSRT8 A.V.GCSRT8 is online now
Elite Contributing Member
 
Join Date: Nov 2009
Location: Antelope Valley, Ca
Posts: 2,320
Thanks: 324
Thanked 172 Times in 155 Posts
Quote:
Originally Posted by Mongoose9400 View Post
Was the supplied IAT different from the OEM or what? A bought a new OEM for my bwoody install and it was only like $10-15 at the dealer.


Sent from my iPhone using AutoGuide.com App
It was one I bought from the dealer about 6-7 months ago because the lx guys were talking about how they were running this new longer style sensor on the 6.1's and it was reducing their knock. So I bought one from the dealer along with an extension that combined the black plug from the 6.1 to the new gray plug for this sensor. My WK1 freaked out with this sensor as well so I just figured the 6.1 didnt like it. Talked to Chris on the lx site about my recent issue and he said to try my other sensor that came with the Jeep because he has not heard of any complaints from any of the lx 392 guys who run his intake with this extension
Reply With Quote Quick reply to this message
  #15  
Old 12-05-2012, 08:31 PM
Mongoose9400's Avatar
Mongoose9400 Mongoose9400 is offline
The Traveler
Lifetime Premium Member
 
Join Date: Dec 2010
Location: Dallas, TX
Posts: 5,225
Thanks: 462
Thanked 667 Times in 516 Posts
Gotcha. Yeah, I've seen some info on the different IAT styles before. Seems running the OEM supplied is the best bet for the Jeep.


Sent from my iPhone using AutoGuide.com App
Reply With Quote Quick reply to this message
  #16  
Old 12-05-2012, 08:35 PM
A.V.GCSRT8 A.V.GCSRT8 is online now
Elite Contributing Member
 
Join Date: Nov 2009
Location: Antelope Valley, Ca
Posts: 2,320
Thanks: 324
Thanked 172 Times in 155 Posts
Quote:
Originally Posted by Mongoose9400 View Post
Gotcha. Yeah, I've seen some info on the different IAT styles before. Seems running the OEM supplied is the best bet for the Jeep.


Sent from my iPhone using AutoGuide.com App
works good now, nothing bad anymore, dont know if its helping but I dont think its hurting. Wish I would have tried a diferent 6.4 sensor on my WK1 to see if it did reduce any kr, had some good timing in it but would have been cool to get more...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Has anyone tried these to avoid downstream cat CEL? SRT8-DOUGLAS SR WK1 Intake/ Exhaust Discussion 2 02-19-2011 09:01 PM
Transmission temperature sensor hookup (Moved) double_d99 WK1 SRT8 General Discussion 0 06-01-2010 08:51 PM
Volant installation sensor question (Moved) flats3 WK1 Intake/ Exhaust Discussion 13 09-23-2009 08:07 PM
park sensor issue (Moved) srtTOMMY WK1 Interior/Exterior Visual Modifications 1 07-28-2009 09:22 AM
False error codes showing up for rear backup sensor system (Moved) cyanideg WK1 Troubleshooting / Problems Discussion / Dealer Service 5 07-27-2009 10:48 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 09:25 AM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
© AutoGuide