No power to stereo, fuse OK - Cherokee SRT8 Forum
WK1 Troubleshooting / Problems Discussion / Dealer Service If you are having some problems with your Jeep Grand Cherokee SRT8 and need assistance in troubleshooting and diagnosing the problem, this is the proper place to discuss it. Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 22 (permalink) Old 01-22-2013, 12:12 PM Thread Starter
Member
 
kf12538's Avatar
 
Join Date: Dec 2010
Location: Wichita, KS
Posts: 73
Thanks: 0
Thanked 4 Times in 3 Posts
No power to stereo, fuse OK

I recently had major engine problems from a timing gear pin shearing on my cam. I have replaced all the parts and my jeep is running great now. However, the stereo will not power on since the engine trouble. There is NO 12V constant power on the factory harness and the fuses are fine. When the trouble happened, the ignition key light came on the dash. Could that have anything to do with cutting stereo power? Any ideas?

RIPP gen 2 supercharger, Magnaflow catback, Black Ops control arms, end links, R1 drilled/slotted rotors, Black Ops carbon fiber front lip
kf12538 is offline  
Sponsored Links
Advertisement
 
post #2 of 22 (permalink) Old 01-23-2013, 04:10 PM
Lifetime Premium Member
 
BOYCHIKS's Avatar
 
Join Date: Jan 2009
Location: Richmond, VA
Posts: 16,360
Thanks: 266
Thanked 432 Times in 374 Posts
Garage
Is it the stock stereo? Try unplugging the NEG battery cable for 15-20 seconds

2008 Jeep SRT-8 Red Rock 2.4 Whipple SOLD
2013 Ford Raptor Super Crew 6.2 SOLD
www.youtube.com/BOYCHIKS
BOYCHIKS is offline  
post #3 of 22 (permalink) Old 01-23-2013, 05:00 PM Thread Starter
Member
 
kf12538's Avatar
 
Join Date: Dec 2010
Location: Wichita, KS
Posts: 73
Thanks: 0
Thanked 4 Times in 3 Posts
It's an aftermarket deck. I tried disconnecting the battery and nothing changed.
kf12538 is offline  
post #4 of 22 (permalink) Old 01-23-2013, 05:07 PM
Senior Member
 
Join Date: Apr 2012
Location: Milwaukee Area, Wisconsin
Posts: 141
Thanks: 15
Thanked 13 Times in 13 Posts
Garage
Do you have power at the fuse?

2006 Jeep SRT (SOLD)
2009 Pontiac G8 GT (Hoping to be sold soon for a C6 Z06)
Theconnman2 is offline  
post #5 of 22 (permalink) Old 01-24-2013, 09:27 AM
Lifetime Premium Member
 
philthyphil's Avatar
 
Join Date: May 2010
Location: Lone Tree, CO
Posts: 1,466
Thanks: 29
Thanked 86 Times in 76 Posts
I know this is gonna sound crazy but there are a few spots in the fuse box that say spare. They are not spares check and make sure the fuses there are good. I took one out and my radio didnt turn on.


2006 Black GC SRT8 6.1L -SOLD
Headers, Heads, Cam, Intake Mani, TB, Intake, Exhaust, etc.
philthyphil is offline  
post #6 of 22 (permalink) Old 01-25-2013, 07:41 AM Thread Starter
Member
 
kf12538's Avatar
 
Join Date: Dec 2010
Location: Wichita, KS
Posts: 73
Thanks: 0
Thanked 4 Times in 3 Posts
Those are good ideas, I have been so busy I haven't had time to keep troubleshooting it yet. I need to verify there is power at the fuse box circuit. Also, I had removed a spare fuse to use for another circuit that was blown. I found a bad fuse with my meter. That may have something to do with it.
kf12538 is offline  
post #7 of 22 (permalink) Old 01-27-2013, 03:04 PM Thread Starter
Member
 
kf12538's Avatar
 
Join Date: Dec 2010
Location: Wichita, KS
Posts: 73
Thanks: 0
Thanked 4 Times in 3 Posts
I'll be damned if it wasn't one of those spare fuses. Stereo is working again...thanks for the suggestions!
kf12538 is offline  
post #8 of 22 (permalink) Old 01-27-2013, 04:40 PM
Elite Contributing Member
 
bxcharger's Avatar
 
Join Date: Jul 2008
Location: Colorado
Posts: 2,511
Thanks: 578
Thanked 652 Times in 458 Posts
Phil to the rescue again, damn I need to keep you on speed dial. Between you and Jim the noobs like us would be lost without you 2!

Last edited by bxcharger; 01-27-2013 at 04:41 PM. Reason: Correction
bxcharger is online now  
post #9 of 22 (permalink) Old 09-26-2015, 06:18 AM
Senior Member
 
Join Date: Oct 2014
Posts: 270
Thanks: 0
Thanked 13 Times in 12 Posts
What other fuses can I check?
SRT8KING300 is offline  
post #10 of 22 (permalink) Old 09-26-2015, 07:29 AM
Elite Contributing Member
 
KMdef9's Avatar
 
Join Date: Jul 2011
Location: The Motorcity
Posts: 2,460
Thanks: 163
Thanked 547 Times in 410 Posts
Garage
Is your radio out because it's not getting power?

2010 Modern Blue Pearlcoat
Performance:
Borla S catback, Volant CAI, Tooned, t-stat, BWoody swaybar endlinks, R1 Concept cross-drilled and slotted rotors
Visual:
HID fogs, LED hi beams, LED switchbacks, LED reverse, LED rear fogs, stobe 3rd brake light, laser jammer (front and rear), Stillen covers, de-badged 'Jeep', gunmetal FR rims (winter), Llyod's mats (summer & winter), tinted windows, 2014 'SRT' badges, shorty antenna
KMdef9 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
No power locks, fob won't unlock or lock doors & nothing inside has power jmckenzie WK1 Troubleshooting / Problems Discussion / Dealer Service 1 09-09-2011 01:36 PM
No power in dash power outlets J33PSRT8 WK1 Troubleshooting / Problems Discussion / Dealer Service 6 07-28-2011 03:27 PM
abs fuse BTC-SRT8 WK1 SRT8 General Discussion 1 01-05-2011 11:41 PM
Moved: Radio going from stereo to mono back to stereo? Hockey Goalie WK1 Audio/Video/Nav/UConnect/Electronics 1 10-09-2010 03:15 PM
AWD Fuse MaSaFi WK1 Troubleshooting / Problems Discussion / Dealer Service 15 09-29-2009 04:25 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome