need help with cam install - Cherokee SRT8 Forum
WK1 Troubleshooting / Problems Discussion / Dealer Service If you are having some problems with your Jeep Grand Cherokee SRT8 and need assistance in troubleshooting and diagnosing the problem, this is the proper place to discuss it. Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 12-24-2012, 07:39 PM Thread Starter
Junior Member
 
Join Date: Jun 2010
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
need help with cam install

I installed a fri littleboy cam today. I went to start it, and all it does is start for a few seconds. Could I have the timing marks wrong? Could this be the cause of this? Any suggestions and/or help would be appreciated.
PEORIASRT is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 12-24-2012, 08:11 PM
Elite Contributing Member
 
CHUCKTOWNSRT8's Avatar
 
Join Date: Jun 2008
Location: Charleston, SC
Posts: 2,536
Thanks: 163
Thanked 513 Times in 349 Posts
Quote:
Originally Posted by PEORIASRT View Post
I installed a fri littleboy cam today. I went to start it, and all it does is start for a few seconds. Could I have the timing marks wrong? Could this be the cause of this? Any suggestions and/or help would be appreciated.
Did you get a tune for it?

Stage 6 Turbocharged 6.1L Silver Jeep SRT8. PWR 419 9.5:1 built for boost/ PWR Mean Street Heads/ Ported Intake/AR 90mm/ PWR Turbo cam/ SHR Tranny/ FTI 3200 Stall Converter. Tuned by Jerseyboy 10.54 @130mph on 12 psi on stock bottom end. Stroker #'s coming soon!. Ballin on a budget!
[SIGPIC][/SIGPIC]
CHUCKTOWNSRT8 is offline  
post #3 of 15 (permalink) Old 12-24-2012, 08:17 PM
Super Moderator
 
cmn1's Avatar
 
Join Date: Mar 2006
Location: Addison, IL
Posts: 10,577
Thanks: 1,052
Thanked 1,863 Times in 1,353 Posts
Garage
Did you throw a code? Usually if the timing is off you will throw a code after you get over 3000 rpms. Get in touch with a tuner.

Chad (06 Inferno Red GC SRT8) PWR 6.3L, PWR Apache Heads, Stage6 76 mm Turbo, Stage6 Fuel Pump, SHR NAG1-HTCr, PI 2400 TQ Converter, ATI Flex Plate, BC Coil Overs, Wilwood TC6R calipers, Kooks Headers, Mopar exhaust, MM 85mm T-body, Jerseyboy CMR, Bwoody Sway Links, R1 Concepts F Slot & Dimp, R StopTech Pads, Earls Trans Cooler, TLS Rear Fog Harness
cmn1 is offline  
post #4 of 15 (permalink) Old 12-24-2012, 08:43 PM Thread Starter
Junior Member
 
Join Date: Jun 2010
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
It did not throw a code, but I could not get it over 3000 rpms. I have not put a tune on it yet. I thought it would run a little bit without a tune. It is hard starting & spits & stutters for a few seconds and then dies. Would a tune fix this? This forum is great. I have guys trying to help me on Xmas Eve. Merry Xmas.
PEORIASRT is offline  
post #5 of 15 (permalink) Old 12-24-2012, 10:20 PM
Senior Contributing Member
 
nyhockeyref93's Avatar
 
Join Date: Mar 2011
Location: Long Island
Posts: 970
Thanks: 18
Thanked 102 Times in 77 Posts
you need a tune lol, sometime they'll run without a tune just idling for a little but most likely going to stall itself out.



2007 Silver Jeep SRT8...that's all you need to know
nyhockeyref93 is offline  
post #6 of 15 (permalink) Old 12-24-2012, 10:42 PM
Premium Reformed Member
 
tugboatchad's Avatar
 
Join Date: Jan 2010
Location: The great NorthWet (Seattle)
Posts: 3,494
Thanks: 2,384
Thanked 939 Times in 647 Posts
My lil boy ran pretty decent without a tune. I drove it 70 miles after install, it would stall out several times in the beginning and then it was fine. Do you have a tune in the works for it?


Sent from my iPhone using AutoGuide.com App

Troy built 2010 Jeep SRT8, Dings Racing forged 392 stroker, boost reference return style fuel system, Mondello heads & manifold, ARH 1 7/8" LT's, Off road midpipe, stock cat back exhaust, ATI 17% OD pulley, Stage 6 2-step, Fluidyne radiator, PP built Nag1, remote transmission cooler, PP Dom. TC., 6,500 PTCM, Wavetrac rear LSD.
tugboatchad is offline  
post #7 of 15 (permalink) Old 12-24-2012, 11:10 PM
Elite Contributing Member
 
WIPLASH's Avatar
 
Join Date: Jun 2009
Posts: 3,769
Thanks: 328
Thanked 432 Times in 348 Posts
it should run ok without a tune but a tune is recommended.


Sent from my iPhone using AutoGuide.com Free App


www.dingsracing.com
I'm gettting frustrated with modding
WIPLASH is offline  
post #8 of 15 (permalink) Old 12-25-2012, 01:50 PM Thread Starter
Junior Member
 
Join Date: Jun 2010
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
if it 's off a tooth,how will it run?since the cam is already a +4.
PEORIASRT is offline  
post #9 of 15 (permalink) Old 12-25-2012, 02:44 PM
Premium Reformed Member
 
tugboatchad's Avatar
 
Join Date: Jan 2010
Location: The great NorthWet (Seattle)
Posts: 3,494
Thanks: 2,384
Thanked 939 Times in 647 Posts
Quote:
Originally Posted by PEORIASRT View Post
if it 's off a tooth,how will it run?since the cam is already a +4.
I would think if its off a tooth and from what I've been told by someone who did that very thing it will run like shit or not at all. The alignment on the dots during install is crucial.


Sent from my iPhone using AutoGuide.com App
tugboatchad is offline  
The Following User Says Thank You to tugboatchad For This Useful Post:
ekaz (12-26-2012)
post #10 of 15 (permalink) Old 12-25-2012, 05:29 PM
Super Moderator
 
cmn1's Avatar
 
Join Date: Mar 2006
Location: Addison, IL
Posts: 10,577
Thanks: 1,052
Thanked 1,863 Times in 1,353 Posts
Garage
Quote:
Originally Posted by tugboatchad View Post
I would think if its off a tooth and from what I've been told by someone who did that very thing it will run like shit or not at all. The alignment on the dots during install is crucial.


Sent from my iPhone using AutoGuide.com App
If timing is off you should throw a code. OP, try to keep Jeep running by feathering the throttle. The code usually shows above 3000rpms
cmn1 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Do I need to install new bolts when I install my new headers? crabphir WK1 Intake/ Exhaust Discussion 9 05-08-2012 10:30 AM
Hid install TheSrt8power WK1 Lighting Discussion 11 02-06-2012 02:49 PM
CAI install? SML9284 New England 21 06-13-2010 05:43 PM
HELP on Afe install please alfman9 WK1 SRT8 General Discussion 5 01-29-2010 06:59 PM
HID Install MARK16 WK1 Troubleshooting / Problems Discussion / Dealer Service 3 10-03-2007 02:21 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome