engine cuts off for a split second. - Cherokee SRT8 Forum
WK1 Troubleshooting / Problems Discussion / Dealer Service If you are having some problems with your Jeep Grand Cherokee SRT8 and need assistance in troubleshooting and diagnosing the problem, this is the proper place to discuss it. Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 20 (permalink) Old 12-10-2012, 10:20 PM Thread Starter
Senior Member
 
SrtGuy's Avatar
 
Join Date: Nov 2009
Location: Odessa Tx
Posts: 138
Thanks: 0
Thanked 0 Times in 0 Posts
engine cuts off for a split second.

hey guys ans gals...i need some help, im driving down the street in second gear, and the jeep is doing fine and all the sudden, the engine cuts off for a split second and a red light flashes above the SRT-8 emblem in the dash? it flashes too fast for me to see what it is? anyone else had this problem?
thanks mike.
SrtGuy is offline  
Sponsored Links
Advertisement
 
post #2 of 20 (permalink) Old 12-10-2012, 11:21 PM
Straight Up Beast SON!!!
 
Knuckles's Avatar
 
Join Date: Oct 2008
Location: Chicagorilla!!
Posts: 17,121
Thanks: 2,910
Thanked 1,229 Times in 992 Posts
Connect up your Predator or Trinity and see if your popping any codes...... Could be a ESM going bad possibly, but you need impedence.the codes first.....

Knuckles
Mods: Bwoody CAI/FRI Lil boy Cam/ SW Headers/CORSA exhaust/SLP UD Pulley/Black Ops Autoworks Ported Intake Manny/Built Trans with FTI 3600 stall/ Johan aka Diablotoona Custom Tune
Knuckles is offline  
post #3 of 20 (permalink) Old 12-11-2012, 05:40 AM
Lifetime Premium Member
 
nyjoed's Avatar
 
Join Date: Nov 2009
Location: Westchester, N.Y.
Posts: 5,201
Thanks: 418
Thanked 388 Times in 278 Posts
Send a message via Yahoo to nyjoed
Is it just the engine or is it completely shutting off then back on? ( like u shit it off and back on?)


Sent from my iPhone using AutoGuide.com App

2010 silver Jeep SRT8 W/ opts 1 and 2 W/ performance audio and nav

72mm FOGLIGHT TWIN TURBO
nyjoed is offline  
The Following User Says Thank You to nyjoed For This Useful Post:
roadboy (12-11-2012)
post #4 of 20 (permalink) Old 12-11-2012, 06:23 AM
Lifetime Premium Member
 
roadboy's Avatar
 
Join Date: Mar 2011
Location: Calgary Canada
Posts: 3,836
Thanks: 1,175
Thanked 960 Times in 791 Posts
Garage
Quote:
Originally Posted by nyjoed View Post
( like u shit it off and back on?)

That made me laugh this morning, thank you
Sent from my iPhone using AutoGuide.com App


Sent from my GT-I9100M using AutoGuide.Com Free App


11.79@113
2008 Jeep GCSRT8 Procharger D1 SHR Viking and FTI 3200 stall
R1 rotors and stop techs, reso-delete,
Electric exhaust cuts outs
Demonized and tuned by Datoona!!!!
roadboy is offline  
post #5 of 20 (permalink) Old 12-11-2012, 06:54 AM Thread Starter
Senior Member
 
SrtGuy's Avatar
 
Join Date: Nov 2009
Location: Odessa Tx
Posts: 138
Thanks: 0
Thanked 0 Times in 0 Posts
The engine just kinda studers and keeps going.. When I use my system check it says "system ok"... But I'll use my programmer today. I'll keep you guys posted.
SrtGuy is offline  
post #6 of 20 (permalink) Old 12-11-2012, 07:04 AM
Lifetime Premium Member
 
nyjoed's Avatar
 
Join Date: Nov 2009
Location: Westchester, N.Y.
Posts: 5,201
Thanks: 418
Thanked 388 Times in 278 Posts
Send a message via Yahoo to nyjoed
Quote:
Originally Posted by roadboy View Post
Sent from my GT-I9100M using AutoGuide.Com Free App
Lol! * shut*


Sent from my iPhone using AutoGuide.com App
nyjoed is offline  
post #7 of 20 (permalink) Old 12-11-2012, 07:51 AM
Senior Member
 
bushmaster3000's Avatar
 
Join Date: Oct 2010
Location: Houston
Posts: 487
Thanks: 6
Thanked 46 Times in 38 Posts
Does it do it at constant speeds, during acceleration or during shifts?

~~~~~ Special Thanks to~~~~
Skip at Demon Performance
Bada$$ Tuner Johan!
bushmaster3000 is offline  
post #8 of 20 (permalink) Old 12-11-2012, 05:40 PM Thread Starter
Senior Member
 
SrtGuy's Avatar
 
Join Date: Nov 2009
Location: Odessa Tx
Posts: 138
Thanks: 0
Thanked 0 Times in 0 Posts
it s doing it during acceleration only.
SrtGuy is offline  
post #9 of 20 (permalink) Old 12-11-2012, 05:50 PM
Member
 
Join Date: Apr 2012
Posts: 64
Thanks: 0
Thanked 7 Times in 5 Posts
Mine did that twice under hard acceleration but I didn't see the light.


Sent from my iPhone using AutoGuide.com App
Tickets_A_Plenty is offline  
post #10 of 20 (permalink) Old 12-11-2012, 05:54 PM Thread Starter
Senior Member
 
SrtGuy's Avatar
 
Join Date: Nov 2009
Location: Odessa Tx
Posts: 138
Thanks: 0
Thanked 0 Times in 0 Posts
its just all the sudden it started doing this? IF it is the computer how much arr they and where would i go about getting one?
SrtGuy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
jeep just cuts out nyjoed WK1 Audio/Video/Nav/UConnect/Electronics 16 11-29-2012 04:07 PM
Looking for a company with DMH low profile cuts in stock Blkoutsrt8 WK1 SRT8 General Discussion 3 06-13-2012 05:05 PM
Dealer techs taking short cuts digi WK1 Troubleshooting / Problems Discussion / Dealer Service 15 10-02-2010 08:34 PM
B&B's split a seam... 12SECUV WK1 SRT8 General Discussion 41 02-20-2007 07:58 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome