And so it continues - Cherokee SRT8 Forum
WK1 Troubleshooting / Problems Discussion / Dealer Service If you are having some problems with your Jeep Grand Cherokee SRT8 and need assistance in troubleshooting and diagnosing the problem, this is the proper place to discuss it. Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 35 (permalink) Old 11-22-2012, 10:46 AM Thread Starter
Lifetime Premium Member
 
Tim H Calgary's Avatar
 
Join Date: Jun 2011
Posts: 1,614
Thanks: 653
Thanked 340 Times in 255 Posts
And so it continues

Keeping up with tradition I had my truck back for a whopping three days before it stopped running yet again. Truck was stone dead this morning not even a click. The interior light did have some juice so the connection is there. I just got it back from having the new dual pump fore innovations hat installed. Not sure if that had something to do with it, I assume those would only come on when it is keyed on?. As well how would I go about diagnosing battery vs alternator?

Thanks guys!

PWR 393, Procharged D-1 @ 6 psi.
Tim H Calgary is offline  
Sponsored Links
Advertisement
 
post #2 of 35 (permalink) Old 11-22-2012, 10:54 AM
Senior Contributing Member
 
Join Date: Nov 2009
Location: Calgary, Canada
Posts: 600
Thanks: 97
Thanked 41 Times in 33 Posts
Also dont rule out the starter. When I had my battery gremlin it was due to a bad starter. I had AMA test the battery and it was fine even though the Jeep was dead. I got a boost and away it went until one time it just would not turn over anymore.

2007 JGC SRT8 Red Rock -- The Screamin' Phoenix
Yohan Tuned
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, Corsa Exhaust, Mopar CAI, Catch Can, R1 S&C Rotors, StopTech St. Perf. Pads, BWoody End Links, Kicker Sub & Speaker Upgrade
Winter: 18" Sport Edition F10 with TPMS and Pirelli Scorpion Ice & Snow - Run Flat - 255/55R18 XL
calgary.srt8 is offline  
post #3 of 35 (permalink) Old 11-22-2012, 11:00 AM Thread Starter
Lifetime Premium Member
 
Tim H Calgary's Avatar
 
Join Date: Jun 2011
Posts: 1,614
Thanks: 653
Thanked 340 Times in 255 Posts
Cool thanks Farren I am calling AMA after work.
Tim H Calgary is offline  
post #4 of 35 (permalink) Old 11-22-2012, 11:10 AM
Straight Up Beast SON!!!
 
Knuckles's Avatar
 
Join Date: Oct 2008
Location: Chicagorilla!!
Posts: 17,127
Thanks: 2,910
Thanked 1,230 Times in 993 Posts
Easiest way to check.a battery is to take it to your local autoparts store and have them charge and load test the battery..... Just cuz a battery will show higher then 11.5 volts does not mean the battery is working, so its underload that you would know if the battery is good or not.. I would start there first....

Knuckles
Mods: Bwoody CAI/FRI Lil boy Cam/ SW Headers/CORSA exhaust/SLP UD Pulley/Black Ops Autoworks Ported Intake Manny/Built Trans with FTI 3600 stall/ Johan aka Diablotoona Custom Tune
Knuckles is offline  
The Following User Says Thank You to Knuckles For This Useful Post:
Tim H Calgary (11-22-2012)
post #5 of 35 (permalink) Old 11-22-2012, 11:17 AM Thread Starter
Lifetime Premium Member
 
Tim H Calgary's Avatar
 
Join Date: Jun 2011
Posts: 1,614
Thanks: 653
Thanked 340 Times in 255 Posts
Battery is only 5 months old, but considering the other options battery is probably the best case scenario.
Tim H Calgary is offline  
post #6 of 35 (permalink) Old 11-22-2012, 11:36 AM
Super Moderator
 
Muellge's Avatar
 
Join Date: Apr 2007
Location: NOLA
Posts: 3,751
Thanks: 426
Thanked 318 Times in 204 Posts
lots of wires disconnected and reconnected for that hat, start with the fuses and then the hardwires....? Let installer troubleshoot.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Five Door League...

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Muellge is offline  
The Following User Says Thank You to Muellge For This Useful Post:
Tim H Calgary (11-22-2012)
post #7 of 35 (permalink) Old 11-22-2012, 11:40 AM
Straight Up Beast SON!!!
 
Knuckles's Avatar
 
Join Date: Oct 2008
Location: Chicagorilla!!
Posts: 17,127
Thanks: 2,910
Thanked 1,230 Times in 993 Posts
Quote:
Originally Posted by Tim H Calgary View Post
Battery is only 5 months old, but considering the other options battery is probably the best case scenario.
EEEEEEE......I doubt its the battery then, but should never over look it bro.... If the battery is good then you have something drawing current while the vehicle is off......
Knuckles is offline  
The Following User Says Thank You to Knuckles For This Useful Post:
Tim H Calgary (11-22-2012)
post #8 of 35 (permalink) Old 11-22-2012, 11:47 AM Thread Starter
Lifetime Premium Member
 
Tim H Calgary's Avatar
 
Join Date: Jun 2011
Posts: 1,614
Thanks: 653
Thanked 340 Times in 255 Posts
I didn't start it for three days (since Monday) and my alarm (viper) does tend to drain the battery a bit but 3 days seems insignificant. I am hoping I was just a moron and left something on. I will get the AMA guy to test the battery when he comes to boost me after work. If the battery is good it goes back to the shop for trouble shooting... It's literally been there 2 and 1/2 out of the last 3 months. Very frustrating!

Thanks again guys.
Tim H Calgary is offline  
post #9 of 35 (permalink) Old 11-22-2012, 12:22 PM
Senior Contributing Member
 
Poutine's Avatar
 
Join Date: Apr 2008
Location: Canada
Posts: 656
Thanks: 16
Thanked 50 Times in 44 Posts
Man, you seem to run into a lot of problems since that Procharger install.
Makes me think twice of getting one down the line.
Hopefully just the starter.
Good luck
Poutine is offline  
post #10 of 35 (permalink) Old 11-22-2012, 12:51 PM
Senior Member
 
Black-sleeper's Avatar
 
Join Date: Nov 2007
Posts: 359
Thanks: 226
Thanked 16 Times in 11 Posts
gaz + lighter = WIN

2004 Black Dodge SRT-4 Stage 3R (SOLD) 2008 Caliber SRT-4 Inferno Red (SOLD)
2006 Bright Silver 300C SRT-8 (SOLD) 2007 Black JGC SRT-8 in the driveway!!
Black-sleeper is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
And the modding continues CentralTexHemi WK1 Interior/Exterior Visual Modifications 38 05-01-2013 12:10 AM
The Build Continues JayZilla WK2 SRT8 General Performance Discussion 8 09-22-2012 04:52 AM
She continues to impress MichaelSRT8 Track Talk 6 09-26-2009 11:37 PM
6.1L continues for 2010? mandan007 WK1 SRT8 General Discussion 43 11-26-2008 03:46 PM
My AAC headlight nightmare continues.... Mango WK1 Lighting Discussion 24 06-22-2007 08:40 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome