And so it continues - Page 3 - Cherokee SRT8 Forum
WK1 Troubleshooting / Problems Discussion / Dealer Service If you are having some problems with your Jeep Grand Cherokee SRT8 and need assistance in troubleshooting and diagnosing the problem, this is the proper place to discuss it. Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

Reply
 
LinkBack Thread Tools Display Modes
post #21 of 35 (permalink) Old 11-24-2012, 11:31 AM Thread Starter
Lifetime Premium Member
 
Tim H Calgary's Avatar
 
Join Date: Jun 2011
Posts: 1,614
Thanks: 653
Thanked 340 Times in 255 Posts
On a possibly related note: I noticed the power for the new fuel hat (dual walbro 405's) is directly off the battery. Could those pumps be running while keyed off? it seems like a very likely source of my issue given the timing.

PWR 393, Procharged D-1 @ 6 psi.
Tim H Calgary is offline  
Sponsored Links
Advertisement
 
post #22 of 35 (permalink) Old 11-24-2012, 11:40 AM
Supporting Vendor
 
DemonPerformance's Avatar
 
Join Date: Dec 2011
Location: Coastal Carolina
Posts: 5,546
Thanks: 1,476
Thanked 1,832 Times in 1,102 Posts
Didn't he run the ignition switch to the FC2 relay box? Ask Dan...just to make sure of course

Skip Demon Performance
Sales@DemonPerformance.com
1-888-312-3666
I wonder if they have Outback Steakhouses in the Outback?


2012-2015 Demon Performance Procharger Kits on sale now!!

Last edited by DemonPerformance; 11-24-2012 at 11:41 AM.
DemonPerformance is offline  
post #23 of 35 (permalink) Old 11-24-2012, 12:41 PM Thread Starter
Lifetime Premium Member
 
Tim H Calgary's Avatar
 
Join Date: Jun 2011
Posts: 1,614
Thanks: 653
Thanked 340 Times in 255 Posts
Yah he said they shouldn't come on unless it's keyed on. I bet he did man but I will ask.
Tim H Calgary is offline  
post #24 of 35 (permalink) Old 11-24-2012, 12:50 PM
Straight Up Beast SON!!!
 
Knuckles's Avatar
 
Join Date: Oct 2008
Location: Chicagorilla!!
Posts: 17,125
Thanks: 2,910
Thanked 1,229 Times in 992 Posts
Quote:
Originally Posted by Tim H Calgary View Post
On a possibly related note: I noticed the power for the new fuel hat (dual walbro 405's) is directly off the battery. Could those pumps be running while keyed off? it seems like a very likely source of my issue given the timing.
If the pumps were on even after you turned the Jeep off then you would hear them.... Based on the Fuse box that came with the Fore Fuel hat it looks pretty simple..... So I assume the positive wire that went to the stock fuel hat is now your remote wire that is triggering the 2 relays that are on the small circuit board..... Take .it back to the shop that installed it and have them double check the install on the fuel hat.... No need to bust your head on theres one if you already paid for an install.... You know?

Knuckles
Mods: Bwoody CAI/FRI Lil boy Cam/ SW Headers/CORSA exhaust/SLP UD Pulley/Black Ops Autoworks Ported Intake Manny/Built Trans with FTI 3600 stall/ Johan aka Diablotoona Custom Tune
Knuckles is offline  
post #25 of 35 (permalink) Old 11-24-2012, 01:18 PM Thread Starter
Lifetime Premium Member
 
Tim H Calgary's Avatar
 
Join Date: Jun 2011
Posts: 1,614
Thanks: 653
Thanked 340 Times in 255 Posts
I keyed it and it started doing this:

http://s1286.beta.photobucket.com/us..._0158.mp4.html

Is that just from the super low battery?. I suspect something is touching that shouldn't be.
Tim H Calgary is offline  
post #26 of 35 (permalink) Old 11-24-2012, 01:20 PM Thread Starter
Lifetime Premium Member
 
Tim H Calgary's Avatar
 
Join Date: Jun 2011
Posts: 1,614
Thanks: 653
Thanked 340 Times in 255 Posts
Quote:
Originally Posted by Knuckles View Post
If the pumps were on even after you turned the Jeep off then you would hear them.... Based on the Fuse box that came with the Fore Fuel hat it looks pretty simple..... So I assume the positive wire that went to the stock fuel hat is now your remote wire that is triggering the 2 relays that are on the small circuit board..... Take .it back to the shop that installed it and have them double check the install on the fuel hat.... No need to bust your head on theres one if you already paid for an install.... You know?
Very true Knuckles just trying to troubleshoot as its kinda bugging me lol. I was planning on some datalogging today, not looking good.
Tim H Calgary is offline  
post #27 of 35 (permalink) Old 11-24-2012, 05:25 PM
Senior Member
 
Join Date: Jun 2012
Location: Calgary, AB
Posts: 303
Thanks: 24
Thanked 10 Times in 7 Posts
Sorry to hear that happening again bro. Lots of things can kill the battery in 3 days so it might not be something very serious. If you have the time you can disconnect the positive side of the battery and put an amp meter on it. If there's a significant current with the truck off start disconnecting the loads (fuel hat, alarm system) and fuses one by one until you see that current drop. That's should help isolate the problem.


Sent from my iPhone using AutoGuide.com App
Eric:-) is offline  
post #28 of 35 (permalink) Old 11-24-2012, 05:54 PM
PWR - Boosted & Stroked
 
J&D's SRT's's Avatar
 
Join Date: Apr 2010
Posts: 8,565
Thanks: 2,043
Thanked 1,548 Times in 1,212 Posts
Just a thought but you don't have a trinity that you leave in it & its not turning off is it. I think I remember done posts about them draining the battery if they weren't set right.

Jim

J&D's SRT's is offline  
post #29 of 35 (permalink) Old 11-24-2012, 06:57 PM
Major Contributing Member
 
LAFNGA5's Avatar
 
Join Date: Apr 2009
Location: Red Deer, AB Canada
Posts: 1,436
Thanks: 6
Thanked 245 Times in 204 Posts
just a quick idea, did this happen anytime after installing your headlights as well? i ask because on my cavalier with the hids, for some reason it would do its own thing and kick the motor/ballast on for some reason and would kill the battery.

if it just started lately after the fuel hat, i would say that for some reason theres a signal/draw kicking around somewhere.

ive left my jeep for literally MONTHS on end due to work and id show up and could start it with no problem no matter how cold it had been outside.

Tim, you as well as anyone else is more than welcome by the shop or if youve got questions feel free to message/text me anytime


2009 Brilliant Black-Powertrain: TTC 6262 Kit, Stage 6 2Step, Demon Fuel, Wavetrac & Axles, Full Paramount Driveline, Jet 180* Stat & Lock Cap, Borla S:Appearance: DC Headlights, Tinted Tails , Smoothed Moldings, Murdered, Black Reps, CF Venom Hood, Venom Green Brake Calipers, Eibachs
10's Best Be Coming
LAFNGA5 is offline  
post #30 of 35 (permalink) Old 11-25-2012, 11:42 AM Thread Starter
Lifetime Premium Member
 
Tim H Calgary's Avatar
 
Join Date: Jun 2011
Posts: 1,614
Thanks: 653
Thanked 340 Times in 255 Posts
Quote:
Originally Posted by LAFNGAS@TTC View Post
just a quick idea, did this happen anytime after installing your headlights as well? i ask because on my cavalier with the hids, for some reason it would do its own thing and kick the motor/ballast on for some reason and would kill the battery.

if it just started lately after the fuel hat, i would say that for some reason theres a signal/draw kicking around somewhere.

ive left my jeep for literally MONTHS on end due to work and id show up and could start it with no problem no matter how cold it had been outside.

Tim, you as well as anyone else is more than welcome by the shop or if youve got questions feel free to message/text me anytime

Thanks Scott, hopefully it doesn't come to that. She's going back in today. Hopefully this is the last of it!

I do have my OT2 wideband for for my AFR plugged in and I noticed it was litup when I went in the compartment under the steering wheel. I will unplug it going forward. Hilariously I also found a pair of wire strippers!. I opened it and they fell onto my foot lol...

Last edited by Tim H Calgary; 11-25-2012 at 11:46 AM.
Tim H Calgary is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
And the modding continues CentralTexHemi WK1 Interior/Exterior Visual Modifications 38 04-30-2013 11:10 PM
The Build Continues JayZilla WK2 SRT8 General Performance Discussion 8 09-22-2012 03:52 AM
She continues to impress MichaelSRT8 Track Talk 6 09-26-2009 10:37 PM
6.1L continues for 2010? mandan007 WK1 SRT8 General Discussion 43 11-26-2008 02:46 PM
My AAC headlight nightmare continues.... Mango WK1 Lighting Discussion 24 06-22-2007 07:40 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome