TCM problem perhaps? - Page 4 - Cherokee SRT8 Forum
WK1 Troubleshooting / Problems Discussion / Dealer Service If you are having some problems with your Jeep Grand Cherokee SRT8 and need assistance in troubleshooting and diagnosing the problem, this is the proper place to discuss it. Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

Reply
 
LinkBack Thread Tools Display Modes
post #31 of 37 (permalink) Old 11-20-2012, 09:41 PM
Member
 
Dave_MacKinnon's Avatar
 
Join Date: Aug 2009
Location: Burlington, Ontario
Posts: 34
Thanks: 0
Thanked 3 Times in 3 Posts
Well that ain't good news!

Dave MacKinnon
Product Manager - Clarion Canada Inc. - www.clarion.com
Proprietor - Of Sound Mind Labs - www.osmlabs.com
Contributing Editor - Performance Auto & Sound Magazine - www.pasmag.com
Contributing Editor - RPM Motoring Monthly Magazine - www.rpmcanada.ca
2007 GC SRT-8
Dave_MacKinnon is offline  
Sponsored Links
Advertisement
 
post #32 of 37 (permalink) Old 11-20-2012, 10:04 PM
Straight Up Beast SON!!!
 
Knuckles's Avatar
 
Join Date: Oct 2008
Location: Chicagorilla!!
Posts: 17,120
Thanks: 2,910
Thanked 1,229 Times in 992 Posts
Quote:
Originally Posted by Dave_MacKinnon View Post
Well that ain't good news!
Yup.............

Knuckles
Mods: Bwoody CAI/FRI Lil boy Cam/ SW Headers/CORSA exhaust/SLP UD Pulley/Black Ops Autoworks Ported Intake Manny/Built Trans with FTI 3600 stall/ Johan aka Diablotoona Custom Tune
Knuckles is offline  
post #33 of 37 (permalink) Old 11-21-2012, 06:25 AM
Lifetime Premium Member
 
Tim H Calgary's Avatar
 
Join Date: Jun 2011
Posts: 1,614
Thanks: 653
Thanked 340 Times in 255 Posts
Quote:
Originally Posted by Dave_MacKinnon View Post
Well gang.. Today my PLX Wiki 2 showed up, so I was playing with the Palmer Dashcommand app and decided to check and see if here were any codes in the ECU, even though there was no light? Lo and behold, we have a U0404 - Invalid Data from fear shift control module A in there... Guess I know what's wrong.. Any idea what these suckers cost?
factorymoparparts.com Part# 68004143AF

440.00 best deal around. I just replaced mine. Thanks to Hotrodcalvert for saving me some money . Dealership up here wanted 1300.00!!!

PWR 393, Procharged D-1 @ 6 psi.

Last edited by Tim H Calgary; 11-21-2012 at 08:06 AM.
Tim H Calgary is offline  
The Following User Says Thank You to Tim H Calgary For This Useful Post:
hotrodcalvert (11-21-2012)
post #34 of 37 (permalink) Old 11-21-2012, 02:49 PM
Member
 
Dave_MacKinnon's Avatar
 
Join Date: Aug 2009
Location: Burlington, Ontario
Posts: 34
Thanks: 0
Thanked 3 Times in 3 Posts
Yeah, local dealership here in Mississauga was $1100 and change..

Dorman makes a replacement part, looks like the best price is about $275.. I'm going to take mine apart and see what it's problem is first... Does anyone know of cleaning instructions? I have seen other forums make reference to them....
Dave_MacKinnon is offline  
post #35 of 37 (permalink) Old 11-21-2012, 02:59 PM
Lifetime Premium Member
 
Tim H Calgary's Avatar
 
Join Date: Jun 2011
Posts: 1,614
Thanks: 653
Thanked 340 Times in 255 Posts
Quote:
Originally Posted by Dave_MacKinnon View Post
Yeah, local dealership here in Mississauga was $1100 and change..

Dorman makes a replacement part, looks like the best price is about $275.. I'm going to take mine apart and see what it's problem is first... Does anyone know of cleaning instructions? I have seen other forums make reference to them....
http://eugenesklyar.com/2012/09/18/s...dule-jeep-srt8

That's the write up I followed. Cleaning did buy me some time.

Good luck!
Tim H Calgary is offline  
post #36 of 37 (permalink) Old 11-21-2012, 08:05 PM
Member
 
Dave_MacKinnon's Avatar
 
Join Date: Aug 2009
Location: Burlington, Ontario
Posts: 34
Thanks: 0
Thanked 3 Times in 3 Posts
Perfect! Thanks very much Tim.. Just need it to behave until January.. I'll be in Vegas for a week, and I can grab the replacement unit then...
Dave_MacKinnon is offline  
post #37 of 37 (permalink) Old 11-23-2012, 06:10 PM
Member
 
Dave_MacKinnon's Avatar
 
Join Date: Aug 2009
Location: Burlington, Ontario
Posts: 34
Thanks: 0
Thanked 3 Times in 3 Posts
Ok, gave her a cleanup tonight.. Took about 20 minutes...

Definitely some contamination between the slider traces.. I'd say that is likely the problem.. If it happens again, I have a glass fiber brush/eraser at work for prepping circuit board traces for soldering. I'll be making some more aggressive cleaning in between..

Has anyone mentioned that designs with moving parts are destined to fail?
Dave_MacKinnon is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
HID problem :( dirtrcr WK1 Lighting Discussion 9 04-26-2012 10:24 AM
TCM Problem? housemouse100 WK1 Troubleshooting / Problems Discussion / Dealer Service 5 04-25-2012 08:14 AM
Diablo Tuner Problem/tcm Problem SRTB WK1 Troubleshooting / Problems Discussion / Dealer Service 6 08-22-2009 02:28 PM
Big Problem.... frankofiore WK1 Troubleshooting / Problems Discussion / Dealer Service 8 09-05-2008 03:25 PM
I Think I Just May Have A Problem OurZoo WK1 SRT8 General Discussion 29 08-20-2007 03:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome