Free Coolant on road - Cherokee SRT8 Forum
WK1 Troubleshooting / Problems Discussion / Dealer Service If you are having some problems with your Jeep Grand Cherokee SRT8 and need assistance in troubleshooting and diagnosing the problem, this is the proper place to discuss it. Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 09-28-2011, 12:37 PM Thread Starter
Member
 
Join Date: Aug 2009
Location: North East Illinois
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Free Coolant on road

Well I did a launch today at this light right before my house and notice a beautiful and majestic mist in my rear-view....

Limped her home like 30 yards, watching temps and oil pressure, get home and out of the car, pop the hood, find this:
RBisch is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 09-28-2011, 12:39 PM
Elite Contributing Member
 
Marylandm3's Avatar
 
Join Date: Dec 2009
Location: Fallston, Md.
Posts: 8,340
Thanks: 758
Thanked 937 Times in 793 Posts
Damn, sorry to hear it...

Jason
2009 Silver Jeep Srt-8
419 ci with 88mm Precision turbo, Paramount driveline
DTP Racing

RIP RoKDoG

Marylandm3 is offline  
post #3 of 9 (permalink) Old 09-28-2011, 12:58 PM
That guy..
 
Rocky31186's Avatar
 
Join Date: Feb 2011
Location: Columbus, Ohio
Posts: 1,282
Thanks: 31
Thanked 60 Times in 54 Posts
Did that plastic break or did the clamp just slide off? those clamps are junk..

06 GCSRT8
BT Catch Can, K&N Intake - Johan Tooned - Toyo Proxes4 - Eibach Lowering Springs - 6000k HID's - Magnaflow Exhaust - R1 Concepts - FRI Lil Boy 0* - Vortech V3
Rocky31186 is offline  
post #4 of 9 (permalink) Old 09-28-2011, 01:02 PM Thread Starter
Member
 
Join Date: Aug 2009
Location: North East Illinois
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Rocky31186 View Post
Did that plastic break or did the clamp just slide off? those clamps are junk..
Clamp as far as I can tell.. Pretty annoying.
RBisch is offline  
post #5 of 9 (permalink) Old 09-28-2011, 02:49 PM
Major Contributing Member
 
Relwarc's Avatar
 
Join Date: Mar 2010
Location: Baltimore, MD
Posts: 1,847
Thanks: 182
Thanked 363 Times in 237 Posts
This is common apparently... seen it happen a few times.

-Doug '09 Modern Blue SRT8 (SOLD). Antivenom hood, dark tint, first to be officially "Bruised!" Best time: 12.65 @ 107
My Drive SRT owner profile! http://www.drivesrt.com/news/2012/05...-maryland.html
My Project: Bruised and Blown (SOLD )http://www.cherokeesrt8.com/forums/6-wk1-general-performance-discussion/73575-project-bruised-blown.html
Relwarc is offline  
post #6 of 9 (permalink) Old 09-28-2011, 03:01 PM
PWR - Boosted & Stroked
 
J&D's SRT's's Avatar
 
Join Date: Apr 2010
Posts: 8,565
Thanks: 2,043
Thanked 1,548 Times in 1,212 Posts
Another semi common place for them to leak is on the passengers side where they go thru the fire wall.

Jim

J&D's SRT's is offline  
post #7 of 9 (permalink) Old 09-28-2011, 04:17 PM
Lifetime Premium Member
 
LoudPedal's Avatar
 
Join Date: Aug 2009
Location: SoCal
Posts: 1,084
Thanks: 176
Thanked 74 Times in 65 Posts
Garage
Sorry to hear it...good thing you were close to home. Are you gonna do an upgrade or just fix the clamp?

SOLD...07..Black....Tune by Johan, BO's CF, Billet Tech, Bwoody CAI-End Links-Track bar, RM Springs, Mopar Catback, QA1 Shocks, Extreme HIDs.
LoudPedal is offline  
post #8 of 9 (permalink) Old 09-28-2011, 04:38 PM
Senior Contributing Member
 
GlobeWarmer's Avatar
 
Join Date: Jun 2009
Location: Phoenix
Posts: 802
Thanks: 8
Thanked 29 Times in 24 Posts
Had mine do the same thing after some spirited driving with a GTO. I replaced it with a T-bolt hose clamp. Problem free ever since.
GlobeWarmer is offline  
post #9 of 9 (permalink) Old 02-04-2013, 04:00 PM Thread Starter
Member
 
Join Date: Aug 2009
Location: North East Illinois
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Well had this happen again. This time no launch it just slipped off. Managed to get it to the dealer after putting the hose back on and adding coolant. Dealer wanted $300 to replace the upper rad hose and U-joint... I told them no. Old hose, new coolant, $113.00 for the flush. /sigh
RBisch is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Cherokee SRT8 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
coolant leaking from coolant reservoir? pnut WK1 Troubleshooting / Problems Discussion / Dealer Service 6 07-20-2012 09:01 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome